aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpaint/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-09-23 04:39:38 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-09-23 04:39:38 +0000
commit8bce42cf5f8416ebdff6804ba79cccc2806a067e (patch)
treec5a9075aff0e44a3536e64cafbfff2973f649e76 /graphics/xpaint/Makefile
parent5afc4828b2804affdcb33d752154010d78a72b02 (diff)
Notes
Diffstat (limited to 'graphics/xpaint/Makefile')
-rw-r--r--graphics/xpaint/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index 4cea7d4d190e..a46cf1eddd38 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xpaint
PORTVERSION= 2.9.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -12,19 +12,20 @@ COMMENT= Simple paint program
LICENSE= GPLv3
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- openjpeg:${PORTSDIR}/graphics/openjpeg \
- tiff:${PORTSDIR}/graphics/tiff \
- freetype:${PORTSDIR}/print/freetype2 \
- jbig:${PORTSDIR}/graphics/jbigkit \
- Xaw3dxft:${PORTSDIR}/x11-toolkits/libxaw3dxft
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libopenjpeg.so:${PORTSDIR}/graphics/openjpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libjbig.so:${PORTSDIR}/graphics/jbigkit \
+ libXaw3dxft.so:${PORTSDIR}/x11-toolkits/libxaw3dxft
RUN_DEPENDS= psselect:${PORTSDIR}/print/psutils
USE_BZIP2= yes
USE_XORG= xft xmu xpm
USE_AUTOTOOLS= libtool
USE_GHOSTSCRIPT_RUN=yes
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
LDFLAGS+= -L${LOCALBASE}/lib
@@ -39,9 +40,6 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's/-ldl //' \
${WRKSRC}/configure ${WRKSRC}/rw/configure
- @${REINPLACE_CMD} -Ee 's:/etc(/X11/app-defaults):${PREFIX}/lib\1:' \
- -e '/xaw_incdir/s,/usr/include,${LOCALBASE}/include,' \
- ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^LIBTOOL/d' \
-e '/^install-exec-am:/s/install-libLTLIBRARIES//' \
${WRKSRC}/rw/Makefile.in