aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpaint/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-03 21:39:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-03 21:39:28 +0000
commit0f209baf8abf8cfffa369ab3fcabe5dc0e342ba1 (patch)
treef8d8a07f3926bff1d3e1536ea1e73c3aa9ddd604 /graphics/xpaint/Makefile
parent4a90e181c4608f5b4b28d19b5e8be81f5e340fdf (diff)
downloadports-0f209baf8abf8cfffa369ab3fcabe5dc0e342ba1.tar.gz
ports-0f209baf8abf8cfffa369ab3fcabe5dc0e342ba1.zip
Notes
Diffstat (limited to 'graphics/xpaint/Makefile')
-rw-r--r--graphics/xpaint/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index 5415afa1c888..02d3cca39710 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xpaint
-PORTVERSION= 2.7.4
+PORTVERSION= 2.7.6
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ac-grenoble.fr/Office/
@@ -16,17 +16,27 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A simple paint program
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+ tiff.4:${PORTSDIR}/graphics/tiff
USE_BZIP2= yes
USE_IMAKE= yes
USE_XPM= yes
-ALL_TARGET= xaw3d
MAN1= xpaint.1
+CFLAGS+= -DARROW_SCROLLBAR
+
+.if defined(WITH_NEXTAW)
+LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
+ALL_TARGET= nextaw
+XAW_INCDIR= ${X11BASE}/include/X11/neXtaw
+.else
+LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+ALL_TARGET= xaw3d
+XAW_INCDIR= ${X11BASE}/include/X11/Xaw3d
+.endif
+
pre-configure:
- @cd ${WRKSRC} && ${LN} -sf ${X11BASE}/include/X11/Xaw3d xaw_incdir
+ @cd ${WRKSRC} && ${LN} -sf ${XAW_INCDIR} xaw_incdir
.include <bsd.port.mk>