aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpaint
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-02-19 09:40:21 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-02-19 09:40:21 +0000
commit3921593daebd727767697e9f10e9f71886eb7237 (patch)
tree6ba9fe7e94e8c2fffdcc699d261c544bb8084fa1 /graphics/xpaint
parent91c5ed36785fd0fd397b72d56cd8b899cfa5b5a9 (diff)
downloadports-3921593daebd727767697e9f10e9f71886eb7237.tar.gz
ports-3921593daebd727767697e9f10e9f71886eb7237.zip
Notes
Diffstat (limited to 'graphics/xpaint')
-rw-r--r--graphics/xpaint/Makefile32
-rw-r--r--graphics/xpaint/distinfo4
-rw-r--r--graphics/xpaint/files/patch-Imakefile20
-rw-r--r--graphics/xpaint/files/patch-Local.config64
-rw-r--r--graphics/xpaint/files/patch-rw__readWritePNG.c3
-rw-r--r--graphics/xpaint/files/patch-util_Makefile57
-rw-r--r--graphics/xpaint/files/patch-xaw3dgxft__Imakefile15
-rw-r--r--graphics/xpaint/pkg-plist3
8 files changed, 81 insertions, 117 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index ce41aa1139a2..d92872ac208d 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= xpaint
-PORTVERSION= 2.9.8.4
+PORTVERSION= 2.9.9
CATEGORIES= graphics
-MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
+MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= johans@FreeBSD.org
COMMENT= A simple paint program
@@ -16,27 +16,31 @@ COMMENT= A simple paint program
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
openjpeg:${PORTSDIR}/graphics/openjpeg \
- tiff.4:${PORTSDIR}/graphics/tiff
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ jbig.1:${PORTSDIR}/graphics/jbigkit \
+ Xaw3dxft.7:${PORTSDIR}/x11-toolkits/libxaw3dxft
USE_BZIP2= yes
-USE_IMAKE= yes
USE_XORG= xft xmu xpm
+GNU_CONFIGURE= yes
-MAN1= xpaint.1
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ENV+= RM="${RM} -f"
+
+MAN1= xpaint.1 pdfconcat.1 imgmerge.1
post-extract:
- @${MKDIR} ${WRKSRC}/X11
- @${LN} -sf ../xaw3dxft ${WRKSRC}/X11/Xaw3d
+ @${LN} -sf ${LOCALBASE}/include/X11/Xaw3dxft ${WRKSRC}/xaw_incdir
+ @${RM} -f ${WRKSRC}/XPaint.ad
post-patch:
- @${REINPLACE_CMD} -e \
- 's|@PREFIX@|${PREFIX}|g ; \
- s|@XPMDIR@|${LOCALBASE}|g ; \
- s|@LOCALBASE@|${LOCALBASE}|g' ${WRKSRC}/Local.config
+ @${REINPLACE_CMD} -e 's/-ldl //' \
+ ${WRKSRC}/configure ${WRKSRC}/rw/configure
+ @${REINPLACE_CMD} -Ee 's:/etc(/X11/app-defaults):${PREFIX}/lib\1:' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/if (!image)/s/return;/return -1;/' \
${WRKSRC}/rw/readWriteTGA.c
-pre-configure:
- @cd ${WRKSRC} && ${SH} ./configure xaw3dxft.a
-
.include <bsd.port.mk>
diff --git a/graphics/xpaint/distinfo b/graphics/xpaint/distinfo
index 8cc2352d1a3f..f38306df8c45 100644
--- a/graphics/xpaint/distinfo
+++ b/graphics/xpaint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xpaint-2.9.8.4.tar.bz2) = 486280297ecf6787f8a4ce2139d68976cf02365a7acd07d1a4ba2b9bbb3dff9c
-SIZE (xpaint-2.9.8.4.tar.bz2) = 1105272
+SHA256 (xpaint-2.9.9.tar.bz2) = 261a3fe356c2e32609cdb640e0ff8174117d82801290192ad191bdde57cc8696
+SIZE (xpaint-2.9.9.tar.bz2) = 1229047
diff --git a/graphics/xpaint/files/patch-Imakefile b/graphics/xpaint/files/patch-Imakefile
deleted file mode 100644
index a8baddef1925..000000000000
--- a/graphics/xpaint/files/patch-Imakefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- Imakefile.orig 2010-04-07 14:37:45.000000000 +0900
-+++ Imakefile 2010-05-29 14:06:49.000000000 +0900
-@@ -94,7 +94,7 @@
-
- DEPLIBS = always xpaint.man XPaint.ad
-
--#if ! defined(__NetBSD__) && !defined(__FreeBSD__)
-+#if ! defined(NetBSDArchitecture) && !defined(FreeBSDArchitecture)
- LOCAL_LIBRARIES = -Lrw -lrw -ldl -rdynamic \
- $(XPM_LIB) $(XFT_LIB) $(TIFF_LIB) $(SGI_LIB) $(JPEG_LIB) $(PNG_LIB)
- #else
-@@ -237,7 +237,7 @@
- XPAINT_PRINT_COMMAND "$(PRINT_COMMAND)" \
- XPAINT_POSTSCRIPT_VIEWER "$(POSTSCRIPT_VIEWER)" \
- XPAINT_EXTERN_VIEWER "$(EXTERN_VIEWER)"
-- cp -p app-defaults/out/XPaint XPaint.ad
-+ cp -f app-defaults/out/XPaint XPaint.ad
-
- XPaint.ad.h: XPaint.ad
- ./substads -ad2c $? $@
diff --git a/graphics/xpaint/files/patch-Local.config b/graphics/xpaint/files/patch-Local.config
deleted file mode 100644
index 5222c5f238b8..000000000000
--- a/graphics/xpaint/files/patch-Local.config
+++ /dev/null
@@ -1,64 +0,0 @@
---- Local.config.orig 2010-11-07 22:32:05.000000000 +0100
-+++ Local.config 2010-12-28 19:07:55.000000000 +0100
-@@ -20,9 +20,8 @@ XCOMM instead PRINTCAP (or disable it as
- LPCCMD = /usr/sbin/lpc status
- #define LPCCMD
-
--#if defined(__NetBSD__) || defined(__FreeBSD)
--SHAREDIR = @PREFIX@/share/xpaint
--LPCCMD = @PREFIX@/sbin/lpc status
-+#if defined(NetBSDArchitecture) || defined(FreeBSDArchitecture)
-+SHAREDIR = /usr/local/share/xpaint
- #endif
-
- XCOMM Enable/disable PRINTCAP (for BSD style printing configuration)
-@@ -174,22 +173,22 @@ XCOMM #define XawClientLibs -lXaw -Bstat
- XCOMM
-
- XCOMM You must have the freetype2 library.
--XFT_INCLUDE = -I/usr/include/freetype2
--XFT_LIB = -lXft -lfontconfig
-+XFT_INCLUDE = -I. `pkg-config --cflags xft`
-+XFT_LIB = `pkg-config --libs xft`
-
- XCOMM You must have the XPM library.
- XCOMM Make sure the path name to the library is correct.
-
--#if defined(__NetBSD__) || defined(__FreeBSD)
--XPM_LIB = -L@XPMDIR@/lib -Wl,-R@XPMDIR@/lib -lXpm -lX11 -lm -lXmu -lXext
-+#if defined(NetBSDArchitecture) || defined(FreeBSDArchitecture)
-+XPM_LIB = -L/usr/local/lib -Wl,-R/usr/local/lib -lXpm -lX11 -lm -lXmu -lXext
- #else
- XPM_LIB = -L/usr/lib -lXpm -lX11 -lm -lXmu -lXext
- #endif
-
- XCOMM Make sure this points to the location of the 'xpm.h' file.
-
--#if defined(__NetBSD__) || defined(__FreeBSD)
--XPM_INCLUDE = -I@XPMDIR@/include/X11
-+#if defined(NetBSDArchitecture) || defined(FreeBSDArchitecture)
-+XPM_INCLUDE = -I/usr/local/include/X11
- #else
- XPM_INCLUDE = -I/usr/include/X11
- #endif
-@@ -218,12 +217,12 @@ XCOMM CDEBUGFLAGS =
-
- XCOMM This should take care of everything needed for BSD.
-
--#if defined(__NetBSD__) || defined(__FreeBSD__)
--TIFF_INCLUDE = -I@LOCALBASE@/include
--TIFF_LIB = -L@LOCALBASE@/lib -Wl,-R@LOCALBASE@/lib -ltiff
--JPEG_INCLUDE = -I@LOCALBASE@/include
--JPEG_LIB = -L@LOCALBASE@/lib -Wl,-R@LOCALBASE@/lib -ljpeg
--PNG_INCLUDE = -I@LOCALBASE@/include/png
--PNG_LIB = -L@LOCALBASE@/lib -Wl,-R@LOCALBASE@/lib -lpng -lz
--XPM_INCLUDE = -I@XPMDIR@/include/X11
-+#if defined(NetBSDArchitecture) || defined(FreeBSDArchitecture)
-+TIFF_INCLUDE = -I/usr/local/include
-+TIFF_LIB = -L/usr/local/lib -Wl,-R/usr/local/lib -ltiff
-+JPEG_INCLUDE = -I/usr/local/include
-+JPEG_LIB = -L/usr/local/lib -Wl,-R/usr/local/lib -ljpeg
-+PNG_INCLUDE = -I/usr/local/include/png
-+PNG_LIB = -L/usr/local/lib -Wl,-R/usr/local/lib -lpng -lz
-+XPM_INCLUDE = -I/usr/local/include/X11
- #endif
diff --git a/graphics/xpaint/files/patch-rw__readWritePNG.c b/graphics/xpaint/files/patch-rw__readWritePNG.c
index 0cc13ed17279..94ab37daaa64 100644
--- a/graphics/xpaint/files/patch-rw__readWritePNG.c
+++ b/graphics/xpaint/files/patch-rw__readWritePNG.c
@@ -1,6 +1,6 @@
--- rw/readWritePNG.c.orig 2010-05-14 06:24:49.000000000 +0900
+++ rw/readWritePNG.c 2010-06-24 04:56:04.000000000 +0900
-@@ -10,15 +10,14 @@
+@@ -10,16 +10,15 @@
#include <stdlib.h>
#include <png.h>
@@ -12,6 +12,7 @@
#include <X11/Xlib.h>
#include <X11/Intrinsic.h>
#include "xpaint.h"
+ #include "../version.h"
+#include <messages.h>
+#include <image.h>
diff --git a/graphics/xpaint/files/patch-util_Makefile b/graphics/xpaint/files/patch-util_Makefile
new file mode 100644
index 000000000000..21fb62062db7
--- /dev/null
+++ b/graphics/xpaint/files/patch-util_Makefile
@@ -0,0 +1,57 @@
+--- util/Makefile.bak 2012-02-05 15:14:24.000000000 +0100
++++ util/Makefile 2012-02-18 23:14:26.000000000 +0100
+@@ -1,13 +1,11 @@
+-GCC = gcc
+-CPP = g++ -fpermissive
+
+ all: pdfconcat ppmtops pgf2pnm
+
+ pdfconcat:
+- $(GCC) -O3 -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat
++ $(CC) $(CFLAGS) -s -DNDEBUG=1 -DNO_CONFIG=1 -ansi -pedantic -Wunused -Wall -W -Wstrict-prototypes -Wtraditional -Wnested-externs -Winline -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wmissing-prototypes -Wmissing-declarations pdfconcat.c -o pdfconcat
+
+ ppmtops:
+- $(GCC) ppmtops.c -o ppmtops
++ $(CC) $(CFLAGS) ppmtops.c -o ppmtops
+
+ pgf2pnm: main.cpp pnm.cpp
+ @if [ -x /usr/include/libpgf ] ; then \
+@@ -15,25 +13,25 @@
+ $(CPP) -c pnm.cpp -o pnm.o -I/usr/include/libpgf ; \
+ $(CPP) -o pgf2pnm main.o pnm.o -lpgf ; \
+ else \
+- @echo "libpgf not installed !!" ; \
++ echo "libpgf not installed !!" ; \
+ fi
+
+ install:
+ @if [ -x pdfconcat ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c pdfconcat $(DESTDIR)/usr/bin ; \
+- echo "install -c pdfconcat $(DESTDIR)/usr/bin" ; \
+- mkdir -p $(DESTDIR)/usr/share/man/man1 ; \
+- install -c -m 644 pdfconcat.1 $(DESTDIR)/usr/share/man/man1 ; \
+- echo "install -c pdfconcat.1 $(DESTDIR)/usr/share/man/man1" ; fi
++ mkdir -p $(PREFIX)/bin ; \
++ install -c pdfconcat $(PREFIX)/bin ; \
++ echo "install -c pdfconcat $(PREFIX)/bin" ; \
++ mkdir -p $(PREFIX)/man/man1 ; \
++ install -c -m 644 pdfconcat.1 $(PREFIX)/man/man1 ; \
++ echo "install -c pdfconcat.1 $(PREFIX)/man/man1" ; fi
+ @if [ -x ppmtops ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c ppmtops $(DESTDIR)/usr/bin ; \
+- echo "install -c ppmtops $(DESTDIR)/usr/bin" ; fi
++ mkdir -p $(PREFIX)/bin ; \
++ install -c ppmtops $(PREFIX)/bin ; \
++ echo "install -c ppmtops $(PREFIX)/bin" ; fi
+ @if [ -x pgf2pnm ] ; then \
+- mkdir -p $(DESTDIR)/usr/bin ; \
+- install -c pgf2pnm $(DESTDIR)/usr/bin ; \
+- echo "install -c pgf2pnm $(DESTDIR)/usr/bin" ; fi
++ mkdir -p $(PREFIX)/bin ; \
++ install -c pgf2pnm $(PREFIX)/bin ; \
++ echo "install -c pgf2pnm $(PREFIX)/bin" ; fi
+
+ clean:
+ rm -f core *~ *.o pdfconcat ppmtops pgf2pnm
diff --git a/graphics/xpaint/files/patch-xaw3dgxft__Imakefile b/graphics/xpaint/files/patch-xaw3dgxft__Imakefile
deleted file mode 100644
index 67c956f5463d..000000000000
--- a/graphics/xpaint/files/patch-xaw3dgxft__Imakefile
+++ /dev/null
@@ -1,15 +0,0 @@
---- Xaw3dxft/Imakefile.orig 2010-03-13 04:07:59.000000000 +0900
-+++ Xaw3dxft/Imakefile 2010-05-29 13:57:44.000000000 +0900
-@@ -25,10 +25,10 @@
- #define IncSubSubdir Xaw3dxft
-
- XCOMM When building outside an X11 source tree:
--EXTRA_INCLUDES = -I. -I/usr/include/X11/Xft -I/usr/include/freetype2
-+EXTRA_INCLUDES = -I. `pkg-config --cflags xft`
-
- #ifdef SharedXawReqs
--REQUIREDLIBS = SharedXawReqs -lXft
-+REQUIREDLIBS = SharedXawReqs `pkg-config --libs xft`
- #endif
-
-
diff --git a/graphics/xpaint/pkg-plist b/graphics/xpaint/pkg-plist
index b81724981bb3..5c6166b8adfe 100644
--- a/graphics/xpaint/pkg-plist
+++ b/graphics/xpaint/pkg-plist
@@ -1,6 +1,6 @@
-@comment $FreeBSD$
bin/imgmerge
bin/pdfconcat
+bin/ppmtops
bin/xpaint
lib/X11/app-defaults/XPaint
lib/X11/app-defaults/XPaint_es
@@ -108,6 +108,7 @@ lib/X11/app-defaults/XPaint_fr
%%DATADIR%%/include/rc.h
%%DATADIR%%/include/region.h
%%DATADIR%%/include/text.h
+%%DATADIR%%/include/version.h
%%DATADIR%%/include/xpaint.h
%%DATADIR%%/messages/Messages
%%DATADIR%%/messages/Messages_es