aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpdf
diff options
context:
space:
mode:
authorChuck Robey <chuckr@FreeBSD.org>2000-09-04 15:33:43 +0000
committerChuck Robey <chuckr@FreeBSD.org>2000-09-04 15:33:43 +0000
commit8e6a6823e9f24656ebe368c798e3d3169b358f1d (patch)
tree369076b1e46d479118ba220becea4d669c9368f2 /graphics/xpdf
parent3ffc4bda329780941142026d7067374d2481d496 (diff)
downloadports-8e6a6823e9f24656ebe368c798e3d3169b358f1d.tar.gz
ports-8e6a6823e9f24656ebe368c798e3d3169b358f1d.zip
Notes
Diffstat (limited to 'graphics/xpdf')
-rw-r--r--graphics/xpdf/Makefile16
-rw-r--r--graphics/xpdf/distinfo3
-rw-r--r--graphics/xpdf/files/patch-aa46
-rw-r--r--graphics/xpdf/files/patch-ab45
4 files changed, 72 insertions, 38 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index 2f610e020705..7dfacf444093 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -6,20 +6,17 @@
#
PORTNAME= xpdf
-PORTVERSION= 0.90
+PORTVERSION= 0.91
CATEGORIES= graphics print
MASTER_SITES= ${MASTER_SITE_TEX_CTAN} ftp://ftp.foolabs.com/pub/xpdf/ \
ftp://ftp.duke.edu/pub/X11/contrib/applications/
MASTER_SITE_SUBDIR=support/xpdf
EXTRACT_SUFX= .tgz
-PATCH_SITES= http://www.fefe.de/
-PATCHFILES= xpdf-0.90-fefe-diff.gz
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= chuckr@freebsd.org
-LIB_DEPENDS= t1x.1:${PORTSDIR}/devel/t1lib
+LIB_DEPENDS= t1x.1:${PORTSDIR}/devel/t1lib \
+ ttf.4:${PORTSDIR}/print/freetype
### crypto
#.if !defined(PACKAGE_BUILDING)
@@ -29,11 +26,14 @@ USE_XLIB= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_AUTOCONF= yes
-CONFIGURE_ARGS= --with-gzip --enable-japanese \
+CONFIGURE_ARGS= --with-gzip --enable-opi \
+ --enable-japanese --enable-chinese \
--with-t1-library=${LOCALBASE}/lib \
--with-t1-includes=${LOCALBASE}/include \
--with-t1x-library=${LOCALBASE}/lib \
- --with-t1x-includes=${LOCALBASE}/include
+ --with-t1x-includes=${LOCALBASE}/include \
+ --with-freetype-library=${LOCALBASE}/lib \
+ --with-freetype-includes=${LOCALBASE}/include
.if defined(A4)
CONFIGURE_ARGS+= --enable-a4-paper
.endif
diff --git a/graphics/xpdf/distinfo b/graphics/xpdf/distinfo
index 202dc4441dea..d2644fca6c71 100644
--- a/graphics/xpdf/distinfo
+++ b/graphics/xpdf/distinfo
@@ -1,2 +1 @@
-MD5 (xpdf-0.90.tgz) = a7678b64713a466279b61c28ba01134b
-MD5 (xpdf-0.90-fefe-diff.gz) = a2e68bb76b4d7a7bf3c43f5af0ec38c8
+MD5 (xpdf-0.91.tgz) = dd675fe691ba7341f2f581e67d724bcb
diff --git a/graphics/xpdf/files/patch-aa b/graphics/xpdf/files/patch-aa
index 1040aa95eed7..27d0c31e24af 100644
--- a/graphics/xpdf/files/patch-aa
+++ b/graphics/xpdf/files/patch-aa
@@ -1,11 +1,39 @@
---- Makefile.in.orig Tue Aug 3 06:36:22 1999
-+++ Makefile.in Sat Aug 14 04:20:32 1999
-@@ -12,7 +12,7 @@
- exec_prefix = @exec_prefix@
- srcdir = @srcdir@
+--- configure.in.org Fri Sep 1 14:35:10 2000
++++ configure.in Fri Sep 1 14:21:53 2000
+@@ -75,6 +75,7 @@
+ dnl ##### Checks for header files.
+ AC_PATH_XTRA
+ AC_HEADER_DIRENT
++AC_CHECK_HEADERS(unistd.h)
--INSTALL = @INSTALL@
-+INSTALL = @INSTALL_PROGRAM@
- INSTALL_DATA = @INSTALL_DATA@
+ dnl ##### Switch over to C++. This will make the checks below a little
+ dnl ##### bit stricter (requiring function prototypes in include files).
+@@ -173,11 +174,27 @@
+ dnl # include file (e.g., in cygwin 1.1.2).
+ AC_CACHE_CHECK([for mkstemp],
+ xpdf_cv_func_mkstemp,
+-[AC_TRY_COMPILE([#include <stdlib.h>],
++[AC_TRY_COMPILE([#include <stdlib.h>
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif
++],
+ [mkstemp("foo");],
+ xpdf_cv_func_mkstemp=yes, xpdf_cv_func_mkstemp=no)])
+ if test "$xpdf_cv_func_mkstemp" = yes; then
+ AC_DEFINE(HAVE_MKSTEMP)
++fi
++dnl # Ditto mkstemps()
++AC_CACHE_CHECK([for mkstemps],
++xpdf_cv_func_mkstemps,
++[AC_TRY_COMPILE([#include <stdlib.h>
++#ifdef HAVE_UNISTD_H
++#include <unistd.h>
++#endif],
++[mkstemps("foo", 0);],
++xpdf_cv_func_mkstemps=yes, xpdf_cv_func_mkstemps=no)])
++if test "$xpdf_cv_func_mkstemps" = yes; then
++ AC_DEFINE(HAVE_MKSTEMPS)
+ fi
- EXE = @EXE@
+ dnl ##### Check select argument type: on HP-UX before version 10, select
diff --git a/graphics/xpdf/files/patch-ab b/graphics/xpdf/files/patch-ab
index edea0bef7a58..6054622530ce 100644
--- a/graphics/xpdf/files/patch-ab
+++ b/graphics/xpdf/files/patch-ab
@@ -1,20 +1,27 @@
---- configure.in.~1~ Tue Aug 3 13:36:22 1999
-+++ configure.in Thu Nov 18 06:45:50 1999
-@@ -69,6 +69,7 @@
- dnl ##### Checks for header files.
- AC_PATH_XTRA
- AC_HEADER_DIRENT
-+AC_CHECK_HEADERS(unistd.h)
+--- goo/gfile.cc.org Fri Sep 1 14:35:26 2000
++++ goo/gfile.cc Fri Sep 1 14:17:34 2000
+@@ -468,6 +468,16 @@
+ int fd;
- dnl ##### Look for header that defines fd_set.
- AC_MSG_CHECKING([fd_set and sys/select.h or sys/bsdtypes.h])
-@@ -147,6 +148,9 @@
- xpdf_cv_func_select_arg,
- [AC_TRY_COMPILE([#include <sys/types.h>
- #include <sys/time.h>
-+#ifdef HAVE_UNISTD_H
-+#include <unistd.h>
-+#endif
- #ifdef HAVE_SYS_SELECT_H
- #include <sys/select.h>
- #endif],
+ if (ext) {
++# if HAVE_MKSTEMPS
++ if ((s = getenv("TMPDIR"))) {
++ *name = new GString(s);
++ } else {
++ *name = new GString("/tmp");
++ }
++ (*name)->append("/XXXXXX");
++ (*name)->append(ext);
++ fd = mkstemps((*name)->getCString(), strlen(ext));
++# else
+ if (!(s = tmpnam(NULL))) {
+ return gFalse;
+ }
+@@ -478,6 +488,7 @@
+ }
+ (*name)->append(ext);
+ fd = open((*name)->getCString(), O_WRONLY | O_CREAT | O_EXCL, 0600);
++# endif
+ } else {
+ #if HAVE_MKSTEMP
+ if ((s = getenv("TMPDIR"))) {