aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpdf
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
commitf2fc2d60ae226a1b8d5411fb4aab91ea92be6f91 (patch)
treee9a77f53d4fe679665594e718ad34b49668507cc /graphics/xpdf
parent063f8ca62467e4709e58c8bb6b67c85970fe28a1 (diff)
downloadports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.tar.gz
ports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.zip
Notes
Diffstat (limited to 'graphics/xpdf')
-rw-r--r--graphics/xpdf/Makefile23
1 files changed, 22 insertions, 1 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index 9ed2f32ebaaf..a908fe75df6b 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -13,6 +13,20 @@ MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support/xpdf
+.if defined(WANT_ANTIKICK)
+PATCH_SITES= http://www.cs.cmu.edu/~dst/Adobe/Gallery/XPDF/anti-kick/
+PATCHFILES= anti.diff
+#.else
+#PATCH_SITES= http://vzzbx.xs4all.nl/files/ \
+# http://www.cs.cmu.edu/~dst/Adobe/Gallery/
+#PATCHFILES= xpdf-ro-remove.patch
+.endif
+PATCH_DIST_STRIP= -p1
+PATCH_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
+ ${MASTER_SITE_TEX_CTAN}
+PATCH_SITE_SUBDIR= support/xpdf
+PATCHFILES= xpdf-2.01-patch1
+
MAINTAINER= nork@FreeBSD.org
COMMENT= Display PDF files, and convert them to other formats
@@ -26,7 +40,7 @@ USE_MOTIF= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 259
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gzip --enable-opi --with-x \
@@ -37,6 +51,9 @@ CONFIGURE_ARGS= --with-gzip --enable-opi --with-x \
.if defined(A4)
CONFIGURE_ARGS+= --enable-a4-paper
.endif
+.if defined(WANT_ANTIKICK)
+CONFIGURE_ARGS+= --enable-antikick
+.endif
MAN1= pdffonts.1 \
pdfimages.1 \
@@ -56,3 +73,7 @@ post-install:
.endif
.include <bsd.port.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -static
+.endif