aboutsummaryrefslogtreecommitdiff
path: root/graphics/xsane/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-30 03:59:43 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-30 03:59:43 +0000
commit1662f1236682e6bd3a61ed4c90c57deeee3bfa77 (patch)
tree2a13c37a0708a24bd9b3b1e692b5690a1fbe3e67 /graphics/xsane/Makefile
parent9b843103d13d708dd7c76853e063a0272aa1bacf (diff)
downloadports-1662f1236682e6bd3a61ed4c90c57deeee3bfa77.tar.gz
ports-1662f1236682e6bd3a61ed4c90c57deeee3bfa77.zip
Notes
Diffstat (limited to 'graphics/xsane/Makefile')
-rw-r--r--graphics/xsane/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index 443d59ed61c3..0ef246ad15c3 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xsane
PORTVERSION= 0.991
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.xsane.org/download/ \
http://gd.tuwien.ac.at/hci/sane/xsane/ \
@@ -25,19 +25,28 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= xsane.1
#SUB_FILES+= pkg-message
OPTIONS= GTK2 "Enable GTK2 support (use GTK1 if turned off)" on \
- GIMP "Enable GIMP plugin support" off
+ GIMP "Enable GIMP plugin support" off \
+ NLS "Enable Native Language Support" on
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
+.endif
+
.if defined(WITHOUT_GTK2)
USE_GNOME= gtk12
CONFIGURE_ARGS+= --disable-gtk2
@@ -51,7 +60,7 @@ SUB_FILES+= pkg-message
LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp1
CONFIGURE_ARGS+= --disable-gimp2
.else
-LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp
+LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp-app
.endif # WITHOUT_GTK2
.else
CONFIGURE_ARGS+= --disable-gimp
@@ -63,7 +72,7 @@ CONFIGURE_ENV+= CFLAGS="${CFLAGS:C/-O[0-9]*//g}"
pre-patch:
@${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} \
- -i "" -e 's|\$$(sbindir)||g'
+ -i "" -e 's|\$$(DESTDIR)\$$(sbindir)||g'
post-install:
.if defined(WITH_GIMP)