aboutsummaryrefslogtreecommitdiff
path: root/graphics/xsane/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-08-21 04:55:40 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-08-21 04:55:40 +0000
commit7b727544c9fff01c6c97d119069bd95e98ef4088 (patch)
tree6e7dabede7722a6e787d6f50c5fa3add93dfbe48 /graphics/xsane/Makefile
parent5bbac6fe4907f1338f119ed2b9146fd30d208173 (diff)
downloadports-7b727544c9fff01c6c97d119069bd95e98ef4088.tar.gz
ports-7b727544c9fff01c6c97d119069bd95e98ef4088.zip
Notes
Diffstat (limited to 'graphics/xsane/Makefile')
-rw-r--r--graphics/xsane/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index c4589216e076..5a14b64ce9f6 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -22,7 +22,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -37,6 +36,13 @@ CONFIGURE_ARGS+= --enable-gimp
CONFIGURE_ARGS+= --disable-gimp
.endif
+.if defined(WITH_GTK2)
+USE_GNOME= gtk20
+.else
+USE_GNOME= gtk12
+CONFIGURE_ARGS= --disable-gtk2
+.endif
+
pre-everything::
.if !defined(WITH_GIMP)
@${ECHO_MSG} "*** Note: XSane can be built with a standalone"