aboutsummaryrefslogtreecommitdiff
path: root/graphics/xsane
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-05-30 18:41:40 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-05-30 18:41:40 +0000
commitd88f6a56456e441026488e11c21de1cfd0c5c296 (patch)
treeb9f4db1ff927ba5b605d3042a0a8587ffb9b9d98 /graphics/xsane
parent852650af2ed5d640b0f428e4c2b650d707a6c33f (diff)
Notes
Diffstat (limited to 'graphics/xsane')
-rw-r--r--graphics/xsane/Makefile21
-rw-r--r--graphics/xsane/files/patch-src_xsane-save.c (renamed from graphics/xsane/files/patch-xsane-save.c)8
-rw-r--r--graphics/xsane/files/patch-src_xsane.h4
-rw-r--r--graphics/xsane/files/pkg-message.in10
4 files changed, 15 insertions, 28 deletions
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index cb615bed1f5a..f8f2e301167c 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -3,14 +3,15 @@
PORTNAME= xsane
PORTVERSION= 0.999
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://www.xsane.org/download/
MAINTAINER= koalative@gmail.com
COMMENT= Gtk-based X11 frontend for SANE (Scanner Access Now Easy)
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/xsane.COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
@@ -19,13 +20,10 @@ LIB_DEPENDS= libpng.so:graphics/png \
BUILD_DEPENDS= scanimage:graphics/sane-backends
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gmake jpeg pkgconfig
+USES= gmake jpeg localbase:ldflags pkgconfig
USE_GNOME= gtk20 gdkpixbuf2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
PORTDOCS= *.html *.jpg
OPTIONS_DEFINE= DOCS GIMP NLS
@@ -36,19 +34,16 @@ OPTIONS_SUB= yes
GIMP_LIB_DEPENDS= libgimp-2.0.so:graphics/gimp-app
GIMP_CONFIGURE_ENABLE= gimp2 gimp
+GIMP_SUB_FILES= pkg-message
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
NLS_LIBS= -L${LOCALBASE}/lib -lintl
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGIMP}
-SUB_FILES+= pkg-message
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's| $$(DESTDIR)$$(sbindir)||' \
- -e 's|$$(DESTDIR)$$(xsanedocdir)||' ${WRKSRC}/src/Makefile.in
+ -e 's|$${datadir}/sane/xsane/doc|${DOCSDIR}|g' \
+ -e 's|$$(DESTDIR)$$(xsanedocdir)||' \
+ ${WRKSRC}/src/Makefile.in ${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e 's|@POSUB@ doc|@POSUB@|' ${WRKSRC}/Makefile.in
post-install:
diff --git a/graphics/xsane/files/patch-xsane-save.c b/graphics/xsane/files/patch-src_xsane-save.c
index 3113c7308ea3..88f43c35a8d5 100644
--- a/graphics/xsane/files/patch-xsane-save.c
+++ b/graphics/xsane/files/patch-src_xsane-save.c
@@ -1,6 +1,6 @@
---- src/xsane-save.c.orig 2010-11-16 22:06:00.000000000 +0100
-+++ src/xsane-save.c 2012-05-04 07:37:59.000000000 +0200
-@@ -4910,7 +4910,7 @@
+--- src/xsane-save.c.orig 2010-11-16 21:06:00 UTC
++++ src/xsane-save.c
+@@ -4910,7 +4910,7 @@ int xsane_save_png(FILE *outfile, int co
return -1; /* error */
}
@@ -9,7 +9,7 @@
{
snprintf(buf, sizeof(buf), "%s %s", ERR_DURING_SAVE, ERR_LIBPNG);
xsane_back_gtk_error(buf, TRUE);
-@@ -5100,7 +5100,7 @@
+@@ -5100,7 +5100,7 @@ int xsane_save_png_16(FILE *outfile, int
return -1; /* error */
}
diff --git a/graphics/xsane/files/patch-src_xsane.h b/graphics/xsane/files/patch-src_xsane.h
index fd09a5ce2aba..e67588398adf 100644
--- a/graphics/xsane/files/patch-src_xsane.h
+++ b/graphics/xsane/files/patch-src_xsane.h
@@ -1,5 +1,5 @@
---- src/xsane.h.o 2012-10-01 11:12:56.549589382 -0400
-+++ src/xsane.h 2012-10-01 11:12:40.660589178 -0400
+--- src/xsane.h.orig 2013-05-22 21:43:46 UTC
++++ src/xsane.h
@@ -251,7 +251,7 @@
# elif defined(HAVE_OS2_H)
# define DEFAULT_BROWSER "netscape"
diff --git a/graphics/xsane/files/pkg-message.in b/graphics/xsane/files/pkg-message.in
index 21a7a2609564..a2be7039f83e 100644
--- a/graphics/xsane/files/pkg-message.in
+++ b/graphics/xsane/files/pkg-message.in
@@ -1,14 +1,6 @@
-===============================================================================
-
-XSane has been installed.
-
To install XSane as a GIMP plug-in, please type:
ln -sf %%LOCALBASE%%/bin/xsane ~/.gimp-*/plug-ins/xsane
Then run the GIMP, and a new "XSane" menu item should appear in the
-"File -> Acquire" menu. Use this to access your scanner.
-
-Have fun!
-
-===============================================================================
+"File -> Create" menu.