aboutsummaryrefslogtreecommitdiff
path: root/graphics/xv
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-11-27 19:27:27 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-11-27 19:27:27 +0000
commit4842a6ee3ea9d2bd7d9976a9789a488eff2fcebe (patch)
treea59fd114a673820189f7531c78d7d3312ffa64dc /graphics/xv
parent9d88e7853343b918a25ad44d0945ac3208bb595c (diff)
downloadports-4842a6ee3ea9d2bd7d9976a9789a488eff2fcebe.tar.gz
ports-4842a6ee3ea9d2bd7d9976a9789a488eff2fcebe.zip
- use STAGEDIR
- remove option NOMAN - use OPTIONS_DEFINE - merge xv-m17m in xv
Notes
Notes: svn path=/head/; revision=335047
Diffstat (limited to 'graphics/xv')
-rw-r--r--graphics/xv/Makefile75
-rw-r--r--graphics/xv/files/patch-Imakefile2
-rw-r--r--graphics/xv/files/pkg-descr25
-rw-r--r--graphics/xv/pkg-plist5
4 files changed, 67 insertions, 40 deletions
diff --git a/graphics/xv/Makefile b/graphics/xv/Makefile
index 56436d8bffe0..652570f8c5f9 100644
--- a/graphics/xv/Makefile
+++ b/graphics/xv/Makefile
@@ -18,57 +18,54 @@ PATCHFILES= xv-3.10a-enhancements.20070520-20081216.diff
MAINTAINER?= dinoex@FreeBSD.org
COMMENT?= X11 program that displays images of various formats
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff \
- png15:${PORTSDIR}/graphics/png \
- jasper:${PORTSDIR}/graphics/jasper
-
-NO_STAGE= yes
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjasper.so:${PORTSDIR}/graphics/jasper
USES= imake
USE_XORG= xext x11 xt
-.if !defined(NOMAN)
-MAN1= bggen.1 vdcomp.1 xcmap.1 xv.1 xvp2p.1
+
+OPTIONS_DEFINE= M17N
+M17N_DESC= build with Multilingualization support
+
+.include <bsd.port.options.mk>
+
+.if defined(CC) && ${CC:T:Mclang}
+# Optimizer crashes with
+# Assertion failed: (isPtrIV == IndVar->getType()->isPointerTy() && "IndVar type must match IVInit type")
+CFLAGS:= ${CFLAGS:S/-O2//g}
.endif
-XVDIST= ${DISTDIR}/${DIST_SUBDIR}
-CFLAGS+= -I${LOCALBASE}/include/libpng15
+.if ${PORT_OPTIONS:MM17N}
+PKGNAMESUFFIX= -m17n${PKGNAMESUFFIX2}
+MAKE_ENV= LOCALE_EXTENSION=-DTV_MULTILINGUAL
+DESCR= ${FILESDIR}/pkg-descr
+.endif
pre-patch:
- @${PATCH} ${PATCH_ARGS} -p1 < ${WRKDIR}/xv-3.10a-jumbo-fix-enh-patch-20070520.txt
+ ${PATCH} ${PATCH_ARGS} -p1 < ${WRKDIR}/xv-3.10a-jumbo-fix-enh-patch-20070520.txt
post-patch:
- @${MV} ${WRKSRC}/config.h ${WRKSRC}/config.h.in
- @${CAT} ${WRKSRC}/config.h.in | \
- ${SED} -e "s@%%LOCALBASE%%@${LOCALBASE}@" > ${WRKSRC}/config.h
-.for i in ${MAN1}
- @${CP} ${WRKSRC}/docs/${i:R}.man ${WRKSRC}
+ ${REINPLACE_CMD} -e "s@%%LOCALBASE%%@${LOCALBASE}@" \
+ ${WRKSRC}/config.h
+.for i in bggen.1 vdcomp.1 xcmap.1 xv.1 xvp2p.1
+ ${CP} ${WRKSRC}/docs/${i:R}.man ${WRKSRC}
.endfor
-.if defined(NOMAN)
- ${REINPLACE_CMD} -e 's,^InstallManPage.*$$,/\* $$& \*/,' \
- ${WRKSRC}/Imakefile
-.endif
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README.jumbo ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README.pcd ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/epsf.ps ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/xpm.ps ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/xvdocs.ps ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/xvtitle.ps ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/help ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/bmp.doc ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/gif* ${DOCSDIR}
-.endif
-
-
-.if defined(CC) && ${CC:T:Mclang}
-# Optimizer crashes with
-# Assertion failed: (isPtrIV == IndVar->getType()->isPointerTy() && "IndVar type must match IVInit type")
-CFLAGS:= ${CFLAGS:S/-O2//g}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README.jumbo ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README.pcd ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/epsf.ps ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/xpm.ps ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/xvdocs.ps ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/xvtitle.ps ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/help ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/bmp.doc ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/gif* ${STAGEDIR}${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/graphics/xv/files/patch-Imakefile b/graphics/xv/files/patch-Imakefile
index dfdd490eb661..b7af2593dce0 100644
--- a/graphics/xv/files/patch-Imakefile
+++ b/graphics/xv/files/patch-Imakefile
@@ -51,7 +51,7 @@
#endif
+PNG = -DDOPNG
-+PNGINC = -I${LOCALBASE}/include
++PNGINC = -I${LOCALBASE}/include/libpng15
+PNGLIB = -L${LOCALBASE}/lib -lpng
+
+JP2K = -DDOJP2K
diff --git a/graphics/xv/files/pkg-descr b/graphics/xv/files/pkg-descr
new file mode 100644
index 000000000000..8e4c66de9142
--- /dev/null
+++ b/graphics/xv/files/pkg-descr
@@ -0,0 +1,25 @@
+Xv is an X11 program that displays images in the GIF,
+JPEG, TIFF, PBM, PGM, PPM, X11 bitmap, Utah Raster Toolkit
+RLE, PDS/VICAR, Sun Rasterfile, BMP, XPM, PCX, IRIS RGB,
+possibly PostScript, Portable Networking Format(PNG) and
+PM formats on workstations and terminals running the
+X Window System, Version 11.
+And more xv japanese extensions patch supports images in
+the MAKI, MAG, PIC, Pi PIC2, PhotoCD. And this patch also
+supports archived image files. Supported archivers are
+arc, arj, lzh, tar, tar+compress, tar+gzip, tar+bzip2, zip,
+and zoo.
+
+Note that this program is shareware except for personal use only.
+Please read the documentation in the directory
+ /usr/local/share/doc/xv
+for proper usage.
+
+And this xv supports multilingual character codes.
+These codes are as follow:
+ plain iso-8859-1 iso-2022-jp
+ euc-japan iso-2022-int-1 iso-2022-kr
+ euc-korea iso-2022-ss2-8 iso-2022-ss2-7
+ Shift JIS
+
+LICENSE: shareware, free for personal use
diff --git a/graphics/xv/pkg-plist b/graphics/xv/pkg-plist
index 4ac998dd2a5f..44c68ff1188b 100644
--- a/graphics/xv/pkg-plist
+++ b/graphics/xv/pkg-plist
@@ -4,6 +4,11 @@ bin/vdcomp
bin/xcmap
bin/xvpictoppm
lib/X11/xv_mgcsfx.sample
+man/man1/bggen.1.gz
+man/man1/vdcomp.1.gz
+man/man1/xcmap.1.gz
+man/man1/xv.1.gz
+man/man1/xvp2p.1.gz
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.jumbo
%%PORTDOCS%%%%DOCSDIR%%/README.pcd