aboutsummaryrefslogtreecommitdiff
path: root/graphics/xv
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-12-02 18:17:46 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-12-02 18:17:46 +0000
commitb891984286bdc026692cf1aa92ca4b1f3e94dec2 (patch)
treeeb9c21aa14995d29bcb0575649d75c3013c9d1da /graphics/xv
parent423f6e98ed3f7ca50452081c93692f834ec0492f (diff)
downloadports-b891984286bdc026692cf1aa92ca4b1f3e94dec2.tar.gz
ports-b891984286bdc026692cf1aa92ca4b1f3e94dec2.zip
- fix build with clang by disabling optimisation
Feature safe: yes
Notes
Notes: svn path=/head/; revision=286777
Diffstat (limited to 'graphics/xv')
-rw-r--r--graphics/xv/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/graphics/xv/Makefile b/graphics/xv/Makefile
index 1ada7d3aad68..dcc646e89fd5 100644
--- a/graphics/xv/Makefile
+++ b/graphics/xv/Makefile
@@ -65,4 +65,11 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/docs/gif* ${DOCSDIR}
.endif
+
+.if defined(CC) && ${CC} == "clang"
+# Optimizer crashes with
+# Assertion failed: (isPtrIV == IndVar->getType()->isPointerTy() && "IndVar type must match IVInit type")
+CFLAGS:= ${CFLAGS:S/-O2//g}
+.endif
+
.include <bsd.port.mk>