aboutsummaryrefslogtreecommitdiff
path: root/graphics/yafray
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-29 09:32:53 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-29 09:32:53 +0000
commitf31498515d3a171369d31817e75a99921a137f55 (patch)
tree7161e3a29f49fecc99c62efbe802780c6440ed7c /graphics/yafray
parentabf659f86d5465570f4e6d8a3ab23f7ab7944c32 (diff)
downloadports-f31498515d3a171369d31817e75a99921a137f55.tar.gz
ports-f31498515d3a171369d31817e75a99921a137f55.zip
Notes
Diffstat (limited to 'graphics/yafray')
-rw-r--r--graphics/yafray/Makefile19
-rw-r--r--graphics/yafray/files/patch-SConstruct8
-rw-r--r--graphics/yafray/files/patch-freebsd-settings.py21
3 files changed, 31 insertions, 17 deletions
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index 653eb4e76e7e..48d4d2564933 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -9,23 +9,26 @@ MASTER_SITES= http://freebsd.nsu.ru/distfiles/ \
#http://www.yafaray.org/sites/default/files/download/builds/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A fast XML based raytracer
+COMMENT= Fast XML based raytracer
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
USES= scons
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
pre-patch:
@${MV} ${WRKSRC}/linux-settings.py ${WRKSRC}/freebsd-settings.py
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ -e 's|%%CXXFLAGS%%|${CXXFLAGS}|' \
+ ${WRKSRC}/freebsd-settings.py
-.if ${OSVERSION} >= 1000000
-BROKEN= does not build
-.endif
+do-install:
+ (cd ${WRKSRC} && ${MAKE_CMD} prefix=${STAGEDIR}${PREFIX} install)
+ (cd ${STAGEDIR}${PREFIX} && ${STRIP_CMD} bin/${PORTNAME} \
+ lib/*.so lib/yafray/*.so)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/yafray/files/patch-SConstruct b/graphics/yafray/files/patch-SConstruct
index fade40439216..c0e7d2522baf 100644
--- a/graphics/yafray/files/patch-SConstruct
+++ b/graphics/yafray/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2006-06-20 21:24:00.000000000 +0400
-+++ SConstruct 2009-11-04 20:56:07.000000000 +0300
-@@ -8,6 +8,11 @@
+--- SConstruct.orig 2006-06-20 19:24:00.000000000 +0200
++++ SConstruct 2014-04-28 22:26:00.000000000 +0200
+@@ -8,6 +8,13 @@
ficheros = {
'darwin' : 'darwin-settings',
'linux2' : 'linux-settings',
@@ -9,6 +9,8 @@
+'freebsd7' : 'freebsd-settings',
+'freebsd8' : 'freebsd-settings',
+'freebsd9' : 'freebsd-settings',
++'freebsd10' : 'freebsd-settings',
++'freebsd11' : 'freebsd-settings',
'win32' : 'win32-settings',
'sunos5' : 'sunos5-settings'
}
diff --git a/graphics/yafray/files/patch-freebsd-settings.py b/graphics/yafray/files/patch-freebsd-settings.py
index 454943db3bb7..9f39a7456510 100644
--- a/graphics/yafray/files/patch-freebsd-settings.py
+++ b/graphics/yafray/files/patch-freebsd-settings.py
@@ -1,13 +1,22 @@
---- freebsd-settings.py.orig Sat Sep 23 00:21:17 2006
-+++ freebsd-settings.py Sat Sep 23 00:21:29 2006
+--- freebsd-settings.py.orig 2006-07-14 12:14:52.000000000 +0200
++++ freebsd-settings.py 2014-04-29 10:49:21.918250680 +0200
@@ -10,6 +10,7 @@
global prefix
prefix = args.get('prefix','/usr/local')
-+def get_include(args): return prefix+"/usr/local/include"
++def get_include(args): return "%%LOCALBASE%%/include"
def get_libpath(args): return prefix+"/lib"
def get_pluginpath(args): return prefix+"/lib/yafray"
def get_binpath(args): return prefix+"/bin"
+@@ -22,7 +23,7 @@
+ if debug:
+ flags+=' -O3 -ffast-math -ggdb'
+ else:
+- flags+=' -O3 -ffast-math -fomit-frame-pointer'
++ flags+=' %%CXXFLAGS%%'
+ if arch!='':
+ flags+=' -march='+arch
+ if tune!='':
@@ -46,9 +47,9 @@
class jpeg(globalinfo.library):
C_ID = 'JPEG'
@@ -15,9 +24,9 @@
- def present(args): return os.path.exists("/usr/include/jpeglib.h")
- def get_include(args): return []
- def get_libpath(args): return []
-+ def present(args): return os.path.exists("/usr/local/include/jpeglib.h")
-+ def get_include(args): return ['/usr/local/include']
-+ def get_libpath(args): return ['/usr/local/lib']
++ def present(args): return os.path.exists("%%LOCALBASE%%/include/jpeglib.h")
++ def get_include(args): return ['%%LOCALBASE%%/include']
++ def get_libpath(args): return ['%%LOCALBASE%%/lib']
def get_libs(args): return ['jpeg']
class pthread(globalinfo.library):