aboutsummaryrefslogtreecommitdiff
path: root/graphics/yafray
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-21 11:21:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-21 11:21:19 +0000
commit44b012cb4338a60d9a240e2b675716cee62bb425 (patch)
tree0fa74f2786127322edbaacb38fdf108dfdc4b4a7 /graphics/yafray
parent75540bed23d4732ed6c0d9ead14a1bb2254413b3 (diff)
downloadports-44b012cb4338a60d9a240e2b675716cee62bb425.tar.gz
ports-44b012cb4338a60d9a240e2b675716cee62bb425.zip
Notes
Diffstat (limited to 'graphics/yafray')
-rw-r--r--graphics/yafray/Makefile36
-rw-r--r--graphics/yafray/distinfo3
-rw-r--r--graphics/yafray/pkg-plist20
3 files changed, 48 insertions, 11 deletions
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index 6511e2acef6f..bbe6fdc8ca49 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -5,9 +5,10 @@
# $FreeBSD$
PORTNAME= yafray
-PORTVERSION= 0.0.4
+PORTVERSION= 0.0.6
CATEGORIES= graphics
MASTER_SITES= http://www.coala.uniovi.es/~jandro/noname/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-2
MAINTAINER= dyeske@yahoo.com
COMMENT= A fast XML based raytracer
@@ -17,6 +18,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=13
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -31,16 +33,32 @@ pre-everything::
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
.endif
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|' \
- ${WRKSRC}/configure
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} <= 500000
+BROKEN= "Does not compile (bad C++ code)"
+.endif
- @${REINPLACE_CMD} -E -e \
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | \
+ ${XARGS} ${REINPLACE_CMD} -E -e \
's|^CXX =.+$$|CXX=${CXX}|; \
s|-O3||; \
+ s|-D_PTHREADS||; \
+ s|-pthread|-lpthread|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g; \
s|-ffast-math||; \
- s|-Wall|${CXXFLAGS}|' \
- ${WRKSRC}/src/Makefile.in
+ s|-ldl||; \
+ s|-Wall|${CXXFLAGS}|'
+
+ @${FIND} ${WRKSRC} -name "configure.in" \
+ -or -name "configure" | ${XARGS} \
+ ${REINPLACE_CMD} -E -e \
+ 's|-pthread|-lpthread|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g'
+
+#make sure we don't need to run auto****
+ @${TOUCH} ${TOUCH_FLAGS} -t 199705212205.21 \
+ ${WRKSRC}/configure.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/yafray/distinfo b/graphics/yafray/distinfo
index 84e2693c2819..ae66945339c9 100644
--- a/graphics/yafray/distinfo
+++ b/graphics/yafray/distinfo
@@ -1 +1,2 @@
-MD5 (yafray-0.0.4.tar.gz) = 77186ea4afb14c36416781b96e2af0f5
+MD5 (yafray-0.0.6-2.tar.gz) = bf87b6018435f3bc5bfd1be598c1a28f
+SIZE (yafray-0.0.6-2.tar.gz) = 498452
diff --git a/graphics/yafray/pkg-plist b/graphics/yafray/pkg-plist
index 5c19046299db..f497c24ef630 100644
--- a/graphics/yafray/pkg-plist
+++ b/graphics/yafray/pkg-plist
@@ -1,3 +1,21 @@
bin/yafray
etc/gram.yafray
-lib/libyafray.so
+lib/libyafraycore.so
+lib/libyafrayplugin.so
+lib/yafray/libpathlight.so
+lib/yafray/libsunlight.so
+lib/yafray/libpointlight.so
+lib/yafray/libphotonlight.so
+lib/yafray/libhemilight.so
+lib/yafray/libspotlight.so
+lib/yafray/libsoftlight.so
+lib/yafray/libarealight.so
+lib/yafray/libglobalphotonlight.so
+lib/yafray/libspherelight.so
+lib/yafray/libbasicshaders.so
+lib/yafray/libbasicblocks.so
+lib/yafray/libmixblocks.so
+lib/yafray/libblendershader.so
+lib/yafray/libhdri.so
+lib/yafray/libsunsky.so
+@dirrm lib/yafray