aboutsummaryrefslogtreecommitdiff
path: root/graphics/yagf
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2012-12-15 09:50:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2012-12-15 09:50:39 +0000
commit4c0abf9be022150a2be922c0541c9b067f9dae52 (patch)
tree8779331123f3a78f045569250b5799a364a0352d /graphics/yagf
parent24be9b1328d4cae6130b9529f08263afba082c1e (diff)
downloadports-4c0abf9be022150a2be922c0541c9b067f9dae52.tar.gz
ports-4c0abf9be022150a2be922c0541c9b067f9dae52.zip
Notes
Diffstat (limited to 'graphics/yagf')
-rw-r--r--graphics/yagf/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/graphics/yagf/Makefile b/graphics/yagf/Makefile
index f041f9dbbfed..99a0e9ce3e6b 100644
--- a/graphics/yagf/Makefile
+++ b/graphics/yagf/Makefile
@@ -3,16 +3,24 @@
PORTNAME= yagf
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://symmetrica.net/cuneiform-linux/
MAINTAINER= bsam@FreeBSD.org
-COMMENT= Graphical interface for the cuneiform OCR program
+COMMENT= Graphical interface for an OCR program (cuneiform and tesseract)
LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
ONLY_FOR_ARCHS= i386 amd64
+OPTIONS_MULTI= OCRENGINE
+OPTIONS_MULTI_OCRENGINE=CUNEIFORM TESSERACT
+CUNEIFORM_DESC= Cuneiform OCR engine
+TESSERACT_DESC= Tesseract OCR engine
+
+OPTIONS_DEFAULT= CUNEIFORM
+
USE_CMAKE= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
@@ -27,4 +35,13 @@ CFLAGS+= -I${LOCALBASE}/include
post-install:
-update-desktop-database
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCUNEIFORM}
+RUN_DEPENDS+= cuneiform:${PORTSDIR}/graphics/cuneiform
+.endif
+.if ${PORT_OPTIONS:MTESSERACT}
+RUN_DEPENDS+= tesseract:${PORTSDIR}/graphics/tesseract
+.endif
+
.include <bsd.port.mk>