aboutsummaryrefslogtreecommitdiff
path: root/graphics/yukon
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2010-01-14 19:12:18 +0000
committerBruce M Simpson <bms@FreeBSD.org>2010-01-14 19:12:18 +0000
commit502e16914534a201c7adc8ac97eccfbad446fd6c (patch)
treea292658ae5de74877ba60ca58b8f04a38177331c /graphics/yukon
parent351b7b50fe2297e131af61783e6b72c9374c5f70 (diff)
downloadports-502e16914534a201c7adc8ac97eccfbad446fd6c.tar.gz
ports-502e16914534a201c7adc8ac97eccfbad446fd6c.zip
Notes
Diffstat (limited to 'graphics/yukon')
-rw-r--r--graphics/yukon/Makefile80
-rw-r--r--graphics/yukon/distinfo3
-rw-r--r--graphics/yukon/files/patch-Makefile53
-rw-r--r--graphics/yukon/files/patch-include::yukon.h16
-rw-r--r--graphics/yukon/pkg-descr9
-rw-r--r--graphics/yukon/pkg-plist11
6 files changed, 172 insertions, 0 deletions
diff --git a/graphics/yukon/Makefile b/graphics/yukon/Makefile
new file mode 100644
index 000000000000..820eea8de796
--- /dev/null
+++ b/graphics/yukon/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: yukon
+# Date created: 12th January 2010
+# Whom: bms
+#
+# $FreeBSD$
+#
+# TODO: roll svn tarball, add patches with sedification.
+
+PORTNAME= yukon
+PORTVERSION= 2010011201
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= bms
+DISTNAME= yukon-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Real-time capture tool for OpenGL applications
+
+BUILD_DEPENDS= ${LOCALBASE}/include/seom/seom.h:${PORTSDIR}/graphics/seom
+LIB_DEPENDS= seom.0:${PORTSDIR}/graphics/seom
+
+NOMAN= defined
+
+USE_BZIP2= yes
+USE_GCC= 4.2+
+USE_GMAKE= yes
+USE_XORG= x11 xv
+USE_GL= yes
+USE_LDCONFIG= ${PREFIX}/lib/yukon
+
+MAKE_JOBS_SAFE= defined
+
+# NOTE: These should be bumped if the underlying GL or Xorg ports change.
+LIBGL_MAJOR= 1
+LIBX11_MAJOR= 6
+
+MAKE_ENV+= LIBGL_MAJOR="${LIBGL_MAJOR}" LIBX11_MAJOR="${LIBX11_MAJOR}"
+PLIST_SUB+= LIBGL_MAJOR="${LIBGL_MAJOR}" LIBX11_MAJOR="${LIBX11_MAJOR}"
+
+#
+# To roll snapshot: as bms: make BOOTSTRAP=defined fetch
+#
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+SVN_REV= 158 # svn tip at epoch 2009120801
+SVNROOT_URI= https://devel.neopsis.com/svn/yukon
+
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} ${SVNROOT_URI}/trunk ${WRKSRC}
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+.if ${USER} == bms
+ ${CHMOD} ugo+r ${DISTDIR}/${DISTNAME}.tar.bz2
+ scp -p ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif # defined(BOOTSTRAP)
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/etc/yukon,${PREFIX}/etc/yukon,' \
+ ${WRKSRC}/src/core/conf.c ${WRKSRC}/src/scripts/yukon
+
+do-install:
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+ @(${MKDIR} ${PREFIX}/etc/yukon/system)
+ @(${PRINTF} >> ${TMPDIR}/yukon-system-conf \
+ 'LDPATH="%s"\n' ${PREFIX}/lib/yukon)
+ @(${INSTALL_DATA} ${TMPDIR}/yukon-system-conf \
+ ${PREFIX}/etc/yukon/system/default)
+ @(${INSTALL_DATA} ${WRKSRC}/tools/yukon.conf \
+ ${PREFIX}/etc/yukon/conf.sample)
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+IGNORE= unsupported on FreeBSD versions prior to 7.0
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/yukon/distinfo b/graphics/yukon/distinfo
new file mode 100644
index 000000000000..77be5ff04a73
--- /dev/null
+++ b/graphics/yukon/distinfo
@@ -0,0 +1,3 @@
+MD5 (yukon-2010011201.tar.bz2) = 46bdbd061e9c0fe26cf97e0a0544023e
+SHA256 (yukon-2010011201.tar.bz2) = 8e261dfe86c762912b9d1a577909c77a01b0877d4ac86bde0ba1c6b7901a3bdd
+SIZE (yukon-2010011201.tar.bz2) = 13388
diff --git a/graphics/yukon/files/patch-Makefile b/graphics/yukon/files/patch-Makefile
new file mode 100644
index 000000000000..657c2a34e73e
--- /dev/null
+++ b/graphics/yukon/files/patch-Makefile
@@ -0,0 +1,53 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 158)
++++ Makefile (working copy)
+@@ -1,15 +1,14 @@
+
+ DESTDIR =
+-PREFIX = /usr/local
+ LIBDIR = lib
+
+ CC = gcc
+-CFLAGS = -Iinclude -Wall -std=c99 -O3
++CFLAGS = -I${PWD}/include -Wall -std=c99 -O3 -I$(LOCALBASE)/include -L$(LOCALBASE)/lib
+
+ OBJS = src/core/conf.o src/core/glue.o src/core/log.o
+ LIBS = libX11.so libGL.so
+
+--include config.make
++###-include config.make
+
+ .PHONY: all clean install
+ all: $(LIBS) yukon-core-lib sysconf
+@@ -23,20 +22,25 @@
+ rm -f $@.native
+
+ yukon-core-lib: $(OBJS)
+- $(CC) -shared -o $@ $(OBJS) -lseom
++ $(CC) -shared -o $@ $(OBJS) -lseom -L${LOCALBASE}/lib
+
+ sysconf:
+ echo 'LDPATH="$(PREFIX)/$(LIBDIR)/yukon"' > $@
+
+-soname = `objdump -x /usr/$(LIBDIR)/$(1) | grep SONAME | awk '{ print $$2 }'`
++soname = `objdump -x $(PREFIX)/$(LIBDIR)/$(1) | grep SONAME | awk '{ print $$2 }'`
+ install: $(LIBS) yukon-core-lib
+ install -m 755 -d $(DESTDIR)$(PREFIX)/bin $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon
+ install -m 755 src/scripts/yukon $(DESTDIR)$(PREFIX)/bin
+ install -m 755 yukon-core-lib $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon
++ ln -sf $(LOCALBASE)/lib/libX11.so.$(LIBX11_MAJOR) \
++ $(PREFIX)/$(LIBDIR)/yukon/libX11.so.native
++ ln -sf $(LOCALBASE)/lib/libGL.so.$(LIBGL_MAJOR) \
++ $(PREFIX)/$(LIBDIR)/yukon/libGL.so.native
++ install -m 755 libX11.so \
++ $(PREFIX)/$(LIBDIR)/yukon/libX11.so.$(LIBX11_MAJOR)
++ install -m 755 libGL.so \
++ $(PREFIX)/$(LIBDIR)/yukon/libGL.so.$(LIBGL_MAJOR)
+
+- $(foreach lib,$(LIBS),ln -sf /usr/$(LIBDIR)/$(lib) $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/$(lib).native;)
+- $(foreach lib,$(LIBS),install -m 755 $(lib) $(DESTDIR)$(PREFIX)/$(LIBDIR)/yukon/$(call soname,$(lib));)
+-
+ clean:
+ rm -f $(OBJS) $(LIBS) yukon-core-lib sysconf
+
diff --git a/graphics/yukon/files/patch-include::yukon.h b/graphics/yukon/files/patch-include::yukon.h
new file mode 100644
index 000000000000..1920c4cc5984
--- /dev/null
+++ b/graphics/yukon/files/patch-include::yukon.h
@@ -0,0 +1,16 @@
+Index: include/yukon.h
+===================================================================
+--- include/yukon.h (revision 158)
++++ include/yukon.h (working copy)
+@@ -2,8 +2,10 @@
+ #ifndef __YUKON_H__
+ #define __YUKON_H__
+
++#include <sys/param.h>
++#include <sys/limits.h>
++
+ #include <stdarg.h>
+-#include <linux/limits.h>
+
+ #include <seom/seom.h>
+
diff --git a/graphics/yukon/pkg-descr b/graphics/yukon/pkg-descr
new file mode 100644
index 000000000000..89ad3b124418
--- /dev/null
+++ b/graphics/yukon/pkg-descr
@@ -0,0 +1,9 @@
+Yukon is a set of libraries and applications that are designed to
+capture realtime videos of OpenGL applications (games). The original
+design idea is based on Anandtech's FrameGetter, but was extended
+to suit today's high-performance computers.
+
+WWW: https://devel.neopsis.com/projects/yukon/
+
+Bruce
+bms@FreeBSD.org
diff --git a/graphics/yukon/pkg-plist b/graphics/yukon/pkg-plist
new file mode 100644
index 000000000000..a621accdf42d
--- /dev/null
+++ b/graphics/yukon/pkg-plist
@@ -0,0 +1,11 @@
+bin/yukon
+etc/yukon/conf.sample
+etc/yukon/system/default
+lib/yukon/libGL.so.%%LIBGL_MAJOR%%
+lib/yukon/libGL.so.native
+lib/yukon/libX11.so.%%LIBX11_MAJOR%%
+lib/yukon/libX11.so.native
+lib/yukon/yukon-core-lib
+@dirrm etc/yukon/system
+@dirrm etc/yukon
+@dirrm lib/yukon