aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura/Makefile
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2010-07-05 17:36:12 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2010-07-05 17:36:12 +0000
commitb82911f54a20e9384ff5df88b2440f99345f3d4c (patch)
treee92875a1569b86a0dd0a9815f3bfa97a73af05ed /graphics/zathura/Makefile
parentd9a265927e46545ad283f4b863bd08f0e98fa492 (diff)
Notes
Diffstat (limited to 'graphics/zathura/Makefile')
-rw-r--r--graphics/zathura/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
new file mode 100644
index 000000000000..ca05d2d52b8f
--- /dev/null
+++ b/graphics/zathura/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: zathura
+# Date created: 29 June 2010
+# Whom: Quentin Stievenart <acieroid@awesom.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zathura
+PORTVERSION= 0.0.7
+CATEGORIES= graphics print
+MASTER_SITES= http://pwmt.org/zathura/download/
+
+MAINTAINER= acieroid@awesom.eu
+COMMENT= Customizable lightweight pdf viewer
+
+LIB_DEPENDS= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk \
+ cairo.2:${PORTSDIR}/graphics/cairo
+
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20
+MAN1= zathura.1
+MANCOMPRESSED= no
+PLIST_FILES= bin/zathura
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|man1|man/man1|g' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>