aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-07-04 20:00:46 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-07-04 20:00:46 +0000
commit587e759280c83fd427599925785e548b31f59549 (patch)
treef9d8c5852dd1f2f9cbd599edbef6beb12addcf91 /graphics/zathura
parent1b058b37a5f00b9786db276d2067b6233dbc9e57 (diff)
downloadports-587e759280c83fd427599925785e548b31f59549.tar.gz
ports-587e759280c83fd427599925785e548b31f59549.zip
Notes
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile2
-rw-r--r--graphics/zathura/distinfo5
-rw-r--r--graphics/zathura/files/patch-zathura_main.c36
3 files changed, 4 insertions, 39 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 133032de4534..044f2c325d2d 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zathura
-PORTVERSION= 0.3.4
+PORTVERSION= 0.3.6
CATEGORIES= graphics print
MASTER_SITES= http://pwmt.org/projects/zathura/download/
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index 02a1670a345d..64b8f76e0039 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,2 +1,3 @@
-SHA256 (zathura-0.3.4.tar.gz) = 52c4a3efc5843ce7c720ea7357667699363c809fd34ada4cb350d0e1031d0234
-SIZE (zathura-0.3.4.tar.gz) = 167584
+TIMESTAMP = 1463993050
+SHA256 (zathura-0.3.6.tar.gz) = 086a8be25d538fc6539fbee8f01ecf16d25819dfaad50cd2dbd84e30152ccb3b
+SIZE (zathura-0.3.6.tar.gz) = 169560
diff --git a/graphics/zathura/files/patch-zathura_main.c b/graphics/zathura/files/patch-zathura_main.c
deleted file mode 100644
index 36378fabc64a..000000000000
--- a/graphics/zathura/files/patch-zathura_main.c
+++ /dev/null
@@ -1,36 +0,0 @@
---- zathura/main.c.orig 2015-12-21 10:19:18 UTC
-+++ zathura/main.c
-@@ -85,10 +85,13 @@ run_synctex_forward(const char* synctex_
- static zathura_t*
- init_zathura(const char* config_dir, const char* data_dir,
- const char* cache_dir, const char* plugin_path, char** argv,
-+#ifdef WITH_SYNCTEX
-+ char* synctex_editor,
-+#endif
- #ifdef GDK_WINDOWING_X11
-- char* synctex_editor, Window embed)
-+ Window embed)
- #else
-- char* synctex_editor)
-+ )
- #endif
- {
- /* create zathura session */
-@@ -249,11 +252,14 @@ main(int argc, char* argv[])
- gtk_init(&argc, &argv);
-
- /* Create zathura session */
-- zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir,
-+ zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir, plugin_path, argv,
-+#ifdef WITH_SYNCTEX
-+ synctex_editor,
-+#endif
- #ifdef GDK_WINDOWING_X11
-- plugin_path, argv, synctex_editor, embed);
-+ embed);
- #else
-- plugin_path, argv, synctex_editor);
-+ );
- #endif
- if (zathura == NULL) {
- girara_error("Could not initialize zathura.");