aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-05-18 20:11:35 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-05-18 20:11:35 +0000
commitb30b0f9ce7ca65e309da6725bc059344fefcd6ba (patch)
tree883e315dd9d737880ef42f6c0d0ff52603b0d002 /graphics/zathura
parent1b4a79f6a156e1e074a880294dd264657fa6d622 (diff)
downloadports-b30b0f9ce7ca65e309da6725bc059344fefcd6ba.tar.gz
ports-b30b0f9ce7ca65e309da6725bc059344fefcd6ba.zip
Notes
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile52
-rw-r--r--graphics/zathura/distinfo4
-rw-r--r--graphics/zathura/files/patch-document.c10
-rw-r--r--graphics/zathura/pkg-message8
-rw-r--r--graphics/zathura/pkg-plist10
5 files changed, 59 insertions, 25 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index fd9d08b97f1f..8e86e6715832 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -6,54 +6,60 @@
#
PORTNAME= zathura
-PORTVERSION= 0.0.8.4
-PORTREVISION= 2
+PORTVERSION= 0.1.2
CATEGORIES= graphics print
-MASTER_SITES= http://pwmt.org/download/
+MASTER_SITES= http://pwmt.org/projects/zathura/download/
MAINTAINER= acieroid@awesom.eu
COMMENT= Customizable lightweight pdf viewer
LIB_DEPENDS= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib \
- cairo.2:${PORTSDIR}/graphics/cairo
+ cairo.2:${PORTSDIR}/graphics/cairo \
+ girara-gtk2.0:${PORTSDIR}/x11-toolkits/girara
USE_GNOME= glib20 gtk20
+USE_GMAKE= yes
FETCH_ARGS= -Fpr
-MAN1= zathura.1
-MANCOMPRESSED= no
-PLIST_FILES= bin/zathura \
- share/applications/zathura.desktop
-PLIST_DIRSTRY= share/applications
-
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
+MAN1+= zathura.1
MAN5+= zathurarc.5
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch: .SILENT
${REINPLACE_CMD} -e 's|man[15]|man/&|g' \
- -e '/CC/s/$${SFLAGS}/${STRIP} /' \
- -e '/CFLAGS/!s/$${LDFLAGS}/$${CFLAGS} &/' \
- -e 's/{DFLAGS/{DEBUG_FLAGS/g' \
- -e 's/755/${BINMODE}/' \
- -e 's/644/${MANMODE}/' \
- -e '/echo[[:space:]]CC/d' \
- -e '/echo/!s/^\([[:space:]]*\)@/\1/' \
- -e '/^all:/s/options//' \
- -e 's/cp[[:space:]]$$</cp $$>/' \
- -e 's/\(include\)[[:space:]]\(.*\)/.\1 "\2"/' \
+ -e 's|$${LIBDIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g'\
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|PLUGINDIR ?= .*$$|PLUGINDIR ?= ${PREFIX}/lib/zathura|'\
+ ${WRKSRC}/config.mk
.if defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's|which rst2man|${FALSE}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|install-manpages$$||'\
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|RSTTOMAN ?= /usr/bin/rst2man|RSTTOMAN ?= ""|'\
+ ${WRKSRC}/config.mk
+.endif
+.if defined(WITHOUT_NLS)
+ ${REINPLACE_CMD} -e '/-C po/d'\
+ ${WRKSRC}/Makefile
.endif
${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
-e 's/-lpthread/${PTHREAD_LIBS}/' \
-e 's/-lc//' \
- -e 's/$$(shell[[:space:]]\(.*\))/`\1`/' \
+ -e 's/DL_LIB /#&/' \
${WRKSRC}/config.mk
${REINPLACE_CMD} -e 's|/etc|${PREFIX}&|g' \
- ${WRKSRC}/config.def.h \
+ ${WRKSRC}/config.h \
${WRKSRC}/zathurarc.5.rst
+post-install: .SILENT
+ ${CAT} pkg-message
+
.include <bsd.port.mk>
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index 2ec33acd84b3..b4776e59faaa 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zathura-0.0.8.4.tar.gz) = 168b13b95c6689dcc3b0cc0f1758bf3877c7a81b4b8985e8c033bfbb8e35380e
-SIZE (zathura-0.0.8.4.tar.gz) = 37542
+SHA256 (zathura-0.1.2.tar.gz) = a496c25071e54f675b65ee5eab02fd002c04c2d7d5cf4aa8a1cb517cc13beaef
+SIZE (zathura-0.1.2.tar.gz) = 65875
diff --git a/graphics/zathura/files/patch-document.c b/graphics/zathura/files/patch-document.c
new file mode 100644
index 000000000000..c0e0444c5d84
--- /dev/null
+++ b/graphics/zathura/files/patch-document.c
@@ -0,0 +1,10 @@
+--- document.c.orig 2012-03-25 00:57:24.000000000 +0400
++++ document.c 2012-04-23 15:02:51.000000000 +0400
+@@ -12,6 +12,7 @@
+ #include <errno.h>
+ #include <glib.h>
+ #include <glib/gi18n.h>
++#include <sys/wait.h>
+
+ #include "document.h"
+ #include "utils.h"
diff --git a/graphics/zathura/pkg-message b/graphics/zathura/pkg-message
new file mode 100644
index 000000000000..c1cdbe5beb96
--- /dev/null
+++ b/graphics/zathura/pkg-message
@@ -0,0 +1,8 @@
+===============================================================================
+
+ In order to read documents, zathura need at least one plugin. Such
+ plugins are in graphics/zathura-* ports. If you want to read pdf files,
+ install the graphics/zathura-pdf-poppler or graphics/zathura-pdf-mupdf
+ port.
+
+===============================================================================
diff --git a/graphics/zathura/pkg-plist b/graphics/zathura/pkg-plist
new file mode 100644
index 000000000000..f24a0cc987d8
--- /dev/null
+++ b/graphics/zathura/pkg-plist
@@ -0,0 +1,10 @@
+bin/zathura
+include/zathura/document.h
+include/zathura/macros.h
+include/zathura/version.h
+include/zathura/zathura.h
+share/applications/zathura.desktop
+%%NLS%%share/locale/de/LC_MESSAGES/zathura.mo
+libdata/pkgconfig/zathura.pc
+@dirrmtry share/applications
+@dirrm include/zathura