aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-10-03 14:37:41 +0000
committerSteve Wills <swills@FreeBSD.org>2011-10-03 14:37:41 +0000
commitd5047b721d7fad32e6a2be1e13fef5067303c68a (patch)
treea8075bf582b059ae8b700b1b98a3553eb93e3b3f /graphics/zathura
parent5b1c1d3d9b9493c73a39d55d3a9dbcb395d08be3 (diff)
downloadports-d5047b721d7fad32e6a2be1e13fef5067303c68a.tar.gz
ports-d5047b721d7fad32e6a2be1e13fef5067303c68a.zip
Notes
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 944f65671aa4..a706e443dacd 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -26,8 +26,13 @@ PLIST_FILES= bin/zathura \
share/applications/zathura.desktop
PLIST_DIRSTRY= share/applications
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
+MAN5+= zathurarc.5
+.endif
+
post-patch: .SILENT
- ${REINPLACE_CMD} -e 's|man1|man/man1|g' \
+ ${REINPLACE_CMD} -e 's|man[15]|man/&|g' \
-e '/CC/s/$${SFLAGS}/${STRIP} /' \
-e '/CFLAGS/!s/$${LDFLAGS}/$${CFLAGS} &/' \
-e 's/{DFLAGS/{DEBUG_FLAGS/g' \
@@ -39,10 +44,16 @@ post-patch: .SILENT
-e 's/cp[[:space:]]$$</cp $$>/' \
-e 's/\(include\)[[:space:]]\(.*\)/.\1 "\2"/' \
${WRKSRC}/Makefile
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} 's|which rst2man|${FALSE}|' ${WRKSRC}/Makefile
+.endif
${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
-e 's/-lpthread/${PTHREAD_LIBS}/' \
-e 's/-lc//' \
-e 's/$$(shell[[:space:]]\(.*\))/`\1`/' \
${WRKSRC}/config.mk
+ ${REINPLACE_CMD} -e 's|/etc|${PREFIX}&|g' \
+ ${WRKSRC}/config.def.h \
+ ${WRKSRC}/zathurarc.5.rst
.include <bsd.port.mk>