aboutsummaryrefslogtreecommitdiff
path: root/graphics/zimg
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-08-30 03:12:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-08-30 03:12:38 +0000
commit2f80a253f725fab5ff408892ba96bbd2237193ea (patch)
tree85728be10244280d5565950808c5e1fcb20cb453 /graphics/zimg
parentb2421601afcfd8a885978347e937dee6a01faddb (diff)
downloadports-2f80a253f725fab5ff408892ba96bbd2237193ea.tar.gz
ports-2f80a253f725fab5ff408892ba96bbd2237193ea.zip
Notes
Diffstat (limited to 'graphics/zimg')
-rw-r--r--graphics/zimg/Makefile4
-rw-r--r--graphics/zimg/distinfo4
-rw-r--r--graphics/zimg/files/patch-zimg.c22
3 files changed, 27 insertions, 3 deletions
diff --git a/graphics/zimg/Makefile b/graphics/zimg/Makefile
index fabe72399ba9..ebab6cd667eb 100644
--- a/graphics/zimg/Makefile
+++ b/graphics/zimg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zimg
-PORTVERSION= 4.22.0
+PORTVERSION= 5.0.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,4 +28,6 @@ CONFIGURE_ARGS= --with-dynaload-cc="${CC}" \
MAN1= zimg.1
PLIST_FILES= include/zimg.h bin/zimg
+CFLAGS+= -DHAVE_GD_FREETYPE
+
.include <bsd.port.mk>
diff --git a/graphics/zimg/distinfo b/graphics/zimg/distinfo
index ca98666d31aa..0d81baac3394 100644
--- a/graphics/zimg/distinfo
+++ b/graphics/zimg/distinfo
@@ -1,2 +1,2 @@
-MD5 (zimg-4.22.0.tar.gz) = 61af1f7fdb32e099f8a0346afa35430e
-SIZE (zimg-4.22.0.tar.gz) = 378824
+MD5 (zimg-5.0.0.tar.gz) = 8522d35be806f6f10fea5a9bee11410c
+SIZE (zimg-5.0.0.tar.gz) = 384858
diff --git a/graphics/zimg/files/patch-zimg.c b/graphics/zimg/files/patch-zimg.c
new file mode 100644
index 000000000000..354fc730d16b
--- /dev/null
+++ b/graphics/zimg/files/patch-zimg.c
@@ -0,0 +1,22 @@
+--- zimg.c.orig Sat Aug 27 21:46:20 2005
++++ zimg.c Sat Aug 27 23:04:13 2005
+@@ -2147,6 +2147,8 @@
+
+ for (current = z.label; current; current = current->next) {
+
++ int width, height;
++
+ int x = current->x;
+ int y = current->y;
+
+@@ -2160,8 +2162,8 @@
+ continue;
+ }
+
+- int width = brect[2] - brect[6];
+- int height = brect[3] - brect[7];
++ width = brect[2] - brect[6];
++ height = brect[3] - brect[7];
+
+ /* if label.x or label.y are positive, do NOT make any
+ * check, if the text will be entirely on the image */