aboutsummaryrefslogtreecommitdiff
path: root/graphics/zint
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-09-10 08:17:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-09-10 08:17:46 +0000
commit78c3c68931b2d1f1b4bbbef187de657089b55369 (patch)
tree50a149ee1e7cffd8318dfd8436f2d0ff867af828 /graphics/zint
parentc9df16a3a723e6e28acfdfd03cc1e09168b59d99 (diff)
downloadports-78c3c68931b2d1f1b4bbbef187de657089b55369.tar.gz
ports-78c3c68931b2d1f1b4bbbef187de657089b55369.zip
Notes
Diffstat (limited to 'graphics/zint')
-rw-r--r--graphics/zint/Makefile12
-rw-r--r--graphics/zint/distinfo5
-rw-r--r--graphics/zint/files/patch-CMakeLists.txt16
-rw-r--r--graphics/zint/files/patch-backend_CMakeLists.txt15
-rw-r--r--graphics/zint/files/patch-backend_code1.c10
-rw-r--r--graphics/zint/files/patch-backend_maxicode.c10
-rw-r--r--graphics/zint/pkg-plist8
7 files changed, 33 insertions, 43 deletions
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
index 54c6ecbd1dcb..682004d33782 100644
--- a/graphics/zint/Makefile
+++ b/graphics/zint/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= zint
-PORTVERSION= 2.4.3
-PORTREVISION= 4
+DISTVERSION= 2.6.3_rc2 # NOT a "release candidate", fixup for 2.6.3
CATEGORIES= graphics
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.6.3
+DISTNAME= ${PORTNAME}-${DISTVERSION}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= Zint Barcode Generator
@@ -13,11 +13,13 @@ COMMENT= Zint Barcode Generator
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
+PORTSCOUT= skipv:2.6.3
+
LIB_DEPENDS= libpng.so:graphics/png
-USES= cmake qt:4
+USES= cmake qt:5
USE_LDCONFIG= yes
-USE_QT= gui xml qmake_build uic_build moc_build rcc_build designer
+USE_QT= buildtools_build qmake_build uitools_build core gui widgets
DESKTOP_ENTRIES="Zint" "Barcode generator" "" "zint-qt" "" false
diff --git a/graphics/zint/distinfo b/graphics/zint/distinfo
index 01009647aef1..d6dde2753806 100644
--- a/graphics/zint/distinfo
+++ b/graphics/zint/distinfo
@@ -1,2 +1,3 @@
-SHA256 (zint-2.4.3.tar.gz) = de2f4fd0d008530511f5dea2cff7f96f45df4c029b57431b2411b7e1f3a523e8
-SIZE (zint-2.4.3.tar.gz) = 403544
+TIMESTAMP = 1519159191
+SHA256 (zint-2.6.3_rc2.src.tar.gz) = db7e91ce917d85bc2f710e96a2adde9d942ad7aebc23a497222d32a6e8484c63
+SIZE (zint-2.6.3_rc2.src.tar.gz) = 769756
diff --git a/graphics/zint/files/patch-CMakeLists.txt b/graphics/zint/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d351088ff8c4
--- /dev/null
+++ b/graphics/zint/files/patch-CMakeLists.txt
@@ -0,0 +1,16 @@
+--- CMakeLists.txt.orig 2018-02-15 10:47:59 UTC
++++ CMakeLists.txt
+@@ -93,12 +93,7 @@ CONFIGURE_FILE(
+ ADD_CUSTOM_TARGET(uninstall
+ "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
+
+-# staniek: don't install
+-if (DATA_INSTALL_DIR)
+- set(CMAKE_MODULES_INSTALL_PATH ${DATA_INSTALL_DIR}/cmake/modules)
+-else (DATA_INSTALL_DIR)
+- set(CMAKE_MODULES_INSTALL_PATH ${CMAKE_ROOT}/Modules)
+-endif(DATA_INSTALL_DIR)
++set(CMAKE_MODULES_INSTALL_PATH ${CMAKE_ROOT}/Modules)
+
+ install(FILES cmake/modules/FindZint.cmake DESTINATION ${CMAKE_MODULES_INSTALL_PATH} COMPONENT Devel)
+
diff --git a/graphics/zint/files/patch-backend_CMakeLists.txt b/graphics/zint/files/patch-backend_CMakeLists.txt
index c2c8447cf5e6..438a1991163b 100644
--- a/graphics/zint/files/patch-backend_CMakeLists.txt
+++ b/graphics/zint/files/patch-backend_CMakeLists.txt
@@ -1,5 +1,5 @@
---- backend/CMakeLists.txt.orig 2011-03-30 15:13:56.000000000 +0800
-+++ backend/CMakeLists.txt 2011-03-30 15:14:34.000000000 +0800
+--- backend/CMakeLists.txt.orig 2018-02-15 10:47:59 UTC
++++ backend/CMakeLists.txt
@@ -2,7 +2,8 @@
project(zint)
@@ -8,14 +8,5 @@
+find_package(PNG REQUIRED)
+include_directories(${PNG_INCLUDE_DIR})
- set(zint_COMMON_SRCS common.c library.c render.c ps.c large.c reedsol.c gs1.c svg.c png.c)
+ set(zint_COMMON_SRCS common.c library.c render.c large.c reedsol.c gs1.c eci.c)
set(zint_ONEDIM_SRCS code.c code128.c 2of5.c upcean.c telepen.c medical.c plessey.c rss.c)
-@@ -21,7 +22,7 @@ add_library(zint SHARED ${zint_SRCS})
- set_target_properties(zint PROPERTIES SOVERSION "${ZINT_VERSION_MAJOR}.${ZINT_VERSION_MINOR}"
- VERSION ${ZINT_VERSION})
-
--target_link_libraries(zint ${PNG_LIBRARIES} )
-+target_link_libraries(zint ${PNG_LIBRARY} )
- target_link_libraries(zint -lm)
-
- install(TARGETS zint ${INSTALL_TARGETS_DEFAULT_ARGS} )
diff --git a/graphics/zint/files/patch-backend_code1.c b/graphics/zint/files/patch-backend_code1.c
deleted file mode 100644
index 1be3e5599dac..000000000000
--- a/graphics/zint/files/patch-backend_code1.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- backend/code1.c.orig 2011-03-30 15:18:25.000000000 +0800
-+++ backend/code1.c 2011-03-30 15:18:35.000000000 +0800
-@@ -28,7 +28,6 @@
- #ifdef __APPLE__
- #include <sys/malloc.h>
- #else
--#include <malloc.h>
- #endif
-
- void horiz(struct zint_symbol *symbol, int row_no, int full)
diff --git a/graphics/zint/files/patch-backend_maxicode.c b/graphics/zint/files/patch-backend_maxicode.c
deleted file mode 100644
index 2a587d33450b..000000000000
--- a/graphics/zint/files/patch-backend_maxicode.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- backend/maxicode.c.orig 2011-03-30 15:17:49.000000000 +0800
-+++ backend/maxicode.c 2011-03-30 15:18:15.000000000 +0800
-@@ -29,7 +29,6 @@
- #ifdef __APPLE__
- #include <sys/malloc.h>
- #else
--#include <malloc.h>
- #endif
-
- int maxi_codeword[144];
diff --git a/graphics/zint/pkg-plist b/graphics/zint/pkg-plist
index 37a742401482..edae5fe7d996 100644
--- a/graphics/zint/pkg-plist
+++ b/graphics/zint/pkg-plist
@@ -3,9 +3,9 @@ bin/zint-qt
include/qzint.h
include/zint.h
lib/libQZint.so
-lib/libQZint.so.2.4
-lib/libQZint.so.2.4.1
+lib/libQZint.so.2.6
+lib/libQZint.so.2.6.3
lib/libzint.so
-lib/libzint.so.2.4
-lib/libzint.so.2.4.1
+lib/libzint.so.2.6
+lib/libzint.so.2.6.3
share/cmake/Modules/FindZint.cmake