aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2011-09-24 23:26:35 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2011-09-24 23:26:35 +0000
commited5b4773f7605598dc49f1e0b6ca4a4baff18b88 (patch)
treea8fbc65329c0cc0655db1586181827519ecac878 /graphics/zphoto/Makefile
parent8dcc28bea8da818de0b4c3dabb7508ad4e59bc22 (diff)
downloadports-ed5b4773f7605598dc49f1e0b6ca4a4baff18b88.tar.gz
ports-ed5b4773f7605598dc49f1e0b6ca4a4baff18b88.zip
Notes
Diffstat (limited to 'graphics/zphoto/Makefile')
-rw-r--r--graphics/zphoto/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 10c03be738a8..21384074e10e 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -17,14 +17,12 @@ COMMENT= Zooming photo album generator
LIB_DEPENDS= ming.5:${PORTSDIR}/graphics/ming \
popt.0:${PORTSDIR}/devel/popt
-.if !defined (WITHOUT_AVIPLAY)
-LIB_DEPENDS+= aviplay.0:${PORTSDIR}/multimedia/avifile
-.endif
.if !defined (WITHOUT_ZIP)
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
.endif
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-avifile
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
@@ -36,9 +34,6 @@ PLIST_FILES+= bin/wxzphoto
.else
CONFIGURE_ARGS+= --disable-wx
.endif
-.if defined (WITHOUT_AVIPLAY)
-CONFIGURE_ARGS+= --disable-avifile
-.endif
.if defined (WITHOUT_ZIP)
CONFIGURE_ARGS+= --disable-zip
.endif