aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-12 05:42:05 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-12 05:42:05 +0000
commit9a4405b5cf1a9fa9e036dee3deedfd4feca9e17c (patch)
tree421be00e7af4211086349df1084a37a295c186fb /graphics/zphoto
parent6176e76b0e4708151bbe4ae779ad3c2df0b217e8 (diff)
downloadports-9a4405b5cf1a9fa9e036dee3deedfd4feca9e17c.tar.gz
ports-9a4405b5cf1a9fa9e036dee3deedfd4feca9e17c.zip
Notes
Diffstat (limited to 'graphics/zphoto')
-rw-r--r--graphics/zphoto/Makefile3
-rw-r--r--graphics/zphoto/distinfo4
-rw-r--r--graphics/zphoto/files/patch-util.c10
-rw-r--r--graphics/zphoto/files/patch-zphoto.c12
4 files changed, 15 insertions, 14 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 5c318cad8d19..6d74951e256d 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/zphoto/distinfo b/graphics/zphoto/distinfo
index e6040d3392f6..25b6454d80d5 100644
--- a/graphics/zphoto/distinfo
+++ b/graphics/zphoto/distinfo
@@ -1,2 +1,2 @@
-MD5 (zphoto-0.8.tar.gz) = 1d99079cc9eb20b87001f49a238cfa46
-SIZE (zphoto-0.8.tar.gz) = 146648
+MD5 (zphoto-0.9.tar.gz) = 49831fc49878c25397f635458ea45a93
+SIZE (zphoto-0.9.tar.gz) = 150821
diff --git a/graphics/zphoto/files/patch-util.c b/graphics/zphoto/files/patch-util.c
deleted file mode 100644
index 479773932167..000000000000
--- a/graphics/zphoto/files/patch-util.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- util.c.orig Sun Apr 4 02:11:57 2004
-+++ util.c Fri Apr 9 00:25:22 2004
-@@ -393,7 +393,6 @@
- int
- zphoto_video_file_p (const char *file_name)
- {
-- return 0;
- /*
- * Check by its file name only (not its content).
- */
diff --git a/graphics/zphoto/files/patch-zphoto.c b/graphics/zphoto/files/patch-zphoto.c
new file mode 100644
index 000000000000..6bf251887617
--- /dev/null
+++ b/graphics/zphoto/files/patch-zphoto.c
@@ -0,0 +1,12 @@
+--- zphoto.c.orig Sat Apr 10 18:12:30 2004
++++ zphoto.c Mon Apr 12 09:48:26 2004
+@@ -1308,8 +1308,8 @@
+ fp = zphoto_efopen(file_name, "r");
+
+ while (fgets(buf, BUFSIZ, fp)) {
+- buf[strcspn(buf, "\r\n")] = '\0'; /* chomp */
+ char *sep, *file_name, *caption;
++ buf[strcspn(buf, "\r\n")] = '\0'; /* chomp */
+ if (buf[0] == '#')
+ continue;
+ if ((sep = strchr(buf, '\t'))) {