aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-01-30 18:10:45 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-01-30 18:10:45 +0000
commitd4ef69fc353de58f938769650f4849081e66bc7f (patch)
treee73cfa3533090e8e65ac979a628011da2c650f97 /graphics/zphoto
parent924367b126cc3437bfd969312d98dd0d76422459 (diff)
downloadports-d4ef69fc353de58f938769650f4849081e66bc7f.tar.gz
ports-d4ef69fc353de58f938769650f4849081e66bc7f.zip
Notes
Diffstat (limited to 'graphics/zphoto')
-rw-r--r--graphics/zphoto/Makefile4
-rw-r--r--graphics/zphoto/distinfo2
-rw-r--r--graphics/zphoto/files/patch-Makefile.in11
-rw-r--r--graphics/zphoto/files/patch-templates::all::Makefile.in11
-rw-r--r--graphics/zphoto/files/patch-util.c11
-rw-r--r--graphics/zphoto/files/patch-zphoto.c19
-rw-r--r--graphics/zphoto/pkg-message6
-rw-r--r--graphics/zphoto/pkg-plist14
8 files changed, 58 insertions, 20 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 7e868bb02b1c..b8414d6d6d7e 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.2
+PORTVERSION= 0.4
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= umeno@rr.iij4u.or.jp
-#BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget
LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
Imlib2.1:${PORTSDIR}/graphics/imlib2 \
popt.0:${PORTSDIR}/devel/popt
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
diff --git a/graphics/zphoto/distinfo b/graphics/zphoto/distinfo
index d3eebefd0af3..ef899ec282db 100644
--- a/graphics/zphoto/distinfo
+++ b/graphics/zphoto/distinfo
@@ -1 +1 @@
-MD5 (zphoto-0.2.tar.gz) = add4cb33908494af595a076db4ddad6a
+MD5 (zphoto-0.4.tar.gz) = 585faf9925ec65c33a599feb014147df
diff --git a/graphics/zphoto/files/patch-Makefile.in b/graphics/zphoto/files/patch-Makefile.in
deleted file mode 100644
index fd261fec32e7..000000000000
--- a/graphics/zphoto/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Sun Jul 21 00:50:36 2002
-+++ Makefile.in Sun Jul 21 00:50:44 2002
-@@ -460,7 +460,7 @@
-
-
- Techno.fdb:
-- wget http://opaque.net/ming/tutorial/flashdot.tgz
-+ fetch http://opaque.net/ming/tutorial/flashdot.tgz
- tar zxf flashdot.tgz Techno.fdb
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/graphics/zphoto/files/patch-templates::all::Makefile.in b/graphics/zphoto/files/patch-templates::all::Makefile.in
new file mode 100644
index 000000000000..257c4ec43d01
--- /dev/null
+++ b/graphics/zphoto/files/patch-templates::all::Makefile.in
@@ -0,0 +1,11 @@
+--- templates/all/Makefile.in.orig Tue Jan 28 22:56:04 2003
++++ templates/all/Makefile.in Fri Jan 31 01:51:27 2003
+@@ -70,7 +70,7 @@
+ ZPHOTO_URL = @ZPHOTO_URL@
+
+ templatesdir = $(pkgdatadir)/templates/all
+-templates_DATA = zphoto.css
++templates_DATA = zphoto.css .photo.html
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/graphics/zphoto/files/patch-util.c b/graphics/zphoto/files/patch-util.c
new file mode 100644
index 000000000000..b217d23c5014
--- /dev/null
+++ b/graphics/zphoto/files/patch-util.c
@@ -0,0 +1,11 @@
+--- util.c.orig Tue Jan 28 19:18:20 2003
++++ util.c Wed Jan 29 00:55:26 2003
+@@ -57,7 +57,7 @@
+ exit(2);
+ }
+
+-extern int vasprintf (char **ptr, const char *fmt, ...);
++/* extern int vasprintf (char **ptr, const char *fmt, ...); */
+
+ char *
+ zphoto_asprintf (const char *fmt, ...)
diff --git a/graphics/zphoto/files/patch-zphoto.c b/graphics/zphoto/files/patch-zphoto.c
new file mode 100644
index 000000000000..b7e6fe1eb57f
--- /dev/null
+++ b/graphics/zphoto/files/patch-zphoto.c
@@ -0,0 +1,19 @@
+--- zphoto.c.orig Tue Jan 28 19:18:20 2003
++++ zphoto.c Fri Jan 31 01:34:57 2003
+@@ -248,7 +248,7 @@
+ int width, height;
+ char *photo_width, *photo_height;
+
+- photo_file_name = basename(options->input_photos[id]);
++ photo_file_name = zphoto_strdup(basename(options->input_photos[id]));
+ if (id > 0)
+ prev_file_name =
+ zphoto_modify_suffix(basename(options->input_photos[id - 1]),
+@@ -283,6 +283,7 @@
+ zphoto_create_date_string(date_string, BUFSIZ,
+ zphoto_get_mtime(options->input_photos[id]));
+ zphoto_template_add_subst(template, "photo_date", date_string);
++ free(photo_file_name);
+ free(prev_file_name);
+ free(next_file_name);
+ free(photo_width);
diff --git a/graphics/zphoto/pkg-message b/graphics/zphoto/pkg-message
index f3892d71c94b..967cbfed89b4 100644
--- a/graphics/zphoto/pkg-message
+++ b/graphics/zphoto/pkg-message
@@ -4,12 +4,14 @@
sh or bash:
$ ZPHOTO_TEMPLATE_DIR=%%PREFIX%%/share/zphoto/templates/en (english)
$ ZPHOTO_TEMPLATE_DIR=%%PREFIX%%/share/zphoto/templates/ja (japanese)
- $ ZPHOTO_FONT=%%PREFIX%%/share/zphoto/fonts/Techno.fdb
+ $ ZPHOTO_TEMPLATE_DIR=%%PREFIX%%/share/zphoto/templates/all (both)
+ $ ZPHOTO_FONT=%%PREFIX%%/share/zphoto/fonts/EfontSerifB.fdb
$ export ZPHOTO_TEMPLATE_DIR ZPHOTO_FONT
csh or tcsh:
% setenv ZPHOTO_TEMPLATE_DIR %%PREFIX%%/share/zphoto/templates/en (english)
% setenv ZPHOTO_TEMPLATE_DIR %%PREFIX%%/share/zphoto/templates/ja (japanese)
- % setenv ZPHOTO_FONT %%PREFIX%%/share/zphoto/fonts/Techno.fdb
+ % setenv ZPHOTO_TEMPLATE_DIR %%PREFIX%%/share/zphoto/templates/all (both)
+ % setenv ZPHOTO_FONT %%PREFIX%%/share/zphoto/fonts/EfontSerifB.fdb
******************************************************************************
diff --git a/graphics/zphoto/pkg-plist b/graphics/zphoto/pkg-plist
index 52c1b78d54d7..77a493b44b1c 100644
--- a/graphics/zphoto/pkg-plist
+++ b/graphics/zphoto/pkg-plist
@@ -1,19 +1,25 @@
bin/zphoto
+share/zphoto/templates/en/.photo.html
share/zphoto/templates/en/index.html
share/zphoto/templates/en/noflash.html
share/zphoto/templates/en/zphoto.css
+share/zphoto/templates/ja/.photo.html
share/zphoto/templates/ja/index.html
share/zphoto/templates/ja/noflash.html
share/zphoto/templates/ja/zphoto.css
+share/zphoto/templates/all/.photo.html
share/zphoto/templates/all/zphoto.css
-share/zphoto/templates/all/noflash.html.ja
-share/zphoto/templates/all/noflash.html.en
-share/zphoto/templates/all/index.html.ja
share/zphoto/templates/all/index.html.en
-share/zphoto/fonts/Techno.fdb
+share/zphoto/templates/all/index.html.ja
+share/zphoto/templates/all/noflash.html.en
+share/zphoto/templates/all/noflash.html.ja
+share/zphoto/doc/zphoto-ja.html
+share/zphoto/doc/zphoto.html
+share/zphoto/fonts/EfontSerifB.fdb
@dirrm share/zphoto/templates/en
@dirrm share/zphoto/templates/ja
@dirrm share/zphoto/templates/all
@dirrm share/zphoto/templates
@dirrm share/zphoto/fonts
+@dirrm share/zphoto/doc
@dirrm share/zphoto