aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-28 15:51:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-28 15:51:33 +0000
commit325958df3fb67b6a877375382666ff7792fd6ba2 (patch)
tree0f6c3483c794387ea9e5413d5db7b9f813b03b7a /graphics
parent2861ce13483130ecd11c9046349eeefb9531ccaf (diff)
downloadports-325958df3fb67b6a877375382666ff7792fd6ba2.tar.gz
ports-325958df3fb67b6a877375382666ff7792fd6ba2.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pear-Image_GraphViz/Makefile24
-rw-r--r--graphics/pear-Image_GraphViz/distinfo3
-rw-r--r--graphics/pear-Image_GraphViz/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index aacf0005bf46..7f98df65125c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -510,6 +510,7 @@
SUBDIR += pear-Image_Canvas
SUBDIR += pear-Image_Color
SUBDIR += pear-Image_Graph
+ SUBDIR += pear-Image_GraphViz
SUBDIR += pear-Image_Transform
SUBDIR += pecl-imagick
SUBDIR += pecl-imlib2
diff --git a/graphics/pear-Image_GraphViz/Makefile b/graphics/pear-Image_GraphViz/Makefile
new file mode 100644
index 000000000000..99f2ce0e0fae
--- /dev/null
+++ b/graphics/pear-Image_GraphViz/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-Image_GraphViz
+# Date created: 17 May 2007
+# Whom: Gerrit Beine (<gerrit.beine@gmx.de>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image_GraphViz
+PORTVERSION= 1.2.1
+CATEGORIES= graphics www pear
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= An interface to AT&T's GraphViz tools
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz
+
+CATEGORY= Image
+FILES= GraphViz.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/graphics/pear-Image_GraphViz/distinfo b/graphics/pear-Image_GraphViz/distinfo
new file mode 100644
index 000000000000..2e7100302bbc
--- /dev/null
+++ b/graphics/pear-Image_GraphViz/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Image_GraphViz-1.2.1.tgz) = 8828e58960e0d93820cb3bdcce85e705
+SHA256 (PEAR/Image_GraphViz-1.2.1.tgz) = 5a566d4cd39f9e39be6c9b8b95ca81fca7d2283638a774a079dafc9b304d5338
+SIZE (PEAR/Image_GraphViz-1.2.1.tgz) = 4872
diff --git a/graphics/pear-Image_GraphViz/pkg-descr b/graphics/pear-Image_GraphViz/pkg-descr
new file mode 100644
index 000000000000..6b6b49a5262c
--- /dev/null
+++ b/graphics/pear-Image_GraphViz/pkg-descr
@@ -0,0 +1,4 @@
+The GraphViz class allows for the creation of and the work with directed and
+undirected graphs and their visualization with AT&T's GraphViz tools.
+
+WWW: http://pear.php.net/package/Image_GraphViz