aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-06-25 00:29:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-06-25 00:29:09 +0000
commit45cb752a04894d48090981be1a7d2f549f2b684f (patch)
treeec081b06d4ac1171d90c17f7c227c9b2007dc591 /graphics
parent5b72408838c185b3a8f6d14cd522ed27f7fd4ed2 (diff)
Begin deorbit burn of ia64. We have not attempted to build packages for
it for many years. While here, alphabetize ARCHs, pet portlint, and modernize usages. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=444251
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dataplot/Makefile4
-rw-r--r--graphics/gsculpt/Makefile9
-rw-r--r--graphics/nvidia-texture-tools/Makefile4
3 files changed, 8 insertions, 9 deletions
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index ae56d5b493cd..d75748f5be65 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -29,14 +29,14 @@ MAXOBV?= 400000 # Change if you need more observations/variable
.include <bsd.port.options.mk>
-.if ((${ARCH}=="amd64") || (${ARCH}=="sparc64") || (${ARCH}=="ia64"))
+.if ${ARCH} == amd64 || ${ARCH} == sparc64
FFLAGS+= -DDD -DI32 -fdefault-real-8 -fdefault-double-8
.else
FFLAGS+= -DSD -DI32 -fdefault-real-8 -fdefault-double-8
.endif
post-extract:
- @${INSTALL_DATA} ${FILESDIR}/Makefile.tmpl ${WRKSRC}/Makefile
+ ${INSTALL_DATA} ${FILESDIR}/Makefile.tmpl ${WRKSRC}/Makefile
@${REINPLACE_CMD} \
-e 's;%%CFLAGS%%;${CFLAGS};' \
-e 's;%%FFLAGS%%;${FFLAGS};' \
diff --git a/graphics/gsculpt/Makefile b/graphics/gsculpt/Makefile
index 5e4dbe447164..02a12e1445f4 100644
--- a/graphics/gsculpt/Makefile
+++ b/graphics/gsculpt/Makefile
@@ -18,6 +18,9 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>0:graphics/py-PyOpenGL \
${PYTHON_PKGNAMEPREFIX}gtkglext>0:x11-toolkits/py-gtkglext
+BROKEN_powerpc= fails to compile
+BROKEN_sparc64= fails to compile
+
WRKSRC= ${WRKDIR}/${DISTNAME:S,-src,,}
USES= pkgconfig python:2 scons
@@ -34,11 +37,7 @@ DESKTOP_ENTRIES="gSculpt" "" \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= does not compile on ia64, powerpc, or sparc64
-.endif
-
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
CFLAGS+= -DGSCULPT_FPU_X86
.endif
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index ac0d54b42a9f..e7c4de452b86 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -16,7 +16,6 @@ LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libIlmImf.so:graphics/OpenEXR
-BROKEN_ia64= does not build
BROKEN_powerpc= does not build
BROKEN_sparc64= does not build
@@ -32,7 +31,8 @@ CXXFLAGS+= -fPIC
PORTDOCS= NVIDIA_Texture_Tools_README.txt ChangeLog
-ONLY_FOR_ARCHS= i386 amd64 powerpc powerpc64 # see src/nvcore/nvcore.h
+# see src/nvcore/nvcore.h
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
OPTIONS_DEFINE= COMPRESSUI DOCS
OPTIONS_SUB= yes