aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-10 13:54:26 +0000
commit5005b67362a735dc18d3d85170eae34e1fb6feab (patch)
tree3a1e73b4128190b7ed7020b2113a1d94d76b0e93 /graphics
parente4eefd3f1e344c567f932fef63a6f04a0bb4eba4 (diff)
downloadports-5005b67362a735dc18d3d85170eae34e1fb6feab.tar.gz
ports-5005b67362a735dc18d3d85170eae34e1fb6feab.zip
According to the Porter's Handbook (5.12.2.3.) default options must be added to
OPTIONS_DEFINE. This policy has been implemented only recently that's why we have many ports violating this policy. This patch adds the default options specified in the Porter's Handbook to OPTIONS_DEFINE where they are being used. Ports maintained by gnome@FreeBSD.org, kde@FreeBSD.org and x11@FreeBSD.org have been excluded. Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=343634
Diffstat (limited to 'graphics')
-rw-r--r--graphics/barbecue/Makefile2
-rw-r--r--graphics/cegui/Makefile3
-rw-r--r--graphics/darknock/Makefile2
-rw-r--r--graphics/deegree-csw/Makefile3
-rw-r--r--graphics/deegree-igeoportal/Makefile3
-rw-r--r--graphics/deegree-wcs/Makefile3
-rw-r--r--graphics/deegree-wfs/Makefile3
-rw-r--r--graphics/deegree-wms/Makefile3
-rw-r--r--graphics/deegree-wps/Makefile3
-rw-r--r--graphics/deegree-wpvs/Makefile3
-rw-r--r--graphics/fv/Makefile3
-rw-r--r--graphics/goocanvas/Makefile2
-rw-r--r--graphics/goocanvas2/Makefile2
-rw-r--r--graphics/gqview/Makefile3
-rw-r--r--graphics/gscan2pdf/Makefile3
-rw-r--r--graphics/gtkdps/Makefile3
-rw-r--r--graphics/hobbes-icons-xpm/Makefile2
-rw-r--r--graphics/import-pictures/Makefile3
-rw-r--r--graphics/impressive/Makefile3
-rw-r--r--graphics/jpeg/Makefile2
-rw-r--r--graphics/libexif-gtk/Makefile3
-rw-r--r--graphics/linux-adobesvg/Makefile3
-rw-r--r--graphics/maverik/Makefile3
-rw-r--r--graphics/meshviewer/Makefile3
-rw-r--r--graphics/mxp/Makefile3
-rw-r--r--graphics/ocrad/Makefile2
-rw-r--r--graphics/ocrfeeder/Makefile3
-rw-r--r--graphics/openjump/Makefile2
-rw-r--r--graphics/pgplot/Makefile3
-rw-r--r--graphics/php5-swfed/Makefile2
-rw-r--r--graphics/plotmtv/Makefile3
-rw-r--r--graphics/pure-gl/Makefile2
-rw-r--r--graphics/py-actdiag/Makefile3
-rw-r--r--graphics/py-seqdiag/Makefile3
-rw-r--r--graphics/py-webcolors/Makefile2
-rw-r--r--graphics/qvplay/Makefile3
-rw-r--r--graphics/ruby-gd/Makefile2
-rw-r--r--graphics/scantailor/Makefile3
-rw-r--r--graphics/sketch/Makefile3
-rw-r--r--graphics/xmorph/Makefile3
-rw-r--r--graphics/xoris/Makefile2
41 files changed, 110 insertions, 0 deletions
diff --git a/graphics/barbecue/Makefile b/graphics/barbecue/Makefile
index 6463173d2fc3..7c3f310ffdf7 100644
--- a/graphics/barbecue/Makefile
+++ b/graphics/barbecue/Makefile
@@ -33,6 +33,8 @@ OPTIONS_SINGLE= AS
OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 418885ec70cc..b4941b3b27ea 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -37,6 +37,9 @@ USES= pathfix pkgconfig
PLIST_SUB+= WITH_OGRE=""
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/graphics/darknock/Makefile b/graphics/darknock/Makefile
index 3efc0109a0ee..ce465c0e95b2 100644
--- a/graphics/darknock/Makefile
+++ b/graphics/darknock/Makefile
@@ -27,6 +27,8 @@ DESKTOP_ENTRIES= "${PORTNAME}" \
"Graphics;Qt;" \
"true"
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/deegree-csw/Makefile b/graphics/deegree-csw/Makefile
index 2692a7416667..32f698095289 100644
--- a/graphics/deegree-csw/Makefile
+++ b/graphics/deegree-csw/Makefile
@@ -31,6 +31,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index 3edf22bc2e5e..d67e817e69ad 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -30,6 +30,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
index 6523ba65fc6e..37dfc194e7c9 100644
--- a/graphics/deegree-wcs/Makefile
+++ b/graphics/deegree-wcs/Makefile
@@ -30,6 +30,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
index 1bfb6bc53620..dde54c6d0077 100644
--- a/graphics/deegree-wfs/Makefile
+++ b/graphics/deegree-wfs/Makefile
@@ -30,6 +30,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/deegree-wms/Makefile b/graphics/deegree-wms/Makefile
index bcca279dddea..52262458bf32 100644
--- a/graphics/deegree-wms/Makefile
+++ b/graphics/deegree-wms/Makefile
@@ -30,6 +30,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/deegree-wps/Makefile b/graphics/deegree-wps/Makefile
index 2eab9677a75e..1b10a11acafa 100644
--- a/graphics/deegree-wps/Makefile
+++ b/graphics/deegree-wps/Makefile
@@ -30,6 +30,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/deegree-wpvs/Makefile b/graphics/deegree-wpvs/Makefile
index dc814c25b987..608895364e67 100644
--- a/graphics/deegree-wpvs/Makefile
+++ b/graphics/deegree-wpvs/Makefile
@@ -30,6 +30,9 @@ OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT6}
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 59e2918aa2d0..27111eae2903 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -31,6 +31,9 @@ PORTDOCS= AUTHORS ChangeLog README
PLIST_FILES= bin/${PORTNAME}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if !defined(WITH_DEBUG)
diff --git a/graphics/goocanvas/Makefile b/graphics/goocanvas/Makefile
index c7f4853b5930..64dcd6f54df3 100644
--- a/graphics/goocanvas/Makefile
+++ b/graphics/goocanvas/Makefile
@@ -23,6 +23,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/goocanvas2/Makefile b/graphics/goocanvas2/Makefile
index ad9d5a567eca..a49b9cf42468 100644
--- a/graphics/goocanvas2/Makefile
+++ b/graphics/goocanvas2/Makefile
@@ -23,6 +23,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/gtk-doc/html/goocanvas2
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index 622a7196a119..206673bee258 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -27,6 +27,9 @@ CONFLICTS= gqview-devel-[0-9]*
PORTSCOUT= limitw:1,even
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
index b2f4cce70d20..b513f19989c8 100644
--- a/graphics/gscan2pdf/Makefile
+++ b/graphics/gscan2pdf/Makefile
@@ -69,6 +69,9 @@ MAN1= ${PORTNAME}.1 scanadf-perl.1 scanimage-perl.1
PORT_VERBS= ${PORTNAME} Gscan2pdf
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/gtkdps/Makefile b/graphics/gtkdps/Makefile
index 3129c317169f..84527e373c68 100644
--- a/graphics/gtkdps/Makefile
+++ b/graphics/gtkdps/Makefile
@@ -25,6 +25,9 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/hobbes-icons-xpm/Makefile b/graphics/hobbes-icons-xpm/Makefile
index c4dd34072aea..531f30aba71a 100644
--- a/graphics/hobbes-icons-xpm/Makefile
+++ b/graphics/hobbes-icons-xpm/Makefile
@@ -15,6 +15,8 @@ NO_BUILD= yes
LIBDIR= ${STAGEDIR}${PREFIX}/include/X11/pixmaps
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/graphics/import-pictures/Makefile b/graphics/import-pictures/Makefile
index 86793f57236f..5d90ec8cd428 100644
--- a/graphics/import-pictures/Makefile
+++ b/graphics/import-pictures/Makefile
@@ -25,6 +25,9 @@ MAN1= ${PORTNAME}.1
PORTDOCS= import-pictures.html
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 597601b3d47c..b582b3fc0f52 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -31,6 +31,9 @@ MAN1= ${PORTNAME}.1
PORTDOCS= ${PORTNAME}.html demo.pdf
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/graphics/jpeg/Makefile b/graphics/jpeg/Makefile
index 38d3f8976027..c8d59add922f 100644
--- a/graphics/jpeg/Makefile
+++ b/graphics/jpeg/Makefile
@@ -31,6 +31,8 @@ ADDITIONAL_HEADER= jinclude.h jpegint.h
CONFIGURE_ARGS+= --enable-maxmem=${J_MAXMEM}
.endif
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-extract:
diff --git a/graphics/libexif-gtk/Makefile b/graphics/libexif-gtk/Makefile
index 3f216c2137ce..22cde1f5ee64 100644
--- a/graphics/libexif-gtk/Makefile
+++ b/graphics/libexif-gtk/Makefile
@@ -24,6 +24,9 @@ USE_LDCONFIG= yes
PORTDOCS= AUTHORS ChangeLog NEWS README
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/linux-adobesvg/Makefile b/graphics/linux-adobesvg/Makefile
index 3841956e2112..52485298fd64 100644
--- a/graphics/linux-adobesvg/Makefile
+++ b/graphics/linux-adobesvg/Makefile
@@ -29,6 +29,9 @@ PLIST_DIRS= ${LIBDIR:S|^${PREFIX}/||}
PORTDOCS= LICENSE.txt ReadMe.html SVGHelp.html
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
do-install:
diff --git a/graphics/maverik/Makefile b/graphics/maverik/Makefile
index a5dcad8e1b4b..6cac1b897d43 100644
--- a/graphics/maverik/Makefile
+++ b/graphics/maverik/Makefile
@@ -26,6 +26,9 @@ MAKE_JOBS_UNSAFE= yes
PORTDOCS= *
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPNG}
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
index 9e26bfb20bff..016a7253b6fb 100644
--- a/graphics/meshviewer/Makefile
+++ b/graphics/meshviewer/Makefile
@@ -42,6 +42,9 @@ DOC_FILES3= *.html *.ico
PLIST_FILES= bin/${PORTNAME}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/graphics/mxp/Makefile b/graphics/mxp/Makefile
index b300d603470a..a954c43820fb 100644
--- a/graphics/mxp/Makefile
+++ b/graphics/mxp/Makefile
@@ -21,6 +21,9 @@ PLIST_FILES= bin/${PORTNAME} \
PLIST_DIRS= %%PORTDOCS%%%%DOCSDIR%%
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-extract:
diff --git a/graphics/ocrad/Makefile b/graphics/ocrad/Makefile
index 1eaa25eb4d2e..946a8bd3b62f 100644
--- a/graphics/ocrad/Makefile
+++ b/graphics/ocrad/Makefile
@@ -23,6 +23,8 @@ PLIST_FILES= bin/${PORTNAME} man/man1/ocrad.1.gz
PORTDOCS= AUTHORS ChangeLog NEWS README
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000024
diff --git a/graphics/ocrfeeder/Makefile b/graphics/ocrfeeder/Makefile
index 9e58157d5092..07b369960f2b 100644
--- a/graphics/ocrfeeder/Makefile
+++ b/graphics/ocrfeeder/Makefile
@@ -31,6 +31,9 @@ USES= gettext gmake pkgconfig
USE_GHOSTSCRIPT=yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/openjump/Makefile b/graphics/openjump/Makefile
index 9a5da8607fa4..a512eaf7c9d8 100644
--- a/graphics/openjump/Makefile
+++ b/graphics/openjump/Makefile
@@ -59,6 +59,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/bin/default-plugins.xml ${TARGET_DIR}/bin/
${INSTALL_DATA} ${WRKSRC}/bin/log4j.xml ${TARGET_DIR}/bin/
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 77b2ed18eedf..0327353d1834 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -26,6 +26,9 @@ SUFFIXES= flib clib bin
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${ARCH:M*64*}
diff --git a/graphics/php5-swfed/Makefile b/graphics/php5-swfed/Makefile
index 1e3e97f70a9f..f9875d59fb29 100644
--- a/graphics/php5-swfed/Makefile
+++ b/graphics/php5-swfed/Makefile
@@ -29,6 +29,8 @@ PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
PORTDOCS= readme.txt
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/graphics/plotmtv/Makefile b/graphics/plotmtv/Makefile
index 02a97c069b22..b4dfbdd9f764 100644
--- a/graphics/plotmtv/Makefile
+++ b/graphics/plotmtv/Makefile
@@ -21,6 +21,9 @@ MAN1= plotmtv.1
MAKE_JOBS_UNSAFE= yes
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/graphics/pure-gl/Makefile b/graphics/pure-gl/Makefile
index f022b628c2ee..69376deddedd 100644
--- a/graphics/pure-gl/Makefile
+++ b/graphics/pure-gl/Makefile
@@ -24,6 +24,8 @@ PORTDOCS= README
PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/graphics/py-actdiag/Makefile b/graphics/py-actdiag/Makefile
index 58ed5e8c86c6..57532e7f8f8c 100644
--- a/graphics/py-actdiag/Makefile
+++ b/graphics/py-actdiag/Makefile
@@ -25,6 +25,9 @@ DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
PORTDOCS= README.txt
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/graphics/py-seqdiag/Makefile b/graphics/py-seqdiag/Makefile
index 2ca3036c28f8..c55a99458e05 100644
--- a/graphics/py-seqdiag/Makefile
+++ b/graphics/py-seqdiag/Makefile
@@ -28,6 +28,9 @@ PORTDOCS= README.txt
PORTEXAMPLES= *
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-install:
diff --git a/graphics/py-webcolors/Makefile b/graphics/py-webcolors/Makefile
index 3a63184e9d76..422b973c41a6 100644
--- a/graphics/py-webcolors/Makefile
+++ b/graphics/py-webcolors/Makefile
@@ -19,6 +19,8 @@ PYDISTUTILS_AUTOPLIST= yes
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/graphics/qvplay/Makefile b/graphics/qvplay/Makefile
index 512521696261..63fcd48a2ca4 100644
--- a/graphics/qvplay/Makefile
+++ b/graphics/qvplay/Makefile
@@ -26,6 +26,9 @@ PORTDOCS= FAQ.txt HISTORY PROTOCOL.eng PROTOCOL.txt \
README README.FreeBSD README.eng
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 4d2d4468f07b..c9d84d1cbd3e 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -33,6 +33,8 @@ CONFIGURE_ARGS= --with-gd-lib="${LOCALBASE}/lib" \
INSTALL_TARGET= site-install
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
# Hmm, GREP and TRUE seem to be defined in the bsd.port.post.mk stage.
diff --git a/graphics/scantailor/Makefile b/graphics/scantailor/Makefile
index 89be83cab25f..23fcd6433cc1 100644
--- a/graphics/scantailor/Makefile
+++ b/graphics/scantailor/Makefile
@@ -36,6 +36,9 @@ HTML_DESC= Install HTML Doxygen files
LATEX_DESC= Install LaTeX Doxygen files
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHTML} || ${PORT_OPTIONS:MLATEX}
diff --git a/graphics/sketch/Makefile b/graphics/sketch/Makefile
index 79c87c67563a..128ed4d32406 100644
--- a/graphics/sketch/Makefile
+++ b/graphics/sketch/Makefile
@@ -21,6 +21,9 @@ USE_DOS2UNIX= yes
PLIST_FILES= bin/sketch
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/graphics/xmorph/Makefile b/graphics/xmorph/Makefile
index c6c8084ac75a..16c93ba4e705 100644
--- a/graphics/xmorph/Makefile
+++ b/graphics/xmorph/Makefile
@@ -29,6 +29,9 @@ MAN1= gtkmorph.1 xmorph.1
INFO= xmorph
NO_STAGE= yes
+
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/graphics/xoris/Makefile b/graphics/xoris/Makefile
index 55e59a1570c7..7b8cf7c00fee 100644
--- a/graphics/xoris/Makefile
+++ b/graphics/xoris/Makefile
@@ -13,6 +13,8 @@ COMMENT= X11 pixel color grabber
USES= imake
USE_XORG= x11
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}