aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-25 18:52:14 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-25 18:52:14 +0000
commit92194a81a49a845c6e483ec437b3521c0fef947d (patch)
tree3c130a91a68d0d6e506bd5e91bbceb77b6f59e0b /graphics
parent65f944c0ff28da424c41f1aadfe53daa479091f0 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/picviz/Makefile11
-rw-r--r--graphics/picviz/files/patch-src__bin__CMakeLists.txt8
-rw-r--r--graphics/picviz/pkg-plist1
3 files changed, 13 insertions, 7 deletions
diff --git a/graphics/picviz/Makefile b/graphics/picviz/Makefile
index 8cca268bc2a9..69843cadaa45 100644
--- a/graphics/picviz/Makefile
+++ b/graphics/picviz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= picviz
PORTVERSION= 0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics security
MASTER_SITES= http://www.wallinfire.net/picviz/attachment/wiki/ReleasesDownload/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}?format=raw
@@ -11,13 +11,10 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}?format=raw
MAINTAINER= ports@timit.nl
COMMENT= Parallel coordinates plotter
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
- cairo.2:${PORTSDIR}/graphics/cairo
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libcairo.so:${PORTSDIR}/graphics/cairo
USE_LDCONFIG= yes
-USES= bison cmake
+USES= bison cmake pkgconfig
-MAN1= pcv.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/graphics/picviz/files/patch-src__bin__CMakeLists.txt b/graphics/picviz/files/patch-src__bin__CMakeLists.txt
new file mode 100644
index 000000000000..15ba3b167abd
--- /dev/null
+++ b/graphics/picviz/files/patch-src__bin__CMakeLists.txt
@@ -0,0 +1,8 @@
+--- ./src/bin/CMakeLists.txt.orig 2008-10-27 11:39:31.000000000 +0000
++++ ./src/bin/CMakeLists.txt 2014-01-25 16:50:49.000000000 +0000
+@@ -3,4 +3,4 @@
+ add_executable(pcv pcv.c)
+ target_link_libraries(pcv picviz)
+
+-INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/pcv DESTINATION bin)
++INSTALL(TARGETS pcv DESTINATION bin)
diff --git a/graphics/picviz/pkg-plist b/graphics/picviz/pkg-plist
index f9ab1346005a..b74ef296061c 100644
--- a/graphics/picviz/pkg-plist
+++ b/graphics/picviz/pkg-plist
@@ -29,5 +29,6 @@ lib/picviz/libpicvizoutsvg.so
lib/picviz/libpicvizrendebug.so
lib/picviz/libpicvizrenheatline.so
libdata/pkgconfig/picviz.pc
+man/man1/pcv.1.gz
@dirrm lib/picviz
@dirrm include/picviz