aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-05-28 20:21:18 +0000
committerRene Ladan <rene@FreeBSD.org>2016-05-28 20:21:18 +0000
commitb39dafe83ef1cf1d8ebd1f55376a7e8dd62f118f (patch)
treef22a36fcfef40be854b24111f6f7be83e54717ea /graphics
parent345f1376b525ab13b7aad70f937c91317932ea27 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-imaging/Makefile57
-rw-r--r--graphics/py-imaging/distinfo2
-rw-r--r--graphics/py-imaging/files/patch-CVE-2016-077524
-rw-r--r--graphics/py-imaging/files/patch-_imagingft.c11
-rw-r--r--graphics/py-imaging/files/patch-libImaging-PcdDecode.c33
-rw-r--r--graphics/py-imaging/files/patch-setup.py30
-rw-r--r--graphics/py-imaging/pkg-descr13
8 files changed, 0 insertions, 171 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 816fe94ff5c4..400df96f570b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -846,7 +846,6 @@
SUBDIR += py-graphy
SUBDIR += py-gvgen
SUBDIR += py-imagesize
- SUBDIR += py-imaging
SUBDIR += py-mcomix
SUBDIR += py-ming
SUBDIR += py-nwdiag
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
deleted file mode 100644
index e5b4b51faf2e..000000000000
--- a/graphics/py-imaging/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# Created by: Thomas Gellekum <tg@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= imaging
-PORTVERSION= 1.1.7
-PORTREVISION= 6
-CATEGORIES= graphics python
-MASTER_SITES= http://effbot.org/media/downloads/ \
- http://www.pythonware.net/storage/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= Imaging-${PORTVERSION}
-
-MAINTAINER= mainland@apeiron.net
-COMMENT= The Python Imaging Library
-
-LIB_DEPENDS= liblcms.so:graphics/lcms \
- libfreetype.so:print/freetype2
-
-DEPRECATED= Unmaintained upstream; use graphics/py-pillow
-EXPIRATION_DATE=2016-03-11
-
-USES= jpeg python
-DIST_SUBDIR= python
-USE_PYTHON= distutils autoplist concurrent
-
-PLIST_FILES= %%PYTHON_INCLUDEDIR%%/ImPlatform.h %%PYTHON_INCLUDEDIR%%/Imaging.h
-PORTDOCS= *
-PORTEXAMPLES= *
-
-CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pillow-*
-
-OPTIONS_DEFINE= DOCS TKINTER
-TKINTER_DESC= tkinter for X support
-
-OPTIONS_DEFAULT= TKINTER
-
-TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
-TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter
-
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MTKINTER}
-post-patch:
- @${REINPLACE_CMD} -e 's|if _tkinter|if None|g' ${WRKSRC}/setup.py
-.endif
-
-post-install:
-.for file in ImPlatform.h Imaging.h
- @${MKDIR} ${STAGEDIR}${PYTHON_INCLUDEDIR}
- ${INSTALL_DATA} ${WRKSRC}/libImaging/${file} ${STAGEDIR}${PYTHON_INCLUDEDIR}
-.endfor
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/Scripts/* ${STAGEDIR}${EXAMPLESDIR}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Docs/* ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/graphics/py-imaging/distinfo b/graphics/py-imaging/distinfo
deleted file mode 100644
index 032e41c036ee..000000000000
--- a/graphics/py-imaging/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (python/Imaging-1.1.7.tar.gz) = 895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211
-SIZE (python/Imaging-1.1.7.tar.gz) = 498749
diff --git a/graphics/py-imaging/files/patch-CVE-2016-0775 b/graphics/py-imaging/files/patch-CVE-2016-0775
deleted file mode 100644
index cbd446180284..000000000000
--- a/graphics/py-imaging/files/patch-CVE-2016-0775
+++ /dev/null
@@ -1,24 +0,0 @@
-From bcaaf97f4ff25b3b5b9e8efeda364e17e80858ec Mon Sep 17 00:00:00 2001
-From: wiredfool <eric-github@soroos.net>
-Date: Wed, 20 Jan 2016 22:37:28 +0000
-Subject: [PATCH] FLI overflow error fix and testcase CVE-2016-0775
-
----
- Tests/check_fli_overflow.py | 16 ++++++++++++++++
- Tests/images/fli_overflow.fli | Bin 0 -> 4645 bytes
- libImaging/FliDecode.c | 2 +-
- 3 files changed, 17 insertions(+), 1 deletion(-)
- create mode 100644 Tests/check_fli_overflow.py
- create mode 100644 Tests/images/fli_overflow.fli
-
---- libImaging/FliDecode.c
-+++ libImaging/FliDecode.c
-@@ -185,7 +185,7 @@ ImagingFliDecode(Imaging im, ImagingCodecState state, UINT8* buf, int bytes)
- /* COPY chunk */
- for (y = 0; y < state->ysize; y++) {
- UINT8* buf = (UINT8*) im->image[y];
-- memcpy(buf+x, data, state->xsize);
-+ memcpy(buf, data, state->xsize);
- data += state->xsize;
- }
- break;
diff --git a/graphics/py-imaging/files/patch-_imagingft.c b/graphics/py-imaging/files/patch-_imagingft.c
deleted file mode 100644
index b6895dfc9221..000000000000
--- a/graphics/py-imaging/files/patch-_imagingft.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- _imagingft.c.orig 2013-12-16 01:41:20.000000000 +0100
-+++ _imagingft.c 2013-12-16 01:42:34.000000000 +0100
-@@ -70,7 +70,7 @@
- const char* message;
- } ft_errors[] =
-
--#include <freetype/fterrors.h>
-+#include FT_ERRORS_H
-
- /* -------------------------------------------------------------------- */
- /* font objects */
diff --git a/graphics/py-imaging/files/patch-libImaging-PcdDecode.c b/graphics/py-imaging/files/patch-libImaging-PcdDecode.c
deleted file mode 100644
index 4c996ee4d8f4..000000000000
--- a/graphics/py-imaging/files/patch-libImaging-PcdDecode.c
+++ /dev/null
@@ -1,33 +0,0 @@
-From ae453aa18b66af54e7ff716f4ccb33adca60afd4 Mon Sep 17 00:00:00 2001
-From: wiredfool <eric-github@soroos.net>
-Date: Tue, 2 Feb 2016 05:46:26 -0800
-Subject: [PATCH] PCD decoder overruns the shuffle buffer, Fixes #568
-
----
- Tests/images/hopper.pcd | Bin 0 -> 788480 bytes
- Tests/test_file_pcd.py | 18 ++++++++++++++++++
- libImaging/PcdDecode.c | 4 ++--
- 3 files changed, 20 insertions(+), 2 deletions(-)
- create mode 100644 Tests/images/hopper.pcd
- create mode 100644 Tests/test_file_pcd.py
-
---- libImaging/PcdDecode.c
-+++ libImaging/PcdDecode.c
-@@ -47,7 +47,7 @@ ImagingPcdDecode(Imaging im, ImagingCodecState state, UINT8* buf, int bytes)
- out[0] = ptr[x];
- out[1] = ptr[(x+4*state->xsize)/2];
- out[2] = ptr[(x+5*state->xsize)/2];
-- out += 4;
-+ out += 3;
- }
-
- state->shuffle((UINT8*) im->image[state->y],
-@@ -62,7 +62,7 @@ ImagingPcdDecode(Imaging im, ImagingCodecState state, UINT8* buf, int bytes)
- out[0] = ptr[x+state->xsize];
- out[1] = ptr[(x+4*state->xsize)/2];
- out[2] = ptr[(x+5*state->xsize)/2];
-- out += 4;
-+ out += 3;
- }
-
- state->shuffle((UINT8*) im->image[state->y],
diff --git a/graphics/py-imaging/files/patch-setup.py b/graphics/py-imaging/files/patch-setup.py
deleted file mode 100644
index 6748982172b1..000000000000
--- a/graphics/py-imaging/files/patch-setup.py
+++ /dev/null
@@ -1,30 +0,0 @@
---- setup.py.orig Sun Dec 3 11:37:29 2006
-+++ setup.py Sat Jan 13 07:24:13 2007
-@@ -145,14 +145,25 @@
-
- prefix = sysconfig.get_config_var("prefix")
- if prefix:
-- add_directory(library_dirs, os.path.join(prefix, "lib"))
-- add_directory(include_dirs, os.path.join(prefix, "include"))
-+ add_directory(library_dirs,
-+ os.path.join(os.getenv("PREFIX"), "lib"))
-+ add_directory(include_dirs,
-+ os.path.join(os.getenv("PREFIX"), "include"))
-+ add_directory(include_dirs,
-+ os.path.join(os.getenv("LOCALBASE"), "include"))
-
- #
- # locate tkinter libraries
-
- if _tkinter:
- TCL_VERSION = _tkinter.TCL_VERSION[:3]
-+ TK_VERSION = _tkinter.TK_VERSION[:3]
-+ add_directory(include_dirs,
-+ os.path.join(os.getenv("PREFIX"),
-+ "include/tcl%s" % TCL_VERSION))
-+ add_directory(include_dirs,
-+ os.path.join(os.getenv("PREFIX"),
-+ "include/tk%s" % TK_VERSION))
-
- if _tkinter and not TCL_ROOT:
- # we have Tkinter but the TCL_ROOT variable was not set;
diff --git a/graphics/py-imaging/pkg-descr b/graphics/py-imaging/pkg-descr
deleted file mode 100644
index b74c2ad1e418..000000000000
--- a/graphics/py-imaging/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-The Python Imaging Library adds image processing capabilities to your
-Python interpreter. This library provides extensive file format
-support, an efficient internal representation, and fairly powerful
-image processing capabilities.
-
-The main distribution site for this software is:
-
-WWW: http://www.pythonware.com/products/pil/index.htm
-
-The PIL handbook is not included in this distribution; to get the
-latest version, check:
-
- http://www.pythonware.com/library.htm