aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-04-18 16:44:03 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-04-18 16:44:03 +0000
commitc89e73eb97ba0d6fd929c8e43f0771f3c0083bb5 (patch)
treef8477cf07cfa483908e15b1f8b6b414276bf7363 /graphics
parentb3dbf4a84747d3d91dcc1316f5fa8a38ca3f4b41 (diff)
downloadports-c89e73eb97ba0d6fd929c8e43f0771f3c0083bb5.tar.gz
ports-c89e73eb97ba0d6fd929c8e43f0771f3c0083bb5.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-visual/Makefile4
-rw-r--r--graphics/py-visual/distinfo6
-rw-r--r--graphics/py-visual/files/patch-src-gtk2-random_device.cpp11
-rw-r--r--graphics/py-visual/files/patch-src-python-num_util.cpp11
-rw-r--r--graphics/py-visual/pkg-plist2
5 files changed, 7 insertions, 27 deletions
diff --git a/graphics/py-visual/Makefile b/graphics/py-visual/Makefile
index f634ecb1f696..e412c079498b 100644
--- a/graphics/py-visual/Makefile
+++ b/graphics/py-visual/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= visual
-PORTVERSION= 4.b14
-PORTREVISION= 2
+PORTVERSION= 4.b26
+#PORTREVISION= 0
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= visualpython
diff --git a/graphics/py-visual/distinfo b/graphics/py-visual/distinfo
index 6e5057c2695b..e6ede9629545 100644
--- a/graphics/py-visual/distinfo
+++ b/graphics/py-visual/distinfo
@@ -1,3 +1,3 @@
-MD5 (visual-4.beta14.tar.bz2) = 9b1d6def88764255b6d4b6fdc2071d07
-SHA256 (visual-4.beta14.tar.bz2) = 5cc5506ddf04f3ee2f77b0be99d3a15b781c5be4cdde3d4207602887d282ca97
-SIZE (visual-4.beta14.tar.bz2) = 597800
+MD5 (visual-4.beta26.tar.bz2) = e06e55117825f4d77435339c03a0bf36
+SHA256 (visual-4.beta26.tar.bz2) = 9d55a4fb1d3a84659ef7d8514a52447863176160b51c6771f11bebebdd4c931c
+SIZE (visual-4.beta26.tar.bz2) = 614231
diff --git a/graphics/py-visual/files/patch-src-gtk2-random_device.cpp b/graphics/py-visual/files/patch-src-gtk2-random_device.cpp
deleted file mode 100644
index 150b1a017d07..000000000000
--- a/graphics/py-visual/files/patch-src-gtk2-random_device.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gtk2/random_device.cpp Sat Jul 31 20:20:28 2004
-+++ src/gtk2/random_device.cpp.port Tue Mar 6 13:17:28 2007
-@@ -32,7 +32,7 @@
- #endif
-
- // Known to be supported for GNU/Linux and Apple OSX. Probably others as well.
--#if defined(__linux__) || (defined(__APPLE__) && defined(__MACH__))
-+#if defined(__linux__) || defined(__FreeBSD__) || (defined(__APPLE__) && defined(__MACH__))
-
- // the default is the unlimited capacity device, using some secure hash
- // try "/dev/random" for blocking when the entropy pool has drained
diff --git a/graphics/py-visual/files/patch-src-python-num_util.cpp b/graphics/py-visual/files/patch-src-python-num_util.cpp
deleted file mode 100644
index ce341aea0855..000000000000
--- a/graphics/py-visual/files/patch-src-python-num_util.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/python/num_util.cpp Thu Nov 30 07:06:03 2006
-+++ src/python/num_util.cpp.port Thu Mar 8 11:18:50 2007
-@@ -230,7 +230,7 @@
- PyErr_SetString(PyExc_ValueError, "expected a PyArrayObject");
- throw_error_already_set();
- }
-- int* dims_ptr = PyArray_DIMS(arr.ptr());
-+ npy_intp* dims_ptr = PyArray_DIMS(arr.ptr());
- int the_rank = rank(arr);
- for (int i = 0; i < the_rank; i++){
- out_dims.push_back(*(dims_ptr + i));
diff --git a/graphics/py-visual/pkg-plist b/graphics/py-visual/pkg-plist
index 6c60a19e80cb..7f65c891ea8c 100644
--- a/graphics/py-visual/pkg-plist
+++ b/graphics/py-visual/pkg-plist
@@ -87,6 +87,7 @@ bin/vpython
%%PORTDOCS%%%%DOCSDIR%%/visual/texture-opacity-lighting.html
%%PORTDOCS%%%%DOCSDIR%%/visual/vector.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Tk-Visual.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/boxlighttest.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bounce.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bounce2.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/colorsliders.py
@@ -109,6 +110,7 @@ bin/vpython
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/labels.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lathe.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lorenz.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mandelbrot.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orbit.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/planar.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/randombox.py