aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-30 07:47:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-30 07:47:25 +0000
commit33c56fba95319226b53a9776f13a2f60653b963e (patch)
treea4fb6fda90e87b75b39657818817f54b850580a4 /graphics
parented776cb3639d4ae34e4c3d9da0d7cbcb10e36fcb (diff)
downloadports-33c56fba95319226b53a9776f13a2f60653b963e.tar.gz
ports-33c56fba95319226b53a9776f13a2f60653b963e.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libx3dtk/Makefile4
-rw-r--r--graphics/libx3dtk/files/patch-examples-infoReader-Date.cpp19
-rw-r--r--graphics/libx3dtk/files/patch-examples-infoReader-Date.h19
-rw-r--r--graphics/libx3dtk/files/patch-src-X3DLoader-X3D_Creator.cpp19
-rw-r--r--graphics/libx3dtk/files/patch-src-kernel-base-SFVec3f.cpp117
5 files changed, 176 insertions, 2 deletions
diff --git a/graphics/libx3dtk/Makefile b/graphics/libx3dtk/Makefile
index bc53d9fb9efb..e0825d6e8a77 100644
--- a/graphics/libx3dtk/Makefile
+++ b/graphics/libx3dtk/Makefile
@@ -27,7 +27,7 @@ USE_XLIB= yes
USE_QT_VER= 3
MAKE_ENV= QTDIR="${QT_PREFIX}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
QMAKE?= ${LOCALBASE}/bin/qmake
QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
@@ -35,7 +35,7 @@ QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "does not compile"
+BROKEN=does not compile
.endif
post-patch:
diff --git a/graphics/libx3dtk/files/patch-examples-infoReader-Date.cpp b/graphics/libx3dtk/files/patch-examples-infoReader-Date.cpp
new file mode 100644
index 000000000000..f4347029269c
--- /dev/null
+++ b/graphics/libx3dtk/files/patch-examples-infoReader-Date.cpp
@@ -0,0 +1,19 @@
+*** examples/infoReader/Date.cpp.orig Thu Sep 28 13:23:25 2006
+--- examples/infoReader/Date.cpp Thu Sep 28 13:23:36 2006
+***************
+*** 39,45 ****
+ return "\"" + m + "/" + d + "/" + y + "\"";
+ }
+
+! std::ostream& X3DTK::operator<<(std::ostream& o, const Date &date)
+ {
+ return o << date.month << "/" << date.day << "/" << date.year;
+ }
+--- 39,45 ----
+ return "\"" + m + "/" + d + "/" + y + "\"";
+ }
+
+! std::ostream& operator<<(std::ostream& o, const Date &date)
+ {
+ return o << date.month << "/" << date.day << "/" << date.year;
+ }
diff --git a/graphics/libx3dtk/files/patch-examples-infoReader-Date.h b/graphics/libx3dtk/files/patch-examples-infoReader-Date.h
new file mode 100644
index 000000000000..3ee379182274
--- /dev/null
+++ b/graphics/libx3dtk/files/patch-examples-infoReader-Date.h
@@ -0,0 +1,19 @@
+*** examples/infoReader/Date.h.orig Thu Sep 28 13:22:51 2006
+--- examples/infoReader/Date.h Thu Sep 28 13:23:03 2006
+***************
+*** 17,23 ****
+ int year;
+ };
+
+! std::ostream& X3DTK::operator<<(std::ostream& o, const Date &date);
+
+ }
+
+--- 17,23 ----
+ int year;
+ };
+
+! std::ostream& operator<<(std::ostream& o, const Date &date);
+
+ }
+
diff --git a/graphics/libx3dtk/files/patch-src-X3DLoader-X3D_Creator.cpp b/graphics/libx3dtk/files/patch-src-X3DLoader-X3D_Creator.cpp
new file mode 100644
index 000000000000..696657b1e33a
--- /dev/null
+++ b/graphics/libx3dtk/files/patch-src-X3DLoader-X3D_Creator.cpp
@@ -0,0 +1,19 @@
+*** src/X3DLoader/X3D_Creator.cpp.orig Thu Sep 28 13:04:15 2006
+--- src/X3DLoader/X3D_Creator.cpp Thu Sep 28 13:04:34 2006
+***************
+*** 147,153 ****
+ return CF;
+ }
+
+! Creator *X3DTK::X3D::joinCreator(Creator *N0, Creator *N1)
+ {
+ Creator *N = new Creator();
+
+--- 147,153 ----
+ return CF;
+ }
+
+! Creator *joinCreator(Creator *N0, Creator *N1)
+ {
+ Creator *N = new Creator();
+
diff --git a/graphics/libx3dtk/files/patch-src-kernel-base-SFVec3f.cpp b/graphics/libx3dtk/files/patch-src-kernel-base-SFVec3f.cpp
new file mode 100644
index 000000000000..eae7510cbd95
--- /dev/null
+++ b/graphics/libx3dtk/files/patch-src-kernel-base-SFVec3f.cpp
@@ -0,0 +1,117 @@
+*** src/kernel/base/SFVec3f.cpp.orig Thu Sep 28 13:02:11 2006
+--- src/kernel/base/SFVec3f.cpp Thu Sep 28 13:02:37 2006
+***************
+*** 69,85 ****
+
+ // operations on vectors
+ //overloading of the operators +, -, *
+! bool X3DTK::operator== (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ return ((v1.x == v2.x) && (v1.y == v2.y) && (v1.z == v2.z));
+ }
+
+! bool X3DTK::operator!= (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ return ((v1.x != v2.x) || (v1.y != v2.y) || (v1.z != v2.z));
+ }
+
+! SFVec3f X3DTK::operator+ (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ SFVec3f res;
+ res.x = v1.x + v2.x;
+--- 69,85 ----
+
+ // operations on vectors
+ //overloading of the operators +, -, *
+! bool operator== (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ return ((v1.x == v2.x) && (v1.y == v2.y) && (v1.z == v2.z));
+ }
+
+! bool operator!= (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ return ((v1.x != v2.x) || (v1.y != v2.y) || (v1.z != v2.z));
+ }
+
+! SFVec3f operator+ (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ SFVec3f res;
+ res.x = v1.x + v2.x;
+***************
+*** 88,94 ****
+ return res;
+ }
+
+! SFVec3f X3DTK::operator- (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ SFVec3f res;
+ res.x = v1.x - v2.x;
+--- 88,94 ----
+ return res;
+ }
+
+! SFVec3f operator- (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ SFVec3f res;
+ res.x = v1.x - v2.x;
+***************
+*** 97,103 ****
+ return res;
+ }
+
+! SFVec3f X3DTK::operator- (const SFVec3f &v)
+ {
+ SFVec3f res;
+ res.x = -v.x;
+--- 97,103 ----
+ return res;
+ }
+
+! SFVec3f operator- (const SFVec3f &v)
+ {
+ SFVec3f res;
+ res.x = -v.x;
+***************
+*** 107,118 ****
+ }
+
+ //scalar product
+! float X3DTK::operator* (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ return v1.x * v2.x + v1.y * v2.y + v1.z * v2.z;
+ }
+
+! SFVec3f X3DTK::operator* (const float a, const SFVec3f &v)
+ {
+ SFVec3f res;
+ res.x = a * v.x;
+--- 107,118 ----
+ }
+
+ //scalar product
+! float operator* (const SFVec3f &v1, const SFVec3f &v2)
+ {
+ return v1.x * v2.x + v1.y * v2.y + v1.z * v2.z;
+ }
+
+! SFVec3f operator* (const float a, const SFVec3f &v)
+ {
+ SFVec3f res;
+ res.x = a * v.x;
+***************
+*** 122,128 ****
+ }
+
+ //crossproduct
+! SFVec3f X3DTK::crossprod(const SFVec3f &v1, const SFVec3f &v2)
+ {
+ SFVec3f res;
+ res.x = v1.y * v2.z - v1.z * v2.y;
+--- 122,128 ----
+ }
+
+ //crossproduct
+! SFVec3f crossprod(const SFVec3f &v1, const SFVec3f &v2)
+ {
+ SFVec3f res;
+ res.x = v1.y * v2.z - v1.z * v2.y;