aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-22 10:13:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-22 10:13:02 +0000
commit51e65891d47e96fb907f5e2091d83d558a565dc3 (patch)
treefb1b48d7620536e03f43fe45c9e704c32574d84f /graphics
parente7bf5f8781a6f4e810d644d0d8d47c5d9677347b (diff)
downloadports-51e65891d47e96fb907f5e2091d83d558a565dc3.tar.gz
ports-51e65891d47e96fb907f5e2091d83d558a565dc3.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-GD-Arrow/Makefile25
-rw-r--r--graphics/p5-GD-Arrow/distinfo2
-rw-r--r--graphics/p5-GD-Arrow/pkg-descr23
-rw-r--r--graphics/p5-GD-Arrow/pkg-plist5
5 files changed, 56 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f0e37fa3c2e9..2cb8f49da65f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -350,6 +350,7 @@
SUBDIR += p5-Chart-PNGgraph
SUBDIR += p5-Color-Rgb
SUBDIR += p5-GD
+ SUBDIR += p5-GD-Arrow
SUBDIR += p5-GD-Barcode
SUBDIR += p5-GD-Graph
SUBDIR += p5-GD-Graph3d
diff --git a/graphics/p5-GD-Arrow/Makefile b/graphics/p5-GD-Arrow/Makefile
new file mode 100644
index 000000000000..4a4fdde5de0b
--- /dev/null
+++ b/graphics/p5-GD-Arrow/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: GD::Arrow
+# Date created: Apr 22, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= GD-Arrow
+PORTVERSION= 0.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/T/TC/TCAINE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Draw arrows using GD
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+
+PERL_CONFIGURE= YES
+
+MAN3= GD::Arrow.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Arrow/distinfo b/graphics/p5-GD-Arrow/distinfo
new file mode 100644
index 000000000000..6b75c7fd7e00
--- /dev/null
+++ b/graphics/p5-GD-Arrow/distinfo
@@ -0,0 +1,2 @@
+MD5 (GD-Arrow-0.01.tar.gz) = 9316f2d8ca3f1826e60064ef4433cb33
+SIZE (GD-Arrow-0.01.tar.gz) = 3437
diff --git a/graphics/p5-GD-Arrow/pkg-descr b/graphics/p5-GD-Arrow/pkg-descr
new file mode 100644
index 000000000000..5e2a347334bb
--- /dev/null
+++ b/graphics/p5-GD-Arrow/pkg-descr
@@ -0,0 +1,23 @@
+This is a subclass of GD::Polygon used to draw an arrow between two vertices.
+
+GD::Arrow::Full draws a full arrow between two verticies.
+
+ |\
+ +----------------------+ \
+ (X2, Y2) * * (X1, Y1)
+ +----------------------+ /
+ |/
+
+GD::Arrow::RightHalf draws a half arrow between two verticies.
+
+ (X2, Y2) *-------------------------* (X1, Y1)
+ +----------------------+ /
+ |/
+
+GD::Arrow::LeftHalf draws a half arrow between two verticies.
+
+ |\
+ +----------------------+ \
+ (X2, Y2) *-------------------------* (X1, Y1)
+
+WWW: http://search.cpan.org/dist/GD-Arrow/
diff --git a/graphics/p5-GD-Arrow/pkg-plist b/graphics/p5-GD-Arrow/pkg-plist
new file mode 100644
index 000000000000..d4c03c2b7f0c
--- /dev/null
+++ b/graphics/p5-GD-Arrow/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/GD/Arrow.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/Arrow/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/Arrow
+@unexec rmdir %D/%%SITE_PERL%%/GD 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD 2>/dev/null || true