aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-29 08:07:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-29 08:07:47 +0000
commit6082ca2e05b85fdb12f2aef925cab45c43bde641 (patch)
treea0f246c26b50146fa795ed24dbed9fe7377d3238 /graphics
parent3b663578f7f4fadc03c93424b74df4b217f91c8f (diff)
downloadports-6082ca2e05b85fdb12f2aef925cab45c43bde641.tar.gz
ports-6082ca2e05b85fdb12f2aef925cab45c43bde641.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/EZWGL/Makefile10
-rw-r--r--graphics/ecg2png/Makefile2
-rw-r--r--graphics/mpegedit/Makefile2
-rw-r--r--graphics/ray++/Makefile2
-rw-r--r--graphics/urt/Makefile6
5 files changed, 11 insertions, 11 deletions
diff --git a/graphics/EZWGL/Makefile b/graphics/EZWGL/Makefile
index 197ecc5937ce..5ed236a73984 100644
--- a/graphics/EZWGL/Makefile
+++ b/graphics/EZWGL/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include "${FILESDIR}/manpages"
post-extract:
- find ${WRKSRC} -name CVS | xargs ${RM} -rf
+ ${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -rf
post-install:
.for file in ${MAN3}
@@ -38,14 +38,14 @@ post-install:
${TAR} -C ${PREFIX}/share/examples/EZ --unlink -xf -
${TAR} -C ${WRKSRC} --exclude 'Makefile.in' -cf - demos | \
${TAR} -C ${PREFIX}/share/examples/EZ --unlink -xf -
- find ${PREFIX}/share/examples/EZ | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/examples/EZ -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/examples/EZ | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/examples/EZ -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/EZ
${TAR} -C ${WRKSRC}/doc --exclude 'misc' -cf - html ps | \
${TAR} -C ${PREFIX}/share/doc/EZ --unlink -xf -
- find ${PREFIX}/share/doc/EZ | xargs ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- find ${PREFIX}/share/doc/EZ -type f | xargs ${CHMOD} ${SHAREMODE}
+ ${FIND} ${PREFIX}/share/doc/EZ | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ ${FIND} ${PREFIX}/share/doc/EZ -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/ecg2png/Makefile b/graphics/ecg2png/Makefile
index e0d558209ddb..9ec07e1a03cd 100644
--- a/graphics/ecg2png/Makefile
+++ b/graphics/ecg2png/Makefile
@@ -25,7 +25,7 @@ QTCPPFLAGS+= -I${LOCALBASE}/include/gd
pre-patch:
@${REINPLACE_CMD} -e 's|-lqt$$|-l${QTNAME}|g' ${WRKSRC}/ecg2png/Makefile.in
- @find ${WRKSRC} -name '*.cpp' | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name '*.cpp' | ${XARGS} ${REINPLACE_CMD} -e \
's|#include <qimageio.h>||g'
@${CHMOD} ${BINMODE} ${WRKSRC}/missing
diff --git a/graphics/mpegedit/Makefile b/graphics/mpegedit/Makefile
index 9957d24059f3..c1d8127e354d 100644
--- a/graphics/mpegedit/Makefile
+++ b/graphics/mpegedit/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
USE_X_PREFIX= yes
post-extract:
- @find ${WRKSRC} -name '.depend' | xargs ${RM} -f
+ @${FIND} ${WRKSRC} -name '.depend' | ${XARGS} ${RM} -f
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mpeg_edit ${PREFIX}/bin
diff --git a/graphics/ray++/Makefile b/graphics/ray++/Makefile
index ae6201df2950..49172c7719a1 100644
--- a/graphics/ray++/Makefile
+++ b/graphics/ray++/Makefile
@@ -21,7 +21,7 @@ INSTALLS_SHLIB= yes
do-install:
@(cd ${WRKSRC} ; \
${INSTALL_DATA} ray++.so ${PREFIX}/lib ; \
- find * -name "*.h" | cpio -pdum ${PREFIX}/include/${PORTNAME} ; \
+ ${FIND} * -name "*.h" | cpio -pdum ${PREFIX}/include/${PORTNAME} ; \
${CHMOD} -R 755 ${PREFIX}/include/${PORTNAME} )
.include <bsd.port.mk>
diff --git a/graphics/urt/Makefile b/graphics/urt/Makefile
index bb87d063e18d..39fea19862aa 100644
--- a/graphics/urt/Makefile
+++ b/graphics/urt/Makefile
@@ -64,14 +64,14 @@ post-install:
cd ${PREFIX}/share/doc/urt; \
${TAR} xf $(DISTDIR)/urt-doc.tar; \
cd doc; \
- find -d . | cpio -dump ..; \
+ ${FIND} -d . | cpio -dump ..; \
cd ..; \
${RM} -rf doc; \
cd ${PREFIX}/share/examples/urt; \
${TAR} xf $(DISTDIR)/urt-img.tar; \
${CHOWN} -R root:wheel . ; \
- find . -type d -exec ${CHMOD} 755 '{}' \; ; \
- find . -type f -exec ${CHMOD} 644 '{}' \;
+ ${FIND} . -type d -exec ${CHMOD} 755 '{}' \; ; \
+ ${FIND} . -type f -exec ${CHMOD} 644 '{}' \;
.endif
.include <bsd.port.mk>