aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-02-12 04:13:41 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-02-12 04:13:41 +0000
commitcb7663b46533a7dd63bee11a7d55499ffc435016 (patch)
tree8bd5b6e1d09067b810c53fe0edf2c86a1f5d5381 /graphics
parentf7cc5b5fa8c50d7969118aef8d9b900c3cdb3aa2 (diff)
downloadports-cb7663b46533a7dd63bee11a7d55499ffc435016.tar.gz
ports-cb7663b46533a7dd63bee11a7d55499ffc435016.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/comix/Makefile39
-rw-r--r--graphics/comix/distinfo6
-rw-r--r--graphics/comix/pkg-plist17
3 files changed, 43 insertions, 19 deletions
diff --git a/graphics/comix/Makefile b/graphics/comix/Makefile
index 7aa2fb44ee6d..ae89003df35d 100644
--- a/graphics/comix/Makefile
+++ b/graphics/comix/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= comix
-PORTVERSION= 2.7
+PORTVERSION= 2.8
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,30 +19,49 @@ RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
NO_BUILD= yes
USE_GNOME= desktopfileutils pygtk2
+WANT_GNOME= yes
USE_PYTHON= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
DOCS= COPYING ChangeLog README
-MAN1= comix.1
+MAN1= comix.1 comicthumb.1
+
+.include <bsd.port.pre.mk>
+
+.if (${HAVE_GNOME:Mnautilus2}!="" || defined(WITH_THUMBNAILS)) && !defined(WITHOUT_THUMBNAILS)
+USE_GNOME+= gconf2
+#MAN1+= comicthumb.1
+GCONF_SCHEMAS= comicbook.schemas
+PLIST_SUB+= THUMBNAILS:=""
+THUMBNAILS_ENABLED=yes
+.else
+PLIST_SUB+= THUMBNAILS:="@comment "
+.endif
post-extract:
- @${GUNZIP_CMD} ${WRKSRC}/${PORTNAME}.1.gz
+ @${FIND} ${WRKSRC} -name \*.gz | ${XARGS} ${GUNZIP_CMD}
post-patch:
- @${REINPLACE_CMD} -e 's|share/man|man|g ; s|1.gz|1|g' \
- ${WRKSRC}/install.py
+ @${REINPLACE_CMD} -e "s|share/man|man|g ; s|1.gz|1|g ; \
+ s|/usr/share/mime|${PREFIX}/share/mime|g ; \
+ s|'/usr'|'${PREFIX}'|g" \
+ ${WRKSRC}/install.py
do-install:
+.if defined(THUMBNAILS_ENABLED)
+ @${MKDIR} ${PREFIX}/share/mime/packages
@(cd ${WRKSRC} ; \
${PYTHON_CMD} install.py install --installdir ${PREFIX})
- @${MKDIR} ${PREFIX}/share/mime/packages/
- @${INSTALL_DATA} ${WRKSRC}/mime/${PORTNAME}.xml \
- ${PREFIX}/share/mime/packages/
+ @${INSTALL_DATA} ${WRKSRC}/mime/comicbook.schemas \
+ ${PREFIX}/etc/gconf/schemas/
+.else
+ @(cd ${WRKSRC} ; \
+ ${PYTHON_CMD} install.py install --installdir ${PREFIX} --no-mime)
+.endif
post-install:
@-update-desktop-database
- @-update-mime-database ${PREFIX}/share/mime
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@@ -50,4 +69,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/comix/distinfo b/graphics/comix/distinfo
index cb81a7175604..8c534bca5ad9 100644
--- a/graphics/comix/distinfo
+++ b/graphics/comix/distinfo
@@ -1,3 +1,3 @@
-MD5 (comix-2.7.tar.gz) = 95dc7c392251014e73cca0a7fe562803
-SHA256 (comix-2.7.tar.gz) = 4249d6234dc7095bd501017eaab1127d769dbb1c2f9380f4060fe2349f05de26
-SIZE (comix-2.7.tar.gz) = 125077
+MD5 (comix-2.8.tar.gz) = 7b155dd914e53146cfc0962785772f82
+SHA256 (comix-2.8.tar.gz) = 6b7e176aa667342ca90dc7be2e2067e4e4858bcce82ecf5958cd21439c8e1270
+SIZE (comix-2.8.tar.gz) = 136867
diff --git a/graphics/comix/pkg-plist b/graphics/comix/pkg-plist
index ccb818a20192..3509426e022e 100644
--- a/graphics/comix/pkg-plist
+++ b/graphics/comix/pkg-plist
@@ -1,18 +1,23 @@
+%%THUMBNAILS:%%bin/comicthumb
bin/comix
share/applications/comix.desktop
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
+share/icons/hicolor/48x48/apps/comix.png
share/locale/de/LC_MESSAGES/comix.mo
share/locale/es/LC_MESSAGES/comix.mo
share/locale/pt_BR/LC_MESSAGES/comix.mo
share/locale/sv/LC_MESSAGES/comix.mo
share/locale/zh_CN/LC_MESSAGES/comix.mo
-share/mime/application/x-cbr.xml
-share/mime/application/x-cbt.xml
-share/mime/application/x-cbz.xml
-share/mime/packages/comix.xml
+%%THUMBNAILS:%%share/mime/application/x-cbr.xml
+%%THUMBNAILS:%%share/mime/application/x-cbt.xml
+%%THUMBNAILS:%%share/mime/application/x-cbz.xml
+%%THUMBNAILS:%%share/mime/packages/comix.xml
share/pixmaps/comix.png
+share/pixmaps/comix/cbr.png
+share/pixmaps/comix/cbt.png
+share/pixmaps/comix/cbz.png
share/pixmaps/comix/stock-flip-horizontal-16.png
share/pixmaps/comix/stock-flip-vertical-16.png
share/pixmaps/comix/stock-rotate-180-16.png
@@ -21,7 +26,7 @@ share/pixmaps/comix/stock-rotate-90-16.png
@dirrm share/pixmaps/comix
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications
-@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
-@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+%%THUMBNAILS:%%@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+%%THUMBNAILS:%%@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true