aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-10-09 22:12:13 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-10-09 22:12:13 +0000
commita8693b8dee82d3226a0bc0b337d3eb2085add552 (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /graphics
parent39890db4500948ba8648094ec8b290262a74d880 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Coin/Makefile1
-rw-r--r--graphics/agg/Makefile1
-rw-r--r--graphics/devil/Makefile1
-rw-r--r--graphics/iulib/Makefile1
-rw-r--r--graphics/opendx/Makefile1
-rw-r--r--graphics/osg/Makefile1
-rw-r--r--graphics/podofo/Makefile1
-rw-r--r--graphics/tgif/Makefile1
-rw-r--r--graphics/urt/Makefile1
-rw-r--r--graphics/vcg/Makefile1
-rw-r--r--graphics/xli/Makefile1
-rw-r--r--graphics/xv/Makefile1
12 files changed, 12 insertions, 0 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index 619c74f17b53..ee41c1618a97 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -17,6 +17,7 @@ COMMENT= C++ 3D graphics library based on the Open Inventor 2.1 API
LIB_DEPENDS= simage.27:${PORTSDIR}/graphics/simage
+USE_GCC= any
USE_OPENAL= al
USE_GL= yes
USE_XORG= xt x11
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index 2b58e515962a..9e39dfee5c14 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -19,6 +19,7 @@ LICENSE= GPLv2
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+USE_GCC= any
USE_XORG= x11
USE_GNOME= gnomehack
USE_SDL= sdl
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index e48718ac97c1..d5ca866754d5 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -29,6 +29,7 @@ OPTIONS= JPEG "Enable JPEG support" on \
WRKSRC= ${WRKDIR}/${DISTNAME:L}
+USE_GCC= any
USE_GNOME= pkgconfig
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I m4 -I ${LOCALBASE}/share/aclocal
diff --git a/graphics/iulib/Makefile b/graphics/iulib/Makefile
index b830d8a3cd3e..7ef0163bd1e0 100644
--- a/graphics/iulib/Makefile
+++ b/graphics/iulib/Makefile
@@ -23,6 +23,7 @@ OPTIONS= SDL "Enable SDL for graphical debugging" off \
VIDIO "Enable Video Input/Output (using ffmpeg)" off
MAKE_JOBS_SAFE= yes
+USE_GCC= any
USE_PYTHON_BUILD= yes
USE_AUTOTOOLS= libtool aclocal automake autoconf
ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I${LOCALBASE}/share/aclocal
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 327b0f4b6ef8..064857405dbe 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= MagickWand.5:${PORTSDIR}/graphics/ImageMagick \
USE_XORG= xinerama xext xpm xmu sm ice
USE_BISON= build
+USE_GCC= any
USE_GL= yes
USE_MOTIF= yes
USE_AUTOTOOLS= libtool
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index a44119a21373..a2cd5e315e19 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
CONFLICTS= osg-devel-[0-9]*
+USE_GCC= any
USE_ZIP= yes
USE_CMAKE= yes
USE_GL= gl glu
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index b7cf66d6a5c1..09064a9b09f6 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -27,6 +27,7 @@ IMPOSE_DESC= Build impose tool (needs Lua)
USE_CMAKE= yes
CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
-DPODOFO_BUILD_STATIC:BOOL=FALSE
+USE_GCC= any
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/tgif/Makefile b/graphics/tgif/Makefile
index 46c9cde181e8..aead77ddd840 100644
--- a/graphics/tgif/Makefile
+++ b/graphics/tgif/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm
OPTIONS= NLS "Enable native language support" on \
A4SIZE "Set default paper size to A4" off
+USE_GCC= any
USE_IMAKE= yes
PORTDOCS= HISTORY README
USE_XORG= x11 xext xt sm ice
diff --git a/graphics/urt/Makefile b/graphics/urt/Makefile
index 2939588f6a89..d50e361d5007 100644
--- a/graphics/urt/Makefile
+++ b/graphics/urt/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
NO_WRKSUBDIR= yes
+USE_GCC= any
USE_XORG= x11 xext
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
diff --git a/graphics/vcg/Makefile b/graphics/vcg/Makefile
index b85c3d022f76..4dde7ca999de 100644
--- a/graphics/vcg/Makefile
+++ b/graphics/vcg/Makefile
@@ -18,6 +18,7 @@ COMMENT= A Visualization Tool for compiler graphs
BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
+USE_GCC= any
USE_XORG= x11 xext
MANL= pbmrot90.l pbmshift.l pbm2hp.l vcgdemomaker.l vcg.l xvcg.l
diff --git a/graphics/xli/Makefile b/graphics/xli/Makefile
index 6a77a5a9e9ae..70ecac34ac8a 100644
--- a/graphics/xli/Makefile
+++ b/graphics/xli/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
USE_XORG= xi
+USE_GCC= any
USE_IMAKE= yes
WRKSRC= ${WRKDIR}/xli-${XLI_SNAPVER}
diff --git a/graphics/xv/Makefile b/graphics/xv/Makefile
index e4f23ce506e3..e27146e5040b 100644
--- a/graphics/xv/Makefile
+++ b/graphics/xv/Makefile
@@ -27,6 +27,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
jasper.4:${PORTSDIR}/graphics/jasper
+USE_GCC= any
USE_IMAKE= yes
USE_XORG= xext x11 xt
.if !defined(NOMAN)