aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2015-11-21 00:21:34 +0000
committerGreg Lehey <grog@FreeBSD.org>2015-11-21 00:21:34 +0000
commit32800c00c88275e233cf58b10964d65217f22800 (patch)
tree56469762dbb1784ce5a7d43eed4ed7809561e4c7 /graphics
parent460198459a3a97ca48bdd838600454ebbadbc1c5 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hugin/Makefile2
-rw-r--r--graphics/hugin/files/patch-src__tools__align_image_stack.cpp20
-rw-r--r--graphics/hugin/files/patch-src__tools__tca_correct.cpp20
3 files changed, 41 insertions, 1 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 62b507aa13cc..32f7e9db442f 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hugin
PORTVERSION= 2015.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
diff --git a/graphics/hugin/files/patch-src__tools__align_image_stack.cpp b/graphics/hugin/files/patch-src__tools__align_image_stack.cpp
new file mode 100644
index 000000000000..b9c6c98e0484
--- /dev/null
+++ b/graphics/hugin/files/patch-src__tools__align_image_stack.cpp
@@ -0,0 +1,20 @@
+--- src/tools/align_image_stack.cpp~ 2015-10-31 11:10:56.000000000 +1100
++++ src/tools/align_image_stack.cpp 2015-10-29 13:09:52.000000000 +1100
+@@ -121,7 +121,7 @@
+ }
+
+ typedef std::multimap<double, vigra::Diff2D> MapPoints;
+-static hugin_omp::Lock lock;
++static hugin_omp::Lock slock;
+
+ template <class ImageType>
+ void FineTuneInterestPoints(Panorama& pano,
+@@ -193,7 +193,7 @@
+ res.maxpos.y,
+ stereo ? ControlPoint::Y : ControlPoint::X_Y);
+ {
+- hugin_omp::ScopedLock sl(lock);
++ hugin_omp::ScopedLock sl(slock);
+ pano.addCtrlPoint(p);
+ };
+ }
diff --git a/graphics/hugin/files/patch-src__tools__tca_correct.cpp b/graphics/hugin/files/patch-src__tools__tca_correct.cpp
new file mode 100644
index 000000000000..e327a0fab142
--- /dev/null
+++ b/graphics/hugin/files/patch-src__tools__tca_correct.cpp
@@ -0,0 +1,20 @@
+--- src/tools/tca_correct.cpp~ 2015-10-31 11:10:44.000000000 +1100
++++ src/tools/tca_correct.cpp 2015-10-29 13:14:14.000000000 +1100
+@@ -465,7 +465,7 @@
+ << " commandline arguments for fulla" << endl;
+ }
+
+-static hugin_omp::Lock lock;
++static hugin_omp::Lock slock;
+ typedef std::multimap<double, vigra::Diff2D> MapPoints;
+
+ template <class ImageType>
+@@ -584,7 +584,7 @@
+ }
+ if (!cps.empty())
+ {
+- hugin_omp::ScopedLock sl(lock);
++ hugin_omp::ScopedLock sl(slock);
+ for (CPVector::const_iterator it = cps.begin(); it != cps.end(); ++it)
+ {
+ pano.addCtrlPoint(*it);