aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-10-07 05:45:04 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-10-07 05:45:04 +0000
commit581e69adb267a46bd059f3252f57fdda449034ef (patch)
tree6116b00d58bb2d3a91aafabcb58642a8c7ebeb58 /graphics
parent0993ac7ee05fb36834452d01188a887420b86d56 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/crystalspace-devel/Makefile1
-rw-r--r--graphics/crystalspace/Makefile1
-rw-r--r--graphics/inkscape/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/graphics/crystalspace-devel/Makefile b/graphics/crystalspace-devel/Makefile
index 8cd98f9099d3..b5a19267716b 100644
--- a/graphics/crystalspace-devel/Makefile
+++ b/graphics/crystalspace-devel/Makefile
@@ -32,6 +32,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
USE_GL= yes
+WANT_PERL= yes
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/crystalspace/Makefile b/graphics/crystalspace/Makefile
index 0ea75752631b..8a6efbea39ad 100644
--- a/graphics/crystalspace/Makefile
+++ b/graphics/crystalspace/Makefile
@@ -33,6 +33,7 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
USE_GL= yes
+WANT_PERL= yes
LDFLAGS+= -L/usr/lib -lc
LIBS= -lc
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 6de1506285c1..cac2427866ca 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -28,6 +28,7 @@ USE_GNOME= gnomehack desktopfileutils intlhack libxslt
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
+USE_PERL5= yes
CONFIGURE_ARGS= --with-popt
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"