aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-03-17 20:08:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-03-17 20:08:56 +0000
commitb464932ec0d39b5d9f9e7019c71b596521b15cc2 (patch)
treeba0a9d86d1aded6b9a4d1a32bc16d6f5e9d5ef31 /graphics
parent4d6422f887f36736b7ab3bb50a5dcf6012051737 (diff)
LuxRender is a physically based and unbiased rendering engine. Based on
state-of-art algorithms, LuxRender simulates the flow of light according to physical equations, thus producing realistic images of photographic quality. LuxRender is free software -- both for personal and commercial use -- and is licensed under the GPL. Fully functional exporters are available for Blender and Maya, while exporters for a growing number of 3D applications are under development. WWW: http://www.luxrender.net/
Notes
Notes: svn path=/head/; revision=251187
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/luxrender/Makefile53
-rw-r--r--graphics/luxrender/distinfo3
-rw-r--r--graphics/luxrender/pkg-descr25
-rw-r--r--graphics/luxrender/pkg-plist7
5 files changed, 89 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8d414bc1e87c..87a394176ae9 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -516,6 +516,7 @@
SUBDIR += long-exposure-tools
SUBDIR += lphoto
SUBDIR += lprof-devel
+ SUBDIR += luxrender
SUBDIR += makehuman
SUBDIR += mapnik
SUBDIR += mapserver
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
new file mode 100644
index 000000000000..0a7b481b78ff
--- /dev/null
+++ b/graphics/luxrender/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: LuxRender
+# Date created: 16 March 2010
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= luxrender
+PORTVERSION= 0.6.1
+CATEGORIES= graphics
+MASTER_SITES= http://src.luxrender.net/lux/archive/ \
+ http://freebsd.nsu.ru/distfiles/luxrender/
+DISTNAME= ${HG_NODEID}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A physically based and unbiased rendering system
+
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+
+HG_NODEID= 36533b0843bd
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_WX= 2.8
+CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
+CMAKE_VERBOSE= yes
+WRKSRC= ${WRKDIR}/lux-${HG_NODEID}
+
+DESKTOP_ENTRIES="LuxRender" "${COMMENT}" "luxrender" "luxrender" \
+ "Application;Graphics;3DGraphics;" false
+
+post-patch:
+# Respect our CFLAGS, do not append `64' suffix to `lib' on amd64, do not
+# install vendor .desktop file
+ @${REINPLACE_CMD} -e \
+ 's,^ADD_DEFINITIONS(-O3 -msse2 -mfpmath=sse -ftree-vectorize -funroll-loops -Wall ,ADD_DEFINITIONS(, ; /LIB_SUFFIX 64/d ; \
+ /luxrender.desktop/d' ${WRKSRC}/CMakeLists.txt
+
+post-configure:
+# Fix CXX_FLAGS in generated files
+ @${REINPLACE_CMD} -e \
+ 's,-pthread;-D_THREAD_SAFE,-pthread -D_THREAD_SAFE,' \
+ ${WRKSRC}/CMakeFiles/lux.dir/flags.make \
+ ${WRKSRC}/CMakeFiles/luxconsole.dir/flags.make \
+ ${WRKSRC}/CMakeFiles/luxconsole.dir/link.txt \
+ ${WRKSRC}/CMakeFiles/luxmerger.dir/flags.make \
+ ${WRKSRC}/CMakeFiles/luxmerger.dir/link.txt \
+ ${WRKSRC}/CMakeFiles/luxrender.dir/flags.make \
+ ${WRKSRC}/CMakeFiles/luxrender.dir/link.txt
+
+.include <bsd.port.mk>
diff --git a/graphics/luxrender/distinfo b/graphics/luxrender/distinfo
new file mode 100644
index 000000000000..ed945be09c70
--- /dev/null
+++ b/graphics/luxrender/distinfo
@@ -0,0 +1,3 @@
+MD5 (luxrender/36533b0843bd.tar.bz2) = 1c2702bbce97dd7dc95adbd16b0bbed7
+SHA256 (luxrender/36533b0843bd.tar.bz2) = b1fd735d17923ccae36b6438aa04b15feb5902c7fe965f440a133248fac98919
+SIZE (luxrender/36533b0843bd.tar.bz2) = 1346360
diff --git a/graphics/luxrender/pkg-descr b/graphics/luxrender/pkg-descr
new file mode 100644
index 000000000000..164c5dfb4a6b
--- /dev/null
+++ b/graphics/luxrender/pkg-descr
@@ -0,0 +1,25 @@
+LuxRender is a physically based and unbiased rendering engine. Based on
+state of the art algorithms, LuxRender simulates the flow of light according
+to physical equations, thus producing realistic images of photographic
+quality. Some of the main features of LuxRender are:
+
+ * biased and unbiased rendering: Users can choose between physical
+ accuracy (unbiased) and speed (biased);
+ * full spectral rendering: Instead of the RGB colour spectrum, full
+ spectra are used for internal calculations;
+ * hierarchical procedural and image based texture system: Procedural and
+ image based textures can be mixed in various ways, making it possible to
+ create complex materials;
+ * displacement mapping and subdivision: Based on procedural or image
+ textures, object surfaces can be transformed;
+ * network and co-operative rendering: Rendering time can be reduced by
+ combining the processing power of multiple computers;
+ * perspective (including shift lens), orthographic, and environment
+ cameras;
+ * HDR output: Render output can be saved in various file formats,
+ including .png, .tga, and .exr.
+
+Fully functional exporters are available for Blender and Maya, while
+exporters for a growing number of 3D applications are under development.
+
+WWW: http://www.luxrender.net/
diff --git a/graphics/luxrender/pkg-plist b/graphics/luxrender/pkg-plist
new file mode 100644
index 000000000000..04bf435d7176
--- /dev/null
+++ b/graphics/luxrender/pkg-plist
@@ -0,0 +1,7 @@
+bin/luxconsole
+bin/luxmerger
+bin/luxrender
+include/luxrender/api.h
+@dirrm include/luxrender
+lib/liblux.a
+share/pixmaps/luxrender.svg