aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-27 03:25:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-27 03:25:51 +0000
commiteeef65aa6469145dc152e41067832fb6df20e6e6 (patch)
tree47c51da7e25810e39e8b346bb310a267bb784513 /graphics
parente3b0edbfd60967b32951f1f7111dc346ff6bdc01 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ale/Makefile13
-rw-r--r--graphics/ale/files/patch-channel.h11
2 files changed, 22 insertions, 2 deletions
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
index 1f7b826abd7f..2e8104ae5093 100644
--- a/graphics/ale/Makefile
+++ b/graphics/ale/Makefile
@@ -17,7 +17,6 @@ PATCH_DIST_ARGS= -p1 -d ${PATCH_WRKSRC}
MAINTAINER= ports@FreeBSD.org
COMMENT= Anti-Lamenessing Engine
-USE_GCC= 3.1
USE_GMAKE= yes
.if !defined(WITHOUT_IMAGEMAGICK)
@@ -25,7 +24,17 @@ LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick
MAKE_ARGS= IMAGEMAGICK=1
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500035
+USE_REINPLACE= yes
+USE_GCC= 3.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^ g++| ${CXX}|" ${WRKSRC}/Makefile
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ale ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/ale/files/patch-channel.h b/graphics/ale/files/patch-channel.h
new file mode 100644
index 000000000000..5de445b973e7
--- /dev/null
+++ b/graphics/ale/files/patch-channel.h
@@ -0,0 +1,11 @@
+--- channel.h.orig Tue Jan 27 10:59:02 2004
++++ channel.h Tue Jan 27 10:59:10 2004
+@@ -20,7 +20,7 @@
+ #ifndef __channel_h__
+ #define __channel_h__
+
+-#include <stdint.h>
++#include <inttypes.h>
+
+ /*
+ * Channel type used by ALE.