aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 17:47:02 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-06 17:47:02 +0000
commit2635344162e282b677450d28e6380b50a7ff6a20 (patch)
tree55cc7cc379762e3a6624ff8ae92be2265c86a67d /graphics
parent26d33e9388ed49b2d1c682c076896f04aaf45fe0 (diff)
downloadports-2635344162e282b677450d28e6380b50a7ff6a20.tar.gz
ports-2635344162e282b677450d28e6380b50a7ff6a20.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/jdraw/Makefile46
-rw-r--r--graphics/jdraw/distinfo3
-rw-r--r--graphics/jdraw/files/jdraw.in9
-rw-r--r--graphics/jdraw/pkg-descr6
-rw-r--r--graphics/jdraw/pkg-plist4
6 files changed, 69 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index c26fcac7300b..94b88fa07a83 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -272,6 +272,7 @@
SUBDIR += jalbum
SUBDIR += jasper
SUBDIR += jbigkit
+ SUBDIR += jdraw
SUBDIR += jgraph
SUBDIR += jgv
SUBDIR += jhead
diff --git a/graphics/jdraw/Makefile b/graphics/jdraw/Makefile
new file mode 100644
index 000000000000..cffe4dd1b99c
--- /dev/null
+++ b/graphics/jdraw/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: jdraw
+# Date created: 2006-04-15
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jdraw
+PORTVERSION= 1.1.4
+CATEGORIES= graphics java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_v${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= nivit@email.it
+COMMENT= A pixel oriented graphics editor
+
+NO_BUILD= yes
+USE_JAVA= yes
+
+OPTIONS= PLASTIC3D "Use Plastic3DLook&Feel" on
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+SUB_FILES= ${PORTNAME}
+SUB_LIST= JAVA=${JAVA} JAVAJARDIR=${JAVAJARDIR} JDRAWJAR=${JDRAWJAR} PLASTIC3D=${PLASTIC3D}
+
+JDRAWJAR= ${DATADIR}/${DISTFILES}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PLASTIC3D)
+PLASTIC3D= "-Dlf=\"com.jgoodies.looks.plastic.Plastic3DLookAndFeel\""
+JAVA_VERSION= 1.5+
+RUN_DEPENDS+= ${JAVAJARDIR}/looks.jar:${PORTSDIR}/devel/looks
+.else
+JAVA_VERSION= 1.4+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/jdraw/distinfo b/graphics/jdraw/distinfo
new file mode 100644
index 000000000000..c9c04a236dbd
--- /dev/null
+++ b/graphics/jdraw/distinfo
@@ -0,0 +1,3 @@
+MD5 (jdraw_v1.1.4.jar) = ad8942da9873ddea09094245cd820c02
+SHA256 (jdraw_v1.1.4.jar) = c59d46942d25535d1581ee8d5091f8dd4679559bdc81aba7a078c4460859cd7e
+SIZE (jdraw_v1.1.4.jar) = 672892
diff --git a/graphics/jdraw/files/jdraw.in b/graphics/jdraw/files/jdraw.in
new file mode 100644
index 000000000000..7cb6969e16eb
--- /dev/null
+++ b/graphics/jdraw/files/jdraw.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+# $FreeBSD$
+if [ -z "$1" ]; then
+ LOOK_AND_FEEL="%%PLASTIC3D%%"
+else
+ LOOK_AND_FEEL="$1"
+fi
+
+%%JAVA%% -cp %%JAVAJARDIR%% ${LOOK_AND_FEEL} -jar %%JDRAWJAR%%
diff --git a/graphics/jdraw/pkg-descr b/graphics/jdraw/pkg-descr
new file mode 100644
index 000000000000..5e17ff489705
--- /dev/null
+++ b/graphics/jdraw/pkg-descr
@@ -0,0 +1,6 @@
+JDraw is a pixel oriented graphics editor designed especially for small
+to medium-sized pictures used to decorate web pages. It is completely
+written in Java, simple to use and saves (animated) GIFs, ICOs and PNGs.
+
+Author: jdomain@users.sourceforge.net
+WWW: http://www.j-domain.de/homepage.php?page=20
diff --git a/graphics/jdraw/pkg-plist b/graphics/jdraw/pkg-plist
new file mode 100644
index 000000000000..c3506d704cca
--- /dev/null
+++ b/graphics/jdraw/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/jdraw
+%%JAVASHAREDIR%%/jdraw/jdraw_v1.1.4.jar
+@dirrm %%JAVASHAREDIR%%/jdraw