aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-02 10:33:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-02 10:33:51 +0000
commit4c61cc5a086d67feefe468856a068761c99c8e89 (patch)
tree68f2edd1f78d9fa669d397d42fae6f827d94b014 /graphics
parent26806227fdbe9733a51d1d42f85fc3557c7d63b2 (diff)
downloadports-4c61cc5a086d67feefe468856a068761c99c8e89.tar.gz
ports-4c61cc5a086d67feefe468856a068761c99c8e89.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/icoconvert/Makefile29
-rw-r--r--graphics/icoconvert/distinfo2
-rw-r--r--graphics/icoconvert/pkg-descr8
4 files changed, 40 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 19fda961e2f9..0140cb8ec4a9 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -152,6 +152,7 @@
SUBDIR += hs-HOpenGL
SUBDIR += hs-hgl
SUBDIR += hsetroot
+ SUBDIR += icoconvert
SUBDIR += icod
SUBDIR += icontact
SUBDIR += imageindex
diff --git a/graphics/icoconvert/Makefile b/graphics/icoconvert/Makefile
new file mode 100644
index 000000000000..367a9af85e34
--- /dev/null
+++ b/graphics/icoconvert/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: icoconvert
+# Date created: Apr 30 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icoconvert
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.mox.net/downloads/
+
+MAINTAINER= flz@xbsd.org
+COMMENT= A small utility to convert Windows icon files into .xpm and .png files
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/icoconvert
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^icoconvert|all|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|^\(FLAGS=\)|\1-I${PREFIX}/include |' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/icoconvert ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/icoconvert/distinfo b/graphics/icoconvert/distinfo
new file mode 100644
index 000000000000..8c7cf96f594f
--- /dev/null
+++ b/graphics/icoconvert/distinfo
@@ -0,0 +1,2 @@
+MD5 (icoconvert-2.0.tar.gz) = 56fe4474c8eaae2c8b886331cda41aca
+SIZE (icoconvert-2.0.tar.gz) = 349954
diff --git a/graphics/icoconvert/pkg-descr b/graphics/icoconvert/pkg-descr
new file mode 100644
index 000000000000..c9ade4799cae
--- /dev/null
+++ b/graphics/icoconvert/pkg-descr
@@ -0,0 +1,8 @@
+A small utility to convert Windows .ico icon files into .xpm and .png files.
+This can be done in batches, and properly supports transparencies as well as
+non 32x32 icon sizes. It also supports 24 bit icons.
+
+WWW: http://www.mox.net/
+
+- Florent Thoumie
+flz@xbsd.org