aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-10 08:22:55 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-10 08:22:55 +0000
commit5b9fd5277921ae09ba13536915cf44d9217c6ad8 (patch)
treef78e3bcf81f4385b77e346c8cec1b8b15c33fd17 /graphics
parent81cffe2329498855865b12303c393b5bb6f1e36c (diff)
downloadports-5b9fd5277921ae09ba13536915cf44d9217c6ad8.tar.gz
ports-5b9fd5277921ae09ba13536915cf44d9217c6ad8.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/agave/Makefile40
-rw-r--r--graphics/agave/distinfo4
-rw-r--r--graphics/agave/files/patch-src__dialogs__gcs-about-window.cc30
-rw-r--r--graphics/agave/files/patch-src__gcs-mainwindow-actions.cc32
-rw-r--r--graphics/agave/files/patch-src__widgets__gcs-paletteview.h10
-rw-r--r--graphics/agave/files/patch-src__widgets__gcs-schemebox.cc11
-rw-r--r--graphics/agave/pkg-descr10
-rw-r--r--graphics/agave/pkg-plist73
8 files changed, 166 insertions, 44 deletions
diff --git a/graphics/agave/Makefile b/graphics/agave/Makefile
index 0c3d6f121f67..a86a6390f8d7 100644
--- a/graphics/agave/Makefile
+++ b/graphics/agave/Makefile
@@ -2,37 +2,39 @@
# $FreeBSD$
PORTNAME= agave
-PORTVERSION= 0.4.2
-PORTREVISION= 11
+PORTVERSION= 0.4.7
CATEGORIES= graphics gnome
MASTER_SITES= http://download.gna.org/colorscheme/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Color scheme builder for the GNOME desktop
-LIB_DEPENDS= libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
- libboost_thread.so:${PORTSDIR}/devel/boost-libs
+LICENSE= GPLv2 # (or later)
-# --disable-gnome option is broken in 0.4.2
-#OPTIONS= GNOME "Adds GNOME support" on
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libglademm-2.4.so:${PORTSDIR}/devel/libglademm24
-USES= gettext gmake pkgconfig tar:bzip2
-USE_GNOME= gnomeprefix gnomehack gnomedocutils intlhack
-GCONF_SCHEMAS= agave.schemas
+USES= gettext gmake pathfix pkgconfig tar:bzip2
+USE_GNOME= gconfmm26 gnomedocutils gnomeprefix gtkmm24
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-scrollkeeper \
+ --disable-schemas-install \
+ --disable-cppunit
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-GNU_CONFIGURE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+GCONF_SCHEMAS= agave.schemas
+
+OPTIONS_DEFINE= GNOME
+
+GNOME_USE= gnome=libgnomeui
+GNOME_CONFIGURE_ENABLE= gnome
-#.if defined(WITHOUT_GNOME)
-#CONFIGURE_ARGS+= --disable-gnome --disable-gconf
-#.else
-USE_GNOME+= libgnomeui
-LIB_DEPENDS+= libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26
-#.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's| _GCS_| __GCS_|' ${WRKSRC}/src/gcs-conf.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/agave/distinfo b/graphics/agave/distinfo
index 2d6d9c228d56..fc96f35895e5 100644
--- a/graphics/agave/distinfo
+++ b/graphics/agave/distinfo
@@ -1,2 +1,2 @@
-SHA256 (agave-0.4.2.tar.bz2) = d34aaca056b3b2f097bb38e90dce7d2b6b9aab3ebe05dea9368fd5f48c7d2bde
-SIZE (agave-0.4.2.tar.bz2) = 306607
+SHA256 (agave-0.4.7.tar.bz2) = ee19f62287d03dfbc41bb2dd86683eb13e3f9664135f4108e9c93e68994402f2
+SIZE (agave-0.4.7.tar.bz2) = 500407
diff --git a/graphics/agave/files/patch-src__dialogs__gcs-about-window.cc b/graphics/agave/files/patch-src__dialogs__gcs-about-window.cc
new file mode 100644
index 000000000000..ce2f2ad72518
--- /dev/null
+++ b/graphics/agave/files/patch-src__dialogs__gcs-about-window.cc
@@ -0,0 +1,30 @@
+--- src/dialogs/gcs-about-window.cc.orig
++++ src/dialogs/gcs-about-window.cc
+@@ -48,9 +48,9 @@
+
+ #ifdef HAVE_GNOME
+ set_url_hook(sigc::mem_fun(*this, &AboutWindow::on_link_clicked));
++#endif // HAVE_GNOME
+ set_website(PACKAGE_WEBSITE);
+ set_website_label(_("Project Website"));
+-#endif // HAVE_GNOME
+
+ Glib::ustring version(PACKAGE_VERSION);
+ set_version(version);
+@@ -111,14 +111,14 @@
+ }
+
+
++#ifdef HAVE_GNOME
+ void
+ AboutWindow::on_link_clicked(Gtk::AboutDialog& dialog,
+ const Glib::ustring& link)
+ {
+-#ifdef HAVE_GNOME
+ gnome_url_show(link.c_str(), 0);
+-#endif // HAVE_GNOME
+ }
++#endif // HAVE_GNOME
+
+ void
+ AboutWindow::on_response(int response_id)
diff --git a/graphics/agave/files/patch-src__gcs-mainwindow-actions.cc b/graphics/agave/files/patch-src__gcs-mainwindow-actions.cc
new file mode 100644
index 000000000000..1a7a12c8c419
--- /dev/null
+++ b/graphics/agave/files/patch-src__gcs-mainwindow-actions.cc
@@ -0,0 +1,32 @@
+--- src/gcs-mainwindow-actions.cc.orig
++++ src/gcs-mainwindow-actions.cc
+@@ -25,7 +25,12 @@
+
+ #include <vector>
+ #include <gtk/gtk.h>
++
++#include <config.h>
++#ifdef HAVE_GNOME
+ #include <libgnome/gnome-help.h>
++#endif // HAVE_GNOME
++
+ #include <gtkmm/iconfactory.h>
+ #include <gtkmm/stock.h>
+ #include <gtkmm/clipboard.h>
+@@ -251,9 +256,16 @@
+ /* Help Menu Actions */
+ void MainWindow::on_action_help_contents(void)
+ {
++#ifdef HAVE_GNOME
+ gnome_help_display("agave.xml",
+ NULL /* link id */,
+ NULL /* GError */);
++#else
++ gtk_show_uri(NULL,
++ "ghelp:agave",
++ gtk_get_current_event_time (),
++ NULL);
++#endif // HAVE_GNOME
+ }
+
+
diff --git a/graphics/agave/files/patch-src__widgets__gcs-paletteview.h b/graphics/agave/files/patch-src__widgets__gcs-paletteview.h
new file mode 100644
index 000000000000..70fe6a9f94b1
--- /dev/null
+++ b/graphics/agave/files/patch-src__widgets__gcs-paletteview.h
@@ -0,0 +1,10 @@
+--- src/widgets/gcs-paletteview.h.orig
++++ src/widgets/gcs-paletteview.h
+@@ -40,6 +40,7 @@
+ #include "core/gcs-types.h"
+ #include "core/gcs-color.h"
+ #include "paletteparser/palette.h"
++#include "palettetreemodel.h"
+ #include "palette-selector.h"
+
+ using namespace Gnome;
diff --git a/graphics/agave/files/patch-src__widgets__gcs-schemebox.cc b/graphics/agave/files/patch-src__widgets__gcs-schemebox.cc
new file mode 100644
index 000000000000..c7e4ee2c9ea5
--- /dev/null
+++ b/graphics/agave/files/patch-src__widgets__gcs-schemebox.cc
@@ -0,0 +1,11 @@
+--- src/widgets/gcs-schemebox.cc.orig
++++ src/widgets/gcs-schemebox.cc
+@@ -45,7 +45,7 @@
+
+ SchemeBox::SchemeBox(Scheme schm)
+ {
+- SchemeBox::SchemeBox();
++ SchemeBox();
+ set_scheme(schm);
+ }
+
diff --git a/graphics/agave/pkg-descr b/graphics/agave/pkg-descr
index c6b349ea11fe..738b2a2f7043 100644
--- a/graphics/agave/pkg-descr
+++ b/graphics/agave/pkg-descr
@@ -1,9 +1,9 @@
GNOME Colorscheme is a color scheme builder for the GNOME desktop. It is
-useful for web creation as well as room painting. It supports 6 various types
-of color schemes: Complements, Split Complements, Triads, Tetrads, Analogous,
-and Monochromatic.
+useful for web creation as well as room painting. It supports 6 various
+types of color schemes: Complements, Split Complements, Triads, Tetrads,
+Analogous, and Monochromatic.
-The user can lighten/darken the whole colorscheme or increase/decrease its
-saturation.
+The user can lighten/darken the whole colorscheme or increase/decrease
+its saturation.
WWW: http://home.gna.org/colorscheme/
diff --git a/graphics/agave/pkg-plist b/graphics/agave/pkg-plist
index 2e4d13847079..013b88e2fa59 100644
--- a/graphics/agave/pkg-plist
+++ b/graphics/agave/pkg-plist
@@ -1,39 +1,76 @@
bin/agave
share/applications/agave.desktop
-share/agave/palettes/Gnome-Palette.gpl
-share/agave/palettes/Tango-Palette.gpl
-share/agave/palettes/Visibone.gpl
-share/agave/palettes/Web.gpl
-share/agave/pixmaps/darken.png
-share/agave/pixmaps/desaturate.png
-share/agave/pixmaps/lighten.png
-share/agave/pixmaps/saturate.png
-share/agave/ui/agave.glade
-share/agave/ui/agave.ui
-share/agave/ui/bookmarkspopup.ui
+%%DATADIR%%/palettes/Gnome-Palette.gpl
+%%DATADIR%%/palettes/Tango-Palette.gpl
+%%DATADIR%%/palettes/Visibone.gpl
+%%DATADIR%%/palettes/Web.gpl
+%%DATADIR%%/pixmaps/darken.png
+%%DATADIR%%/pixmaps/desaturate.png
+%%DATADIR%%/pixmaps/lighten.png
+%%DATADIR%%/pixmaps/saturate.png
+%%DATADIR%%/ui/agave.glade
+%%DATADIR%%/ui/agave.ui
+%%DATADIR%%/ui/bookmarkspopup.ui
share/gnome/help/agave/C/agave.xml
+share/gnome/help/agave/C/figures/analogous.png
+share/gnome/help/agave/C/figures/complements.png
share/gnome/help/agave/C/figures/gtk-color-selector.png
share/gnome/help/agave/C/figures/main-window.png
+share/gnome/help/agave/C/figures/split-complements.png
+share/gnome/help/agave/C/figures/tetrads.png
+share/gnome/help/agave/C/figures/triads.png
share/gnome/help/agave/C/legal.xml
-share/omf/agave/agave-C.omf
-share/icons/hicolor/48x48/apps/agave-icon.png
-share/icons/hicolor/scalable/apps/agave-icon.svg
+share/gnome/help/agave/cs/agave.xml
+share/gnome/help/agave/cs/figures/analogous.png
+share/gnome/help/agave/cs/figures/complements.png
+share/gnome/help/agave/cs/figures/gtk-color-selector.png
+share/gnome/help/agave/cs/figures/main-window.png
+share/gnome/help/agave/cs/figures/split-complements.png
+share/gnome/help/agave/cs/figures/tetrads.png
+share/gnome/help/agave/cs/figures/triads.png
+share/gnome/help/agave/cs/legal.xml
+share/gnome/help/agave/de/agave.xml
+share/gnome/help/agave/de/figures/analogous.png
+share/gnome/help/agave/de/figures/complements.png
+share/gnome/help/agave/de/figures/gtk-color-selector.png
+share/gnome/help/agave/de/figures/main-window.png
+share/gnome/help/agave/de/figures/split-complements.png
+share/gnome/help/agave/de/figures/tetrads.png
+share/gnome/help/agave/de/figures/triads.png
+share/gnome/help/agave/de/legal.xml
+share/icons/hicolor/16x16/apps/agave.png
+share/icons/hicolor/22x22/apps/agave.png
+share/icons/hicolor/32x32/apps/agave.png
+share/icons/hicolor/scalable/apps/agave.svg
share/locale/bg/LC_MESSAGES/agave.mo
share/locale/ca/LC_MESSAGES/agave.mo
share/locale/cs/LC_MESSAGES/agave.mo
share/locale/de/LC_MESSAGES/agave.mo
share/locale/es_ES/LC_MESSAGES/agave.mo
+share/locale/fr/LC_MESSAGES/agave.mo
+share/locale/gl_ES/LC_MESSAGES/agave.mo
share/locale/it/LC_MESSAGES/agave.mo
+share/locale/ja/LC_MESSAGES/agave.mo
share/locale/nl/LC_MESSAGES/agave.mo
+share/locale/pl/LC_MESSAGES/agave.mo
share/locale/pt_BR/LC_MESSAGES/agave.mo
share/locale/ru/LC_MESSAGES/agave.mo
share/locale/sv/LC_MESSAGES/agave.mo
share/locale/zh_TW/LC_MESSAGES/agave.mo
+share/omf/agave/agave-C.omf
+share/omf/agave/agave-cs.omf
+share/omf/agave/agave-de.omf
@dirrm share/omf/agave
+@dirrmtry share/locale/gl_ES/LC_MESSAGES
+@dirrmtry share/locale/gl_ES
+@dirrm share/gnome/help/agave/de/figures
+@dirrm share/gnome/help/agave/de
+@dirrm share/gnome/help/agave/cs/figures
+@dirrm share/gnome/help/agave/cs
@dirrm share/gnome/help/agave/C/figures
@dirrm share/gnome/help/agave/C
@dirrm share/gnome/help/agave
-@dirrm share/agave/ui
-@dirrm share/agave/pixmaps
-@dirrm share/agave/palettes
-@dirrm share/agave
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/palettes
+@dirrm %%DATADIR%%