aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 07:56:43 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 07:56:43 +0000
commitddcc0de9218039c78eb34c7bc64fadb4dfe7a707 (patch)
treebee4ba075b3a0b4d3276fe1e92c704118abdbfe3 /graphics
parentfc366adb105b7bb2dc40e2a7e3e8c2022e37efe2 (diff)
downloadports-ddcc0de9218039c78eb34c7bc64fadb4dfe7a707.tar.gz
ports-ddcc0de9218039c78eb34c7bc64fadb4dfe7a707.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-CAD-Drawing/Makefile15
-rw-r--r--graphics/p5-Image-Info/Makefile13
-rw-r--r--graphics/p5-Image-Pngslimmer/Makefile14
-rw-r--r--graphics/p5-Image-Size/Makefile12
-rw-r--r--graphics/p5-SWF-File/Makefile15
5 files changed, 49 insertions, 20 deletions
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index be3f1ecf33a2..118efaa15640 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -7,7 +7,7 @@
PORTNAME= CAD-Drawing
PORTVERSION= 0.26
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,14 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Methods to create, load, and save vector graphics
-BUILD_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
+RUN_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
${SITE_PERL}/CAD/Calc.pm:${PORTSDIR}/math/p5-CAD-Calc \
${SITE_PERL}/Math/MatrixReal.pm:${PORTSDIR}/math/p5-MatrixReal \
${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/Stream/FileInputStream.pm:${PORTSDIR}/devel/p5-Stream \
${SITE_PERL}/Math/Geometry/Planar.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${BUILD_DEPENDS}
MAN3= CAD::Drawing.3 \
CAD::Drawing::Calculate.3 \
@@ -39,4 +38,10 @@ MAN3= CAD::Drawing.3 \
PERL_MODBUILD= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Image-Info/Makefile b/graphics/p5-Image-Info/Makefile
index e1fe31816ce8..5a90cc8f93a2 100644
--- a/graphics/p5-Image-Info/Makefile
+++ b/graphics/p5-Image-Info/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Image-Info
PORTVERSION= 1.30
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for getting image information
-RUN_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+RUN_DEPENDS= ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -26,4 +26,11 @@ MAN3= Image::Info.3 Image::Info::BMP.3 Image::Info::SVG.3 \
Image::Info::TIFF.3 Image::Info::PPM.3 \
Image::Info::XBM.3 Image::Info::XPM.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Image-Pngslimmer/Makefile b/graphics/p5-Image-Pngslimmer/Makefile
index 25a3e8e5f9c6..90843aabc5cb 100644
--- a/graphics/p5-Image-Pngslimmer/Makefile
+++ b/graphics/p5-Image-Pngslimmer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Image-Pngslimmer
PORTVERSION= 0.30
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,12 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Slims (dynamically created) PNGs
-RUN_DEPENDS= p5-Compress-Zlib>=2.003:${PORTSDIR}/archivers/p5-Compress-Zlib \
- p5-Compress-Raw-Zlib>=2.003:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Image::Pngslimmer.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Image-Size/Makefile b/graphics/p5-Image-Size/Makefile
index cb2672dbed84..78910d4be50d 100644
--- a/graphics/p5-Image-Size/Makefile
+++ b/graphics/p5-Image-Size/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Image-Size
PORTVERSION= 3.221
+PORTREVISION= 1
CATEGORIES= graphics www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,11 +15,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tolid@tolid.eu.org
COMMENT= Perl5 module to determine the size of images in several common formats
-RUN_DEPENDS= p5-Compress-Zlib>=2:${PORTSDIR}/archivers/p5-Compress-Zlib
-
PERL_CONFIGURE= yes
MAN1= imgsize.1
MAN3= Image::Size.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
index 1093783d0bee..faccb60514ae 100644
--- a/graphics/p5-SWF-File/Makefile
+++ b/graphics/p5-SWF-File/Makefile
@@ -7,6 +7,7 @@
PORTNAME= SWF-File
PORTVERSION= 0.42
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics www perl5
MASTER_SITES= CPAN
@@ -15,9 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Manipulating Flash movie (SWF) files
-BUILD_DEPENDS= ${SITE_PERL}/Data/TemporaryBag.pm:${PORTSDIR}/devel/p5-Data-TemporaryBag \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${SITE_PERL}/Data/TemporaryBag.pm:${PORTSDIR}/devel/p5-Data-TemporaryBag
+BUILD_DEPENDS= ${SITE_PERL}/Data/TemporaryBag.pm:${PORTSDIR}/devel/p5-Data-TemporaryBag
PERL_CONFIGURE= yes
@@ -32,4 +32,11 @@ post-patch:
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+BUILD_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>