aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-01-09 10:48:53 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-01-09 10:48:53 +0000
commit0b79a54b9ce410419276fc62d169277f2e84e5d5 (patch)
tree31dc34c05b150ac505f5539530ac93b918d39188 /graphics
parent0fcc91354e3771e001f2aed57951acb61570e9fb (diff)
downloadports-0b79a54b9ce410419276fc62d169277f2e84e5d5.tar.gz
ports-0b79a54b9ce410419276fc62d169277f2e84e5d5.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tiff/Makefile67
-rw-r--r--graphics/tiff/distinfo1
-rw-r--r--graphics/tiff/files/patch-aa15
-rw-r--r--graphics/tiff/files/patch-ab42
-rw-r--r--graphics/tiff/files/patch-ac24
-rw-r--r--graphics/tiff/pkg-comment1
-rw-r--r--graphics/tiff/pkg-descr17
-rw-r--r--graphics/tiff/pkg-plist163
8 files changed, 330 insertions, 0 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
new file mode 100644
index 000000000000..2cdd45f6d743
--- /dev/null
+++ b/graphics/tiff/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: tiff34
+# Version required: 3.4beta035
+# Date created: 8 October 1996
+# Whom: Richard Hwang <rhwang@bigpanda.com>
+# Mikhail Teterin <mi@aldan.ziplink.net>
+#
+# $Id$
+#
+
+DISTNAME= tiff-v3.4beta035
+PKGNAME= tiff-3.4b035
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.sgi.com/graphics/tiff/ \
+ ftp://ftp.isri.unlv.edu/pub/mirror/tiff/
+EXTRACT_SUFX= -tar.gz
+
+LIB_DEPENDS= jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ZIP --with-JPEG --with-DIR_BIN=${PREFIX}/bin \
+ --with-DIR_LIB=${PREFIX}/lib --with-DIR_INC=${PREFIX}/include \
+ --with-CC="${CC}" --with-GCOPTS="${CFLAGS}" \
+ --with-DIRS_LIBINC=${PREFIX}/include \
+ --with-DIR_GZLIB=/usr/lib \
+ --with-DIR_JPEGLIB=${PREFIX}/lib \
+ --with-LIBGL=no --with-LIBIMAGE=no \
+ --with-INSTALL="/bin/sh ${WRKSRC}/port/install.sh" \
+ --noninteractive
+MAN1= fax2ps.1 fax2tiff.1 gif2tiff.1 pal2rgb.1 ppm2tiff.1 ras2tiff.1 \
+ rgb2ycbcr.1 sgi2tiff.1 thumbnail.1 tiff2bw.1 tiff2ps.1 tiffcmp.1 \
+ tiffcp.1 tiffdither.1 tiffdump.1 tiffgt.1 tiffinfo.1 tiffmedian.1 \
+ tiffsplit.1 tiffsv.1
+MAN3= TIFFCheckTile.3t TIFFClose.3t TIFFComputeStrip.3t TIFFComputeTile.3t \
+ TIFFCurrentDirectory.3t TIFFCurrentRow.3t TIFFCurrentStrip.3t \
+ TIFFCurrentTile.3t TIFFDefaultStripSize.3t TIFFDefaultTileSize.3t \
+ TIFFError.3t TIFFFdOpen.3t TIFFFileName.3t TIFFFileno.3t \
+ TIFFFindCODEC.3t TIFFFlush.3t TIFFFlushData.3t TIFFGetField.3t \
+ TIFFGetMode.3t TIFFIsByteSwapped.3t TIFFIsMSB2LSB.3t TIFFIsTiled.3t \
+ TIFFIsUpSampled.3t TIFFLastDirectory.3t TIFFNumberOfStrips.3t \
+ TIFFNumberOfTiles.3t TIFFOpen.3t TIFFPrintDirectory.3t \
+ TIFFRGBAImage.3t TIFFRGBAImageBegin.3t TIFFRGBAImageEnd.3t \
+ TIFFRGBAImageGet.3t TIFFRGBAImageOK.3t TIFFReadBufferSetup.3t \
+ TIFFReadDirectory.3t TIFFReadEncodedStrip.3t TIFFReadEncodedTile.3t \
+ TIFFReadRGBAImage.3t TIFFReadRawStrip.3t TIFFReadRawTile.3t \
+ TIFFReadScanline.3t TIFFReadTile.3t TIFFRegisterCODEC.3t \
+ TIFFReverseBits.3t TIFFScanlineSize.3t TIFFSetDirectory.3t \
+ TIFFSetErrorHandler.3t TIFFSetField.3t TIFFSetSubDirectory.3t \
+ TIFFSetWarningHandler.3t TIFFStripSize.3t TIFFSwabArrayOfLong.3t \
+ TIFFSwabArrayOfShort.3t TIFFSwabLong.3t TIFFSwabShort.3t \
+ TIFFTileRowSize.3t TIFFTileSize.3t TIFFUnRegisterCODEC.3t \
+ TIFFVGetField.3t TIFFVSetField.3t TIFFVStripSize.3t TIFFVTileSize.3t \
+ TIFFWarning.3t TIFFWriteBufferSetup.3t TIFFWriteDirectory.3t \
+ TIFFWriteEncodedStrip.3t TIFFWriteEncodedTile.3t TIFFWriteRawStrip.3t \
+ TIFFWriteRawTile.3t TIFFWriteScanline.3t TIFFbuffer.3t TIFFcodec.3t \
+ TIFFfree.3t TIFFmalloc.3t TIFFmemcmp.3t TIFFmemcpy.3t TIFFmemory.3t \
+ TIFFmemset.3t TIFFquery.3t TIFFrealloc.3t TIFFsize.3t TIFFstrip.3t \
+ TIFFswab.3t TIFFtile.3t libtiff.3t
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/tiff/images
+ ${INSTALL_DATA} ${WRKSRC}/html/*.html ${PREFIX}/share/doc/tiff
+ ${INSTALL_DATA} ${WRKSRC}/html/images/* ${PREFIX}/share/doc/tiff/images
+.endif
+ /sbin/ldconfig -m ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/graphics/tiff/distinfo b/graphics/tiff/distinfo
new file mode 100644
index 000000000000..7655525528a0
--- /dev/null
+++ b/graphics/tiff/distinfo
@@ -0,0 +1 @@
+MD5 (tiff-v3.4beta035-tar.gz) = 42885f24e039e9ae72b092f787fa8b05
diff --git a/graphics/tiff/files/patch-aa b/graphics/tiff/files/patch-aa
new file mode 100644
index 000000000000..d7dc94943ef4
--- /dev/null
+++ b/graphics/tiff/files/patch-aa
@@ -0,0 +1,15 @@
+--- configure.orig Tue Jun 11 07:24:56 1996
++++ configure Sun Dec 29 05:15:45 1996
+@@ -1135,8 +1135,10 @@
+ TIFFLIBREF='-L${DEPTH}/libtiff -ltiff'
+ ;;
+ *-freebsd*)
+- DSOSUF=so.${DIST_MAJOR}.0
+- LIBCOPTS='-fpic -fPIC'
++ DSOSUF=so
++ DSOSUF_VERSION=${DSOSUF}.4.0
++ LIBCOPTS='-fpic -DPIC'
++ DSOOPTS='-Bshareable'
+ DSO=FREEBSD
+ TIFFLIBREF='-L${DEPTH}/libtiff -ltiff'
+ ;;
diff --git a/graphics/tiff/files/patch-ab b/graphics/tiff/files/patch-ab
new file mode 100644
index 000000000000..ef15901b3476
--- /dev/null
+++ b/graphics/tiff/files/patch-ab
@@ -0,0 +1,42 @@
+--- libtiff/Makefile.in.orig Tue Jun 11 00:25:00 1996
++++ libtiff/Makefile.in Tue Dec 31 13:30:39 1996
+@@ -62,7 +62,7 @@
+ #
+ CONF_LIBRARY=@CONF_JPEG@ @CONF_ZIP@
+ COPTS = @GCOPTS@
+-OPTIMIZER=-O
++#OPTIMIZER=-O
+ CFLAGS = @ENVOPTS@ @LIBCOPTS@ ${COPTS} ${OPTIMIZER} ${IPATH} ${CONF_LIBRARY}
+ #
+ SRCS = \
+@@ -190,8 +190,8 @@
+ ${AR} ${AROPTS} libtiff.@DSOSUF@ shr.o
+ rm -f shr.o
+ touch $@
+-# NetBSD 1.1 or FreeBSD
+-NETBSDdso FREEBSDdso: ${OBJS}
++# NetBSD 1.1
++NETBSDdso: ${OBJS}
+ @rm -f libtiff_pic.a
+ @${AR} cq libtiff_pic.a `lorder ${OBJS} | tsort -q`
+ ${RANLIB} libtiff_pic.a
+@@ -204,6 +204,10 @@
+ -o libtiff.@DSOSUF_VERSION@ ${OBJS} @LIBJPEG@ @LIBGZ@
+ @LN@ @LN_S@ libtiff.@DSOSUF_VERSION@ libtiff.@DSOSUF@
+ touch $@
++# FreeBSD shared lib rule
++FREEBSDdso: ${OBJS}
++ ${LD} -Bshareable -o libtiff.@DSOSUF_VERSION@ ${OBJS}
++ touch $@
+ # OSF/1 3.2 shared lib rule
+ OSFdso: ${OBJS}
+ ${LD} -o libtiff.@DSOSUF@ -shared -error_unresolved ${OBJS} @LIBJPEG@ @LIBGZ@ -lc -lm
+@@ -317,7 +321,7 @@
+ ${INSTALL} -idb tiff.sw.tools -m 555 -F @DIR_LIB@ \
+ -O libtiff.@DSOSUF_VERSION@; \
+ ${INSTALL} -idb tiff.sw.tools -F @DIR_LIB@ \
+- -ln libtiff.@DSOSUF_VERSION@ -O libtiff.@DSOSUF@; \
++ -lns libtiff.@DSOSUF_VERSION@ -O libtiff.@DSOSUF@; \
+ else \
+ ${INSTALL} -idb tiff.sw.tools -m 444 -F @DIR_LIB@ \
+ -O libtiff.@DSOSUF@; \
diff --git a/graphics/tiff/files/patch-ac b/graphics/tiff/files/patch-ac
new file mode 100644
index 000000000000..b59336bffca4
--- /dev/null
+++ b/graphics/tiff/files/patch-ac
@@ -0,0 +1,24 @@
+--- tools/Makefile.in.orig Tue Jun 11 00:25:22 1996
++++ tools/Makefile.in Tue Dec 31 13:40:41 1996
+@@ -43,17 +43,17 @@
+ INSTALL = @INSTALL@
+ #
+ COPTS = @GCOPTS@
+-OPTIMIZER=-O
++#OPTIMIZER=-O
+ IPATH = -I. -I${SRCDIR} -I${LIBDIR}
+-CFLAGS = @ENVOPTS@ ${COPTS} ${OPTIMIZER} ${IPATH}
++CFLAGS = @ENVOPTS@ ${COPTS} ${OPTIMIZER} ${IPATH} -L../libtiff
+ #
+-TIFFLIB = ${DEPTH}/libtiff/libtiff.@DSOSUF@
++TIFFLIB = ${DEPTH}/libtiff/libtiff.@DSOSUF_VERSION@
+ LIBJPEG = @LIBJPEG@
+ LIBGZ = @LIBGZ@
+ LIBTIFF = @TIFFLIBREF@
+ LIBPORT = @LIBPORT@
+ MACHLIBS= @MACHDEPLIBS@
+-LIBS = ${LIBTIFF} ${LIBJPEG} ${LIBGZ} ${LIBPORT} ${MACHLIBS}
++LIBS = ${LIBJPEG} ${LIBGZ} @LIBPORT@ @MACHDEPLIBS@ -ltiff
+ #
+ OBJS= \
+ fax2tiff.o \
diff --git a/graphics/tiff/pkg-comment b/graphics/tiff/pkg-comment
new file mode 100644
index 000000000000..8571dca86ce6
--- /dev/null
+++ b/graphics/tiff/pkg-comment
@@ -0,0 +1 @@
+libtiff provides support for the Tag Image File Format (TIFF)
diff --git a/graphics/tiff/pkg-descr b/graphics/tiff/pkg-descr
new file mode 100644
index 000000000000..4f923f7f805f
--- /dev/null
+++ b/graphics/tiff/pkg-descr
@@ -0,0 +1,17 @@
+This software provides support for the Tag Image File Format (TIFF), a
+widely used format for storing image data.
+
+Included in this software distribution is a library, libtiff, for
+reading and writing TIFF, a small collection of tools for doing simple
+manipulations of TIFF images on UNIX systems, and documentation on the
+library and tools. A small assortment of TIFF-related software for
+UNIX that has been contributed by others is also included.
+
+The library is capable of dealing with images that are written to
+follow the 5.0 or 6.0 TIFF spec. There is also considerable support
+for some of the more esoteric portions of the 6.0 TIFF spec.
+
+SGI has also added html-documentation in addition to man-pages.
+
+ TIFF web site: http://www-mipl.jpl.nasa.gov/~ndr/tiff
+Master FTP site: ftp://ftp.sgi.com/graphics/tiff
diff --git a/graphics/tiff/pkg-plist b/graphics/tiff/pkg-plist
new file mode 100644
index 000000000000..46c86658485b
--- /dev/null
+++ b/graphics/tiff/pkg-plist
@@ -0,0 +1,163 @@
+lib/libtiff.a
+lib/libtiff.so.4.0
+@exec /sbin/ldconfig -m %D/lib
+bin/fax2tiff
+bin/fax2ps
+bin/gif2tiff
+bin/pal2rgb
+bin/ppm2tiff
+bin/rgb2ycbcr
+bin/thumbnail
+bin/ras2tiff
+bin/tiff2bw
+bin/tiff2ps
+bin/tiffcmp
+bin/tiffcp
+bin/tiffdither
+bin/tiffdump
+bin/tiffinfo
+bin/tiffmedian
+bin/tiffsplit
+include/tiff.h
+include/tiffio.h
+man/man1/fax2ps.1.gz
+man/man1/fax2tiff.1.gz
+man/man1/gif2tiff.1.gz
+man/man1/pal2rgb.1.gz
+man/man1/ppm2tiff.1.gz
+man/man1/ras2tiff.1.gz
+man/man1/rgb2ycbcr.1.gz
+man/man1/sgi2tiff.1.gz
+man/man1/thumbnail.1.gz
+man/man1/tiff2bw.1.gz
+man/man1/tiff2ps.1.gz
+man/man1/tiffcmp.1.gz
+man/man1/tiffcp.1.gz
+man/man1/tiffdither.1.gz
+man/man1/tiffdump.1.gz
+man/man1/tiffgt.1.gz
+man/man1/tiffinfo.1.gz
+man/man1/tiffmedian.1.gz
+man/man1/tiffsplit.1.gz
+man/man1/tiffsv.1.gz
+man/man3/TIFFCheckTile.3t.gz
+man/man3/TIFFClose.3t.gz
+man/man3/TIFFComputeStrip.3t.gz
+man/man3/TIFFComputeTile.3t.gz
+man/man3/TIFFCurrentDirectory.3t.gz
+man/man3/TIFFCurrentRow.3t.gz
+man/man3/TIFFCurrentStrip.3t.gz
+man/man3/TIFFCurrentTile.3t.gz
+man/man3/TIFFDefaultStripSize.3t.gz
+man/man3/TIFFDefaultTileSize.3t.gz
+man/man3/TIFFError.3t.gz
+man/man3/TIFFFdOpen.3t.gz
+man/man3/TIFFFileName.3t.gz
+man/man3/TIFFFileno.3t.gz
+man/man3/TIFFFindCODEC.3t.gz
+man/man3/TIFFFlush.3t.gz
+man/man3/TIFFFlushData.3t.gz
+man/man3/TIFFGetField.3t.gz
+man/man3/TIFFGetMode.3t.gz
+man/man3/TIFFIsByteSwapped.3t.gz
+man/man3/TIFFIsMSB2LSB.3t.gz
+man/man3/TIFFIsTiled.3t.gz
+man/man3/TIFFIsUpSampled.3t.gz
+man/man3/TIFFLastDirectory.3t.gz
+man/man3/TIFFNumberOfStrips.3t.gz
+man/man3/TIFFNumberOfTiles.3t.gz
+man/man3/TIFFOpen.3t.gz
+man/man3/TIFFPrintDirectory.3t.gz
+man/man3/TIFFRGBAImage.3t.gz
+man/man3/TIFFRGBAImageBegin.3t.gz
+man/man3/TIFFRGBAImageEnd.3t.gz
+man/man3/TIFFRGBAImageGet.3t.gz
+man/man3/TIFFRGBAImageOK.3t.gz
+man/man3/TIFFReadBufferSetup.3t.gz
+man/man3/TIFFReadDirectory.3t.gz
+man/man3/TIFFReadEncodedStrip.3t.gz
+man/man3/TIFFReadEncodedTile.3t.gz
+man/man3/TIFFReadRGBAImage.3t.gz
+man/man3/TIFFReadRawStrip.3t.gz
+man/man3/TIFFReadRawTile.3t.gz
+man/man3/TIFFReadScanline.3t.gz
+man/man3/TIFFReadTile.3t.gz
+man/man3/TIFFRegisterCODEC.3t.gz
+man/man3/TIFFReverseBits.3t.gz
+man/man3/TIFFScanlineSize.3t.gz
+man/man3/TIFFSetDirectory.3t.gz
+man/man3/TIFFSetErrorHandler.3t.gz
+man/man3/TIFFSetField.3t.gz
+man/man3/TIFFSetSubDirectory.3t.gz
+man/man3/TIFFSetWarningHandler.3t.gz
+man/man3/TIFFStripSize.3t.gz
+man/man3/TIFFSwabArrayOfLong.3t.gz
+man/man3/TIFFSwabArrayOfShort.3t.gz
+man/man3/TIFFSwabLong.3t.gz
+man/man3/TIFFSwabShort.3t.gz
+man/man3/TIFFTileRowSize.3t.gz
+man/man3/TIFFTileSize.3t.gz
+man/man3/TIFFUnRegisterCODEC.3t.gz
+man/man3/TIFFVGetField.3t.gz
+man/man3/TIFFVSetField.3t.gz
+man/man3/TIFFVStripSize.3t.gz
+man/man3/TIFFVTileSize.3t.gz
+man/man3/TIFFWarning.3t.gz
+man/man3/TIFFWriteBufferSetup.3t.gz
+man/man3/TIFFWriteDirectory.3t.gz
+man/man3/TIFFWriteEncodedStrip.3t.gz
+man/man3/TIFFWriteEncodedTile.3t.gz
+man/man3/TIFFWriteRawStrip.3t.gz
+man/man3/TIFFWriteRawTile.3t.gz
+man/man3/TIFFWriteScanline.3t.gz
+man/man3/TIFFbuffer.3t.gz
+man/man3/TIFFcodec.3t.gz
+man/man3/TIFFfree.3t.gz
+man/man3/TIFFmalloc.3t.gz
+man/man3/TIFFmemcmp.3t.gz
+man/man3/TIFFmemcpy.3t.gz
+man/man3/TIFFmemory.3t.gz
+man/man3/TIFFmemset.3t.gz
+man/man3/TIFFquery.3t.gz
+man/man3/TIFFrealloc.3t.gz
+man/man3/TIFFsize.3t.gz
+man/man3/TIFFstrip.3t.gz
+man/man3/TIFFswab.3t.gz
+man/man3/TIFFtile.3t.gz
+man/man3/libtiff.3t.gz
+share/doc/tiff/bugs.html
+share/doc/tiff/build.html
+share/doc/tiff/contrib.html
+share/doc/tiff/document.html
+share/doc/tiff/images.html
+share/doc/tiff/index.html
+share/doc/tiff/internals.html
+share/doc/tiff/intro.html
+share/doc/tiff/libtiff.html
+share/doc/tiff/misc.html
+share/doc/tiff/support.html
+share/doc/tiff/tools.html
+share/doc/tiff/v3.4beta007.html
+share/doc/tiff/v3.4beta016.html
+share/doc/tiff/v3.4beta018.html
+share/doc/tiff/v3.4beta024.html
+share/doc/tiff/v3.4beta028.html
+share/doc/tiff/v3.4beta029.html
+share/doc/tiff/v3.4beta031.html
+share/doc/tiff/v3.4beta032.html
+share/doc/tiff/v3.4beta033.html
+share/doc/tiff/v3.4beta034.html
+share/doc/tiff/images/back.gif
+share/doc/tiff/images/bali.jpg
+share/doc/tiff/images/cat.gif
+share/doc/tiff/images/cover.jpg
+share/doc/tiff/images/cramps.gif
+share/doc/tiff/images/jello.jpg
+share/doc/tiff/images/jim.gif
+share/doc/tiff/images/note.gif
+share/doc/tiff/images/oxford.gif
+share/doc/tiff/images/quad.jpg
+share/doc/tiff/images/ring.gif
+share/doc/tiff/images/smallliz.jpg
+share/doc/tiff/images/strike.gif
+share/doc/tiff/images/warning.gif