aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:00 +0000
commit5898d7df5c5c0c4c33faa934a38001e755f6d900 (patch)
treeedc1328e7d68e649db202ae07c396b88869f73de /graphics
parent14b67ba33b83fe27381b6547b20370f812a4da0f (diff)
downloadports-5898d7df5c5c0c4c33faa934a38001e755f6d900.tar.gz
ports-5898d7df5c5c0c4c33faa934a38001e755f6d900.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autoq3d/Makefile23
-rw-r--r--graphics/burplex/Makefile22
-rw-r--r--graphics/easypaint/Makefile9
-rw-r--r--graphics/evolvotron/Makefile16
-rw-r--r--graphics/opencsg/Makefile17
-rw-r--r--graphics/pencil/Makefile24
-rw-r--r--graphics/qiviewer/Makefile18
-rw-r--r--graphics/qxv/Makefile15
-rw-r--r--graphics/seam-carving-gui/Makefile13
9 files changed, 46 insertions, 111 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
index ae69e15328dd..1c5a332280ec 100644
--- a/graphics/autoq3d/Makefile
+++ b/graphics/autoq3d/Makefile
@@ -9,16 +9,15 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/AutoQ3D%20${PORTVERSION}
DISTNAME= AutoQ3DCommunity${PORTVERSION:C/\./-/}qt4source
MAINTAINER= nemysis@gmx.ch
-COMMENT= Qt4 quick 3D model editor
+COMMENT= Qt 4 quick 3D model editor
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USE_DOS2UNIX= yes
+USES= dos2unix qmake
USE_GL= glu
USE_ZIP= yes
-USE_QT4= corelib gui opengl \
- moc_build qmake_build
+USE_QT4= corelib gui opengl moc_build
PORTDOCS= 3DQformat.txt ChangeLog.txt
@@ -27,9 +26,8 @@ DESKTOP_ENTRIES="AutoQ3D" \
"AutoQ3D" \
"AutoQ3D" \
"Graphics;3DGraphics;Qt;" \
- false
+ true
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
.for file in src/main.cpp src/fgui/cadform.cpp src/dialogs/prgsettings.cpp
@@ -37,16 +35,13 @@ post-patch:
's|/usr/share/AutoQ3D-Community|${DATADIR}|g' ${WRKSRC}/${file}
.endfor
-do-configure:
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS})
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${PREFIX}/bin
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images *.htm *.qm" ${DATADIR})
- ${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png ${PREFIX}/share/pixmaps
+ ${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${STAGEDIR}${PREFIX}/bin
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "images *.htm *.qm" ${STAGEDIR}${DATADIR})
+ ${INSTALL_DATA} ${WRKSRC}/AutoQ3D.png ${STAGEDIR}${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/burplex/Makefile b/graphics/burplex/Makefile
index 744fc1fdf914..eee51f4882de 100644
--- a/graphics/burplex/Makefile
+++ b/graphics/burplex/Makefile
@@ -14,31 +14,23 @@ LICENSE= BSD
RUN_DEPENDS= ${LOCALBASE}/bin/dcraw:${PORTSDIR}/graphics/dcraw
-USE_QT4= gui qmake_build uic_build moc_build rcc_build \
+USES= qmake
+USE_QT4= gui uic_build moc_build rcc_build \
imageformats_run
-HAS_CONFIGURE= yes
-QMAKE_ARGS= -recursive PREFIX=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAN7= burplex.7
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} \
+ man/man7/burplex.7.gz
DESKTOP_ENTRIES= "burplex" "${COMMENT}" "" \
- "burplex" "" "false"
+ "burplex" "" "true"
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},' \
${WRKSRC}/mainwindow.cpp
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKE_ARGS} ${QMAKEFLAGS}
-
do-install:
- ${MKDIR} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${MANPREFIX}/man/man7
- ${INSTALL_MAN} ${WRKSRC}/burplex.7 ${MANPREFIX}/man/man7
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/burplex.7 ${STAGEDIR}${MANPREFIX}/man/man7
.include <bsd.port.mk>
diff --git a/graphics/easypaint/Makefile b/graphics/easypaint/Makefile
index a25dadbfd2b8..e9114ffaf190 100644
--- a/graphics/easypaint/Makefile
+++ b/graphics/easypaint/Makefile
@@ -13,7 +13,8 @@ COMMENT= Easy graphic editing program
LICENSE= GPLv3
-USE_QT4= gui xml qmake_build uic_build moc_build rcc_build
+USES= qmake
+USE_QT4= gui xml uic_build moc_build rcc_build
QPROFILE= easyPaint
WRKSRC= ${WRKDIR}/${QPROFILE}
@@ -22,11 +23,7 @@ DESKTOP_ENTRIES="easyPaint" "${COMMENT}" "" "easypaint" \
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${QMAKE}
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${QPROFILE} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${QPROFILE} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index ff43d416c189..ca0107b2f8ba 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -19,10 +19,11 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT4= corelib gui xml moc_build qmake_build
+USES= qmake
+USE_QT4= corelib gui xml moc_build
USE_PYTHON= yes
-HAS_CONFIGURE= yes
-CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
+QMAKE_ARGS+= VERSION_NUMBER="${PORTVERSION}"
+QMAKE_SOURCE_PATH= ${WRKSRC}/main.pro
MAKE_JOBS_UNSAFE= yes
PORTDOCS= NEWS README TODO USAGE evolvotron.html
@@ -44,21 +45,14 @@ CXXFLAGS+= -include ${WRKSRC}/${i}/${i}_precompiled.h \
-I${WRKSRC}/${i}
.endfor
.else
-QMAKEFLAGS+= CONFIG+=precompile_header
+QMAKE_ARGS+= CONFIG+=precompile_header
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' \
- ${WRKSRC}/configure ${WRKSRC}/VERSION
@${REINPLACE_CMD} -e \
'/^CONFIG/s|precompile_header|| ; \
/DEFINES/s|_LINUX|_BSD|' ${WRKSRC}/common.pro
-post-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX} \
- VERSION_NUMBER="${PORTVERSION}" main.pro
-
do-install:
.for i in evolvotron evolvotron_mutate evolvotron_render
${INSTALL_PROGRAM} ${WRKSRC}/${i}/${i} ${STAGEDIR}${PREFIX}/bin/
diff --git a/graphics/opencsg/Makefile b/graphics/opencsg/Makefile
index 1ad85f12b051..b817c3097059 100644
--- a/graphics/opencsg/Makefile
+++ b/graphics/opencsg/Makefile
@@ -11,22 +11,17 @@ DISTNAME= OpenCSG-${PORTVERSION}
MAINTAINER= mr@FreeBSD.org
COMMENT= Constructive Solid Geometry rendering library
+USES= qmake
USE_GL= glew
+USE_QT4= corelib gui
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
-USE_QT4= qmake_build corelib gui
PLIST_SUB= PORTVERSION=${PORTVERSION}
-#MAKE_JOBS_UNSAFE=yes
-
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${QMAKE} src.pro
do-install:
${INSTALL_LIB} ${WRKDIR}/${DISTNAME}/lib/libopencsg.so.${PORTVERSION} \
- ${PREFIX}/lib
- ${LN} -sf libopencsg.so.${PORTVERSION} ${PREFIX}/lib/libopencsg.so.1
- ${LN} -sf libopencsg.so.${PORTVERSION} ${PREFIX}/lib/libopencsg.so
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/include/opencsg.h ${PREFIX}/include
+ ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf libopencsg.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libopencsg.so.1
+ ${LN} -sf libopencsg.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libopencsg.so
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/include/opencsg.h ${STAGEDIR}${PREFIX}/include
.include <bsd.port.mk>
diff --git a/graphics/pencil/Makefile b/graphics/pencil/Makefile
index aaa9b491dc5f..addab1b99c28 100644
--- a/graphics/pencil/Makefile
+++ b/graphics/pencil/Makefile
@@ -22,38 +22,26 @@ LIB_DEPENDS+= ming:${PORTSDIR}/graphics/ming \
drm:${PORTSDIR}/graphics/libdrm
USE_ZIP= yes
-USES= gettext iconv
+USES= gettext iconv qmake
USE_GNOME= glib20
-USE_QT4= gui moc_build qmake_build rcc_build xml_build opengl_build
+USE_QT4= gui moc_build rcc_build xml_build opengl_build
USE_XORG= xi xrender xrandr xfixes xcursor xinerama xext x11 xau xdmcp \
xxf86vm xdamage
USE_GL= gl glu
+QMAKE_ARGS+= INCLUDEPATH+=${LOCALBASE}/include/ming
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
PLIST_FILES= bin/pencil
PORTDOCS= README TODO
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} -unix PREFIX=${PREFIX} \
- INCLUDEPATH+=${LOCALBASE}/include/ming \
- ${PORTNAME}.pro
-
post-patch:
@${MKDIR} ${WRKSRC}/src/external/freebsd
@${CP} ${FILESDIR}/src-external-freebsd-freebsd.cpp \
${WRKSRC}/src/external/freebsd/freebsd.cpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Pencil ${PREFIX}/bin/pencil
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/Pencil ${STAGEDIR}${PREFIX}/bin/pencil
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/qiviewer/Makefile b/graphics/qiviewer/Makefile
index 3f85ee1ad670..03f90752e338 100644
--- a/graphics/qiviewer/Makefile
+++ b/graphics/qiviewer/Makefile
@@ -12,10 +12,10 @@ COMMENT= Fast and lightweight image viewer
LICENSE= GPLv2
+USES= qmake
USE_BZIP2= yes
-USE_QT4= gui xml dbus imageformats linguist_build qmake_build \
+USE_QT4= gui xml dbus imageformats_run linguist_build \
moc_build rcc_build uic_build
-QMAKEFLAGS+= PREFIX="${PREFIX}"
PLIST_FILES= bin/qiviewer \
share/applications/qiviewer.desktop \
@@ -29,19 +29,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/src
OPTIONS_DEFINE= WEBP
WEBP_DESC= Support for WebP image format (experimental)
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MWEBP}
-QMAKEFLAGS+= CONFIG+=enable-webp
-PLIST_SUB+= WEBP=""
-.else
-PLIST_SUB+= WEBP="@comment "
-.endif
-
-do-configure:
- @cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS}
+WEBP_QMAKE_ON= CONFIG+=enable-webp
post-configure:
${REINPLACE_CMD} -e 's|lrelease|lrelease-qt4|g' \
diff --git a/graphics/qxv/Makefile b/graphics/qxv/Makefile
index 8f0b805ba46c..d843379b18eb 100644
--- a/graphics/qxv/Makefile
+++ b/graphics/qxv/Makefile
@@ -8,7 +8,7 @@ CATEGORIES+= graphics
MASTER_SITES= http://labs.freehackers.org/attachments/download/422/
MAINTAINER= cy@FreeBSD.org
-COMMENT= A QT4 program that displays images of various formats
+COMMENT= Qt 4 program that displays images of various formats
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -24,22 +24,15 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
expat.6:${PORTSDIR}/textproc/expat2 \
xcb.2:${PORTSDIR}/x11/xcb
-USES= iconv
+USES= iconv qmake
USE_BZIP2= yes
USE_XORG= sm xrender xext x11 xau xdmcp ice
-USE_QT4= corelib gui qmake_build moc_build uic_build rcc_build
+USE_QT4= corelib gui moc_build uic_build rcc_build
MAKE_JOBS_UNSAFE= yes
-HAS_CONFIGURE= yes
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
-
do-install:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${INSTALL_PROGRAM} ${PORTNAME} ${LOCALBASE}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/graphics/seam-carving-gui/Makefile b/graphics/seam-carving-gui/Makefile
index 1fbd95c03f27..e55096b62c92 100644
--- a/graphics/seam-carving-gui/Makefile
+++ b/graphics/seam-carving-gui/Makefile
@@ -11,21 +11,14 @@ DISTNAME= SeamCarvingGui-Src-${PORTVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= The Seam Carving GUI is a GUI front end to CAIR
-HAS_CONFIGURE= yes
-
-USE_GMAKE= yes
-USE_QT4= gui imageformats_run moc_build qmake_build uic_build
+USES= gmake qmake
+USE_QT4= gui imageformats_run moc_build uic_build
WRKSRC= ${WRKDIR}/Src\ Seam\ Carving\ GUI\ ${PORTVERSION}
PLIST_FILES= bin/SeamCarvingGui
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && \
- ${SETENV} QMAKESPEC="${QMAKESPEC}" ${QMAKE} seam-carving-gui.pro
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/SeamCarvingGui ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/SeamCarvingGui ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>