aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-10-13 21:18:59 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-10-13 21:18:59 +0000
commitc82561879596d9bc9d1de07067427039ab55c3d7 (patch)
tree9910eb6f6766eaea58ec75e888fe54ccc3e6b6c6 /graphics
parent725f471b155d747fbfc5f9a07d98efb390ab7cbe (diff)
downloadports-c82561879596d9bc9d1de07067427039ab55c3d7.tar.gz
ports-c82561879596d9bc9d1de07067427039ab55c3d7.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-gphoto2/Makefile28
-rw-r--r--graphics/py-gphoto2/distinfo2
-rw-r--r--graphics/py-gphoto2/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4c147616ea0a..c4c51675299b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -834,6 +834,7 @@
SUBDIR += py-gimp
SUBDIR += py-glewpy
SUBDIR += py-goocanvas
+ SUBDIR += py-gphoto2
SUBDIR += py-graph
SUBDIR += py-graph-core
SUBDIR += py-graph-dot
diff --git a/graphics/py-gphoto2/Makefile b/graphics/py-gphoto2/Makefile
new file mode 100644
index 000000000000..95b6bf93aa10
--- /dev/null
+++ b/graphics/py-gphoto2/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= gphoto2
+PORTVERSION= 1.2.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= python-gphoto2
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Python bindings for libgphoto2
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
+
+USES= pkgconfig python
+USE_PYTHON= autoplist concurrent distutils
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e 's|share/python-gphoto2/examples|${EXAMPLESDIR:S,${PREFIX}/,,}|' \
+ -e 's|share/python-gphoto2|${DOCSDIR:S,${PREFIX}/,,}|' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gphoto2/distinfo b/graphics/py-gphoto2/distinfo
new file mode 100644
index 000000000000..c8b39acc875f
--- /dev/null
+++ b/graphics/py-gphoto2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-gphoto2/gphoto2-1.2.0.tar.gz) = 444277aacbd48d6262057da76a71c6da8824b752ac49c00640a5f4e6bba066a0
+SIZE (python-gphoto2/gphoto2-1.2.0.tar.gz) = 925837
diff --git a/graphics/py-gphoto2/pkg-descr b/graphics/py-gphoto2/pkg-descr
new file mode 100644
index 000000000000..11ecffd07aab
--- /dev/null
+++ b/graphics/py-gphoto2/pkg-descr
@@ -0,0 +1,3 @@
+python-gphoto2 provides Python interface to libgphoto2.
+
+WWW: http://pypi.python.org/pypi/gphoto2/