aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-18 05:57:17 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-18 05:57:17 +0000
commit1402ed0dcc689c483f843cafb8b5a492ba7ac5db (patch)
tree8946d0c3ffb0c5fec72f684a33265b6195ba527b /graphics
parent924ce8f82106305db268f59d30fb219a2ea563cf (diff)
downloadports-1402ed0dcc689c483f843cafb8b5a492ba7ac5db.tar.gz
ports-1402ed0dcc689c483f843cafb8b5a492ba7ac5db.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ming/Makefile6
-rw-r--r--graphics/ming/distinfo2
-rw-r--r--graphics/ming/files/Makefile17
-rw-r--r--graphics/ming/pkg-plist5
-rw-r--r--graphics/py-ming/Makefile4
-rw-r--r--graphics/py-ming/files/patch-Makefile26
-rw-r--r--graphics/ruby-ming/Makefile5
7 files changed, 38 insertions, 27 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 3e0376450054..2e8b4b9230b9 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2a
CATEGORIES= graphics
MASTER_SITES= http://www.opaque.net/ming/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-examples${EXTRACT_SUFX}
@@ -40,7 +40,9 @@ post-extract:
${SED} -e 's:"\.\./\.\./ming\.h":<ming.h>:g' \
${WRKSRC}/ming.h > ${WRKSRC}/mingpp.h
cd ${WRKSRC}/../util && \
- ${RM} bindump.c hexdump.c listmp3.c
+ ${RM} bindump.c decompile5.c hexdump.c listmp3.c
+# cd ${WRKSRC}/../php_ext && ${LN} -sf ming-4.0.6.c ming.c
+ ${RM} -rf ${WRKSRC}/../examples/results
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
diff --git a/graphics/ming/distinfo b/graphics/ming/distinfo
index 47b7a6a95d40..4799263aa154 100644
--- a/graphics/ming/distinfo
+++ b/graphics/ming/distinfo
@@ -1,2 +1,2 @@
-MD5 (ming-0.1.1.tgz) = d3da8902e238266d2d8f7c1ec8e1668a
+MD5 (ming-0.2a.tgz) = 72b25da0af28d9cb025c2aaf3fd0185c
MD5 (ming-examples.tgz) = 592953577628990479c9be78522da8de
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index de6ce6146b4c..ad7640a226dc 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
LIB= ming
-SHLIB_MAJOR?= 2
+SHLIB_MAJOR?= 3
SHLIB_MINOR?= 0
CFLAGS+= -I${.CURDIR}/actioncompiler -I${.CURDIR}/blocks -I${LOCALBASE}/include
LDADD= -lm
@@ -12,12 +12,16 @@ SRCS= blocklist.c \
movie.c \
movieclip.c \
position.c \
+ shape_cubic.c \
shape_util.c \
text_util.c \
+ actioncompiler/assembler.c \
actioncompiler/compile.c \
actioncompiler/compileaction.c \
- actioncompiler/compiler.tab.c \
- actioncompiler/lex.yy.c \
+ actioncompiler/lex.swf4.c \
+ actioncompiler/lex.swf5.c \
+ actioncompiler/swf4compiler.tab.c \
+ actioncompiler/swf5compiler.tab.c \
blocks/action.c \
blocks/bitmap.c \
blocks/block.c \
@@ -41,6 +45,7 @@ SRCS= blocklist.c \
blocks/mp3.c \
blocks/output.c \
blocks/outputblock.c \
+ blocks/placeobject.c \
blocks/rect.c \
blocks/shape.c \
blocks/soundstream.c \
@@ -57,6 +62,7 @@ INCS= blocklist.h \
movie.h \
movieclip.h \
position.h \
+ shape_cubic.h \
shape_util.h \
text_util.h
@@ -89,8 +95,9 @@ pre-_includeinstall:
beforeinstall:
${INSTALL} -C -o ${INCOWN} -g ${INCGRP} -m ${INCMODE} \
${.CURDIR}/blocks/block.h ${.CURDIR}/blocks/cxform.h \
- ${.CURDIR}/blocks/error.h ${.CURDIR}/blocks/input.h \
- ${.CURDIR}/blocks/matrix.h ${.CURDIR}/blocks/outputblock.h \
+ ${.CURDIR}/blocks/error.h ${.CURDIR}/blocks/exports.h \
+ ${.CURDIR}/blocks/input.h ${.CURDIR}/blocks/matrix.h \
+ ${.CURDIR}/blocks/outputblock.h ${.CURDIR}/blocks/placeobject.h \
${.CURDIR}/blocks/sound.h ${.CURDIR}/blocks/sprite.h \
${.CURDIR}/blocks/swf.h ${.CURDIR}/blocks/blocktypes.h \
${.CURDIR}/blocks/character.h ${.CURDIR}/blocks/libswf.h \
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index fc60ca3473a7..32a1973dd4eb 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -15,6 +15,7 @@ include/ming/ming.h
include/ming/movie.h
include/ming/movieclip.h
include/ming/position.h
+include/ming/shape_cubic.h
include/ming/shape_util.h
include/ming/text_util.h
include/ming/blocks/block.h
@@ -22,12 +23,14 @@ include/ming/blocks/blocktypes.h
include/ming/blocks/character.h
include/ming/blocks/cxform.h
include/ming/blocks/error.h
+include/ming/blocks/exports.h
include/ming/blocks/input.h
include/ming/blocks/libswf.h
include/ming/blocks/matrix.h
include/ming/blocks/method.h
include/ming/blocks/output.h
include/ming/blocks/outputblock.h
+include/ming/blocks/placeobject.h
include/ming/blocks/rect.h
include/ming/blocks/sound.h
include/ming/blocks/sprite.h
@@ -37,7 +40,7 @@ include/ming/mingpp.h
@dirrm include/ming
lib/libming.a
lib/libming.so
-lib/libming.so.2
+lib/libming.so.3
%%PORTDOCS%%share/doc/ming/CHANGES
%%PORTDOCS%%share/doc/ming/CREDITS
%%PORTDOCS%%share/doc/ming/README
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 9ce31afb7f51..ad62d902c0e6 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2a
CATEGORIES= graphics python
MASTER_SITES= # none
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +15,7 @@ DISTFILES= # none
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/ming:patch
-LIB_DEPENDS= ming.2:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming
USE_PYTHON= yes
diff --git a/graphics/py-ming/files/patch-Makefile b/graphics/py-ming/files/patch-Makefile
index c876db7624bd..93d22f947949 100644
--- a/graphics/py-ming/files/patch-Makefile
+++ b/graphics/py-ming/files/patch-Makefile
@@ -1,20 +1,20 @@
---- Makefile.orig Mon Mar 19 10:26:33 2001
-+++ Makefile Tue Mar 20 18:28:05 2001
+--- Makefile.orig Sat Aug 18 02:05:55 2001
++++ Makefile Tue Sep 18 14:44:34 2001
@@ -1,13 +1,13 @@
- #PYINCDIR = /usr/local/include/python2.0
- #PYLIBDIR = /usr/local/lib/python2.0
-
--PYINCDIR = /usr/include/python1.5
--PYLIBDIR = /usr/lib/python1.5
+-PYINCDIR = /usr/local/include/python2.0
+-PYLIBDIR = /usr/local/lib/python2.0
+PYINCDIR = ${LOCALBASE}/include/${PYTHON_VERSION}
+PYLIBDIR = ${LOCALBASE}/lib/${PYTHON_VERSION}
+ #PYINCDIR = /usr/include/python1.5
+ #PYLIBDIR = /usr/lib/python1.5
+
-all:
+all: mingcmodule.so
- mingcmodule.so: ming_wrap.o ../libming.a
-- gcc -g -Wall -shared -o mingcmodule.so ming_wrap.o ../libming.a
-+ ${CC} -g -Wall -L .. -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
+ mingcmodule.so: ming_wrap.o
+- gcc -g -Wall -shared -o mingcmodule.so ming_wrap.o -lming
++ ${CC} -g -Wall -shared -o mingcmodule.so ming_wrap.o -L${LOCALBASE}/lib -lming
mingc.pyd: ming_wrap.o
dllwrap --dllname mingc.pyd --driver-name gcc --def mingc.def \
@@ -25,9 +25,9 @@
- gcc -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
+ ${CC} ${CFLAGS} -g -Wall -I .. -I ${PYINCDIR} -fpic -c ming_wrap.c
- swig:
- swig -I.. -python ming.i
-@@ -24,4 +24,4 @@
+ ../libming.a:
+ cd ..; make static
+@@ -27,4 +27,4 @@
rm -f mingcmodule.so core *~ *.o ming.pyc
install:
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index 1ea65b152ee7..54366c24d277 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.1.1
-PORTREVISION= 2
+PORTVERSION= 0.2a
CATEGORIES= graphics ruby
MASTER_SITES= # none
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -17,7 +16,7 @@ MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel \
${NONEXISTENT}:${PORTSDIR}/graphics/ming:patch
-LIB_DEPENDS= ming.2:${PORTSDIR}/graphics/ming
+LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming
USE_RUBY= yes
USE_RUBY_EXTCONF= yes