aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-01-27 10:07:38 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-01-27 10:07:38 +0000
commit32674286e4fe68c84898d9c3d74d2a7cbe458147 (patch)
tree197f0d9a5f7c68969dc6a8222cb6ba29145ee923 /graphics
parentaa86803c215c95ec3908bdc6cbea6efb03da46fe (diff)
downloadports-32674286e4fe68c84898d9c3d74d2a7cbe458147.tar.gz
ports-32674286e4fe68c84898d9c3d74d2a7cbe458147.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gqview-devel/Makefile24
-rw-r--r--graphics/gqview-devel/distinfo2
-rw-r--r--graphics/gqview-devel/files/patch-Makefile.in11
-rw-r--r--graphics/gqview-devel/pkg-plist6
-rw-r--r--graphics/gqview/Makefile2
5 files changed, 26 insertions, 19 deletions
diff --git a/graphics/gqview-devel/Makefile b/graphics/gqview-devel/Makefile
index d0e14eb9440c..a13a6b0f9f90 100644
--- a/graphics/gqview-devel/Makefile
+++ b/graphics/gqview-devel/Makefile
@@ -7,37 +7,33 @@
#
PORTNAME= gqview
-PORTVERSION= 1.3.7
+PORTVERSION= 1.3.8
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -devel
-MAINTAINER= cthulhu@cthulhu.ru
+MAINTAINER= philip@FreeBSD.org
COMMENT= Another gtk2-based graphic file viewer
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext-old \
+ iconv.3:${PORTSDIR}/converters/libiconv \
+ png.5:${PORTSDIR}/graphics/png
+
USE_X_PREFIX= yes
USE_GNOME= gtk20
-WANT_GNOME= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-.if !defined(WANT_GNOME) || defined(WITHOUT_GNOME)
-CONFIGURE_ARGS= --disable-gnome
-.endif
+CONFLICTS= gqview-1.2.*
MAN1= gqview.1
-post-patch:
- @${REINPLACE_CMD} -e 's|INCLUDED_LIBINTL=yes|INCLUDED_LIBINTL=no|g' \
- ${WRKSRC}/aclocal.m4
-
-post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/gqview
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/gqview
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/graphics/gqview-devel/distinfo b/graphics/gqview-devel/distinfo
index f3eb49e0dda3..6a92693394a1 100644
--- a/graphics/gqview-devel/distinfo
+++ b/graphics/gqview-devel/distinfo
@@ -1 +1 @@
-MD5 (gqview-1.3.7.tar.gz) = 6a579839a5f283d2eb6e8713e4c97602
+MD5 (gqview-1.3.8.tar.gz) = c379f28a9c1128e9ab40bec9e5605eb0
diff --git a/graphics/gqview-devel/files/patch-Makefile.in b/graphics/gqview-devel/files/patch-Makefile.in
new file mode 100644
index 000000000000..66ae71a523f3
--- /dev/null
+++ b/graphics/gqview-devel/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Jan 23 18:33:39 2004
++++ Makefile.in Fri Jan 23 18:37:29 2004
+@@ -547,7 +547,7 @@
+
+ info-am:
+
+-install-data-am: install-desktopDATA install-helpDATA install-iconDATA \
++install-data-am: install-desktopDATA install-iconDATA \
+ install-man
+
+ install-exec-am:
diff --git a/graphics/gqview-devel/pkg-plist b/graphics/gqview-devel/pkg-plist
index 4969cda180a4..39207d96b080 100644
--- a/graphics/gqview-devel/pkg-plist
+++ b/graphics/gqview-devel/pkg-plist
@@ -1,6 +1,5 @@
bin/gqview
-%%PORTDOCS%%share/doc/gqview/README
-share/gqview/README
+%%PORTDOCS%%%%DOCSDIR%%/README
share/locale/bg/LC_MESSAGES/gqview.mo
share/locale/cs/LC_MESSAGES/gqview.mo
share/locale/da/LC_MESSAGES/gqview.mo
@@ -28,5 +27,4 @@ share/locale/uk/LC_MESSAGES/gqview.mo
share/locale/vi/LC_MESSAGES/gqview.mo
share/locale/zh_CN.GB2312/LC_MESSAGES/gqview.mo
share/locale/zh_TW/LC_MESSAGES/gqview.mo
-%%PORTDOCS%%@dirrm share/doc/gqview
-@dirrm share/gqview
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index e79e97aea648..1c76cdd8c918 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -25,6 +25,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-gnome
+CONFLICTS= gqview-devel-1.3.*
+
MAN1= gqview.1
post-patch: