aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-19 21:16:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-02-19 21:16:23 +0000
commit5cab51406a30f53053d1d6bacc760246fdf5a0ba (patch)
tree1033cc97f2b1e671d736b1af576a803fc5e17afc /graphics
parentbf3ad450d767a2b75254be6ca805091daae9d700 (diff)
downloadports-5cab51406a30f53053d1d6bacc760246fdf5a0ba.tar.gz
ports-5cab51406a30f53053d1d6bacc760246fdf5a0ba.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gdal/Makefile3
-rw-r--r--graphics/gdal/distinfo4
-rw-r--r--graphics/gdal/files/patch-GDALmake.opt.in10
-rw-r--r--graphics/gdal/files/patch-configure98
-rw-r--r--graphics/gdal/files/patch-frmts-openjpeg-GNUmakefile13
-rw-r--r--graphics/gdal/files/patch-frmts-openjpeg-makefile.vc15
-rw-r--r--graphics/gdal/files/patch-frmts-openjpeg-openjpegdataset.cpp51
7 files changed, 3 insertions, 191 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 38a955d79c30..f97650809af0 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gdal
-PORTVERSION= 1.11.1
-PORTREVISION= 6
+PORTVERSION= 1.11.2
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/${PORTVERSION}/ \
ftp://ftp.remotesensing.org/pub/gdal/${PORTVERSION}/ \
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index 91b0ab32d030..00c748da5c1c 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdal-1.11.1.tar.xz) = 20e1042cff15a71038459a299732fb342428aea9912f32df30c85790fcab6302
-SIZE (gdal-1.11.1.tar.xz) = 6464112
+SHA256 (gdal-1.11.2.tar.xz) = b7a18956dde45d636330d558a3a804684565f9356b517ddec223462f2430075f
+SIZE (gdal-1.11.2.tar.xz) = 6473004
diff --git a/graphics/gdal/files/patch-GDALmake.opt.in b/graphics/gdal/files/patch-GDALmake.opt.in
deleted file mode 100644
index 16d9dd6d7e2f..000000000000
--- a/graphics/gdal/files/patch-GDALmake.opt.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- GDALmake.opt.in.orig 2014-04-17 04:04:49.000000000 +0800
-+++ GDALmake.opt.in 2014-08-22 15:05:34.068301293 +0800
-@@ -192,6 +192,7 @@
- # JPEG-2000 Support via OpenJPEG library.
- #
- HAVE_OPENJPEG = @HAVE_OPENJPEG@
-+OPENJPEG_VERSION = @OPENJPEG_VERSION@
-
- #
- # MrSID support via LizardTech's DSDK
diff --git a/graphics/gdal/files/patch-configure b/graphics/gdal/files/patch-configure
deleted file mode 100644
index 9b87b885cc0a..000000000000
--- a/graphics/gdal/files/patch-configure
+++ /dev/null
@@ -1,98 +0,0 @@
---- configure.orig 2014-04-17 04:04:49.000000000 +0800
-+++ configure 2014-08-22 15:05:34.087308378 +0800
-@@ -746,6 +746,7 @@
- FGDB_INC
- FGDB_LIB
- FGDB_ENABLED
-+OPENJPEG_VERSION
- HAVE_OPENJPEG
- JASPER_FLAGS
- HAVE_JASPER
-@@ -22200,14 +22201,78 @@
- if test "$HAVE_OPENJPEG" = "yes"; then
- LIBS="-lopenjp2 $LIBS"
- fi
-+ else
-+ for ac_header in openjpeg-2.1/openjpeg.h
-+do :
-+ ac_fn_c_check_header_mongrel "$LINENO" "openjpeg-2.1/openjpeg.h" "ac_cv_header_openjpeg_2_1_openjpeg_h" "$ac_includes_default"
-+if test "x$ac_cv_header_openjpeg_2_1_openjpeg_h" = xyes; then :
-+ cat >>confdefs.h <<_ACEOF
-+#define HAVE_OPENJPEG_2_1_OPENJPEG_H 1
-+_ACEOF
-+
-+fi
-+
-+done
-+
-+ if test "$ac_cv_header_openjpeg_2_1_openjpeg_h" = "yes"; then
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for opj_stream_set_user_data_length in -lopenjp2" >&5
-+$as_echo_n "checking for opj_stream_set_user_data_length in -lopenjp2... " >&6; }
-+if ${ac_cv_lib_openjp2_opj_stream_set_user_data_length+:} false; then :
-+ $as_echo_n "(cached) " >&6
-+else
-+ ac_check_lib_save_LIBS=$LIBS
-+LIBS="-lopenjp2 $LIBS"
-+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-+/* end confdefs.h. */
-+
-+/* Override any GCC internal prototype to avoid an error.
-+ Use char because int might match the return type of a GCC
-+ builtin and then its argument prototype would still apply. */
-+#ifdef __cplusplus
-+extern "C"
-+#endif
-+char opj_stream_set_user_data_length ();
-+int
-+main ()
-+{
-+return opj_stream_set_user_data_length ();
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+if ac_fn_c_try_link "$LINENO"; then :
-+ ac_cv_lib_openjp2_opj_stream_set_user_data_length=yes
-+else
-+ ac_cv_lib_openjp2_opj_stream_set_user_data_length=no
-+fi
-+rm -f core conftest.err conftest.$ac_objext \
-+ conftest$ac_exeext conftest.$ac_ext
-+LIBS=$ac_check_lib_save_LIBS
-+fi
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_openjp2_opj_stream_set_user_data_length" >&5
-+$as_echo "$ac_cv_lib_openjp2_opj_stream_set_user_data_length" >&6; }
-+if test "x$ac_cv_lib_openjp2_opj_stream_set_user_data_length" = xyes; then :
-+ HAVE_OPENJPEG=yes
-+else
-+ HAVE_OPENJPEG=no
-+fi
-+
-+ if test "$HAVE_OPENJPEG" = "yes"; then
-+ OPENJPEG_VERSION=20100
-+ LIBS="-lopenjp2 $LIBS"
-+ fi
-+ fi
- fi
- else
-
- HAVE_OPENJPEG=yes
- if test -r $with_openjpeg/include/openjpeg-2.0/openjpeg.h ; then
- EXTRA_INCLUDES="-I$with_openjpeg/include $EXTRA_INCLUDES"
-+ elif test -r $with_openjpeg/include/openjpeg-2.1/openjpeg.h ; then
-+ OPENJPEG_VERSION=20100
-+ EXTRA_INCLUDES="-I$with_openjpeg/include $EXTRA_INCLUDES"
- else
-- as_fn_error $? "openjpeg.h not found in $with_openjpeg/include/openjpeg-2.0" "$LINENO" 5
-+ as_fn_error $? "openjpeg.h not found in $with_openjpeg/include/openjpeg-2.0 or $with_openjpeg/include/openjpeg-2.1" "$LINENO" 5
- fi
-
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for opj_stream_set_user_data_length in -lopenjp2" >&5
-@@ -22266,6 +22331,7 @@
-
- HAVE_OPENJPEG=$HAVE_OPENJPEG
-
-+OPENJPEG_VERSION=$OPENJPEG_VERSION
-
-
-
diff --git a/graphics/gdal/files/patch-frmts-openjpeg-GNUmakefile b/graphics/gdal/files/patch-frmts-openjpeg-GNUmakefile
deleted file mode 100644
index aa564a6cdfe0..000000000000
--- a/graphics/gdal/files/patch-frmts-openjpeg-GNUmakefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- frmts/openjpeg/GNUmakefile.orig 2014-04-17 04:04:48.000000000 +0800
-+++ frmts/openjpeg/GNUmakefile 2014-08-22 15:05:34.071310422 +0800
-@@ -5,6 +5,10 @@
-
- CPPFLAGS := $(GDAL_INCLUDE) $(CPPFLAGS)
-
-+ifneq ($(OPENJPEG_VERSION),)
-+CPPFLAGS := $(CPPFLAGS) -DOPENJPEG_VERSION=$(OPENJPEG_VERSION)
-+endif
-+
- default: $(OBJ:.o=.$(OBJ_EXT))
-
- clean:
diff --git a/graphics/gdal/files/patch-frmts-openjpeg-makefile.vc b/graphics/gdal/files/patch-frmts-openjpeg-makefile.vc
deleted file mode 100644
index 2fb86dae986b..000000000000
--- a/graphics/gdal/files/patch-frmts-openjpeg-makefile.vc
+++ /dev/null
@@ -1,15 +0,0 @@
---- frmts/openjpeg/makefile.vc.orig 2014-04-17 04:04:48.000000000 +0800
-+++ frmts/openjpeg/makefile.vc 2014-08-22 15:05:34.090310184 +0800
-@@ -5,7 +5,11 @@
-
- !INCLUDE $(GDAL_ROOT)\nmake.opt
-
--EXTRAFLAGS = $(OPENJPEG_CFLAGS)
-+EXTRAFLAGS = $(OPENJPEG_CFLAGS) $(OPENJPEG_VERSION_CFLAGS)
-+
-+!IFDEF OPENJPEG_VERSION
-+OPENJPEG_VERSION_CFLAGS = -DOPENJPEG_VERSION=$(OPENJPEG_VERSION)
-+!ENDIF
-
- default: $(OBJ)
- xcopy /D /Y *.obj ..\o
diff --git a/graphics/gdal/files/patch-frmts-openjpeg-openjpegdataset.cpp b/graphics/gdal/files/patch-frmts-openjpeg-openjpegdataset.cpp
deleted file mode 100644
index 5e37cbe5a414..000000000000
--- a/graphics/gdal/files/patch-frmts-openjpeg-openjpegdataset.cpp
+++ /dev/null
@@ -1,51 +0,0 @@
---- frmts/openjpeg/openjpegdataset.cpp.orig 2014-04-17 04:04:48.000000000 +0800
-+++ frmts/openjpeg/openjpegdataset.cpp 2014-08-22 15:05:34.093308400 +0800
-@@ -29,8 +29,12 @@
-
- /* This file is to be used with openjpeg 2.0 */
-
-+#if defined(OPENJPEG_VERSION) && OPENJPEG_VERSION >= 20100
-+#include <openjpeg-2.1/openjpeg.h>
-+#else
- #include <stdio.h> /* openjpeg.h needs FILE* */
- #include <openjpeg-2.0/openjpeg.h>
-+#endif
- #include <vector>
-
- #include "gdaljp2abstractdataset.h"
-@@ -612,7 +616,11 @@
- opj_stream_set_read_function(pStream, JP2OpenJPEGDataset_Read);
- opj_stream_set_seek_function(pStream, JP2OpenJPEGDataset_Seek);
- opj_stream_set_skip_function(pStream, JP2OpenJPEGDataset_Skip);
-+#if defined(OPENJPEG_VERSION) && OPENJPEG_VERSION >= 20100
-+ opj_stream_set_user_data(pStream, fp, NULL);
-+#else
- opj_stream_set_user_data(pStream, fp);
-+#endif
-
- if(!opj_read_header(pStream,pCodec,&psImage))
- {
-@@ -948,7 +956,11 @@
- opj_stream_set_read_function(pStream, JP2OpenJPEGDataset_Read);
- opj_stream_set_seek_function(pStream, JP2OpenJPEGDataset_Seek);
- opj_stream_set_skip_function(pStream, JP2OpenJPEGDataset_Skip);
-+#if defined(OPENJPEG_VERSION) && OPENJPEG_VERSION >= 20100
-+ opj_stream_set_user_data(pStream, fp, NULL);
-+#else
- opj_stream_set_user_data(pStream, fp);
-+#endif
-
- opj_image_t * psImage = NULL;
- OPJ_INT32 nX0,nY0;
-@@ -1496,7 +1508,11 @@
- opj_stream_set_write_function(pStream, JP2OpenJPEGDataset_Write);
- opj_stream_set_seek_function(pStream, JP2OpenJPEGDataset_Seek);
- opj_stream_set_skip_function(pStream, JP2OpenJPEGDataset_Skip);
-+#if defined(OPENJPEG_VERSION) && OPENJPEG_VERSION >= 20100
-+ opj_stream_set_user_data(pStream, fp, NULL);
-+#else
- opj_stream_set_user_data(pStream, fp);
-+#endif
-
- if (!opj_start_compress(pCodec,psImage,pStream))
- {