aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-20 19:41:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-02-20 19:41:41 +0000
commit75f59fe02096b3fc9411e392912557db43b42e5f (patch)
treeaa23fe3ca23aa8dd5205e2b57a67d310ac92e547 /graphics
parent8b858757749ddff645c938ae58a52c5c1438e33c (diff)
downloadports-75f59fe02096b3fc9411e392912557db43b42e5f.tar.gz
ports-75f59fe02096b3fc9411e392912557db43b42e5f.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gnash-devel/Makefile17
-rw-r--r--graphics/gnash-devel/distinfo6
-rw-r--r--graphics/gnash-devel/files/patch-plugin-klash-klash_part.cpp11
-rw-r--r--graphics/gnash-devel/files/patch-plugin-klash4-klash_part.cpp11
-rw-r--r--graphics/gnash-devel/files/patch-utilities-dumpshm.cpp35
-rw-r--r--graphics/gnash-devel/pkg-plist25
6 files changed, 75 insertions, 30 deletions
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index d3c54e5d1cbc..2456fe327ed8 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 20100110
-PORTREVISION= 1
+PORTVERSION= 20100218
CATEGORIES= graphics
MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
PKGNAMESUFFIX= -devel
@@ -23,7 +22,7 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
CONFLICTS= gnash-[0-9]*
-REVISION= 11741
+REVISION= 11957
USE_BZIP2= yes
USE_GMAKE= yes
@@ -39,7 +38,6 @@ MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-boost-lib="${LOCALBASE}/lib" \
- --with-agg-lib="${LOCALBASE}/lib" \
--disable-testsuite --enable-avm2 \
--with-plugins-install=system \
--sysconfdir="${WRKDIR}/etc" \
@@ -53,7 +51,9 @@ PLIST_SUB+= GNASHVER="${GNASHVER}"
USE_LDCONFIG= ${PREFIX}/lib/gnash
-MAN1= cygnal.1 dumpshm.1 flvdumper.1 gnash.1 gprocessor.1 soldumper.1 rtmpget.1
+MAN1= cygnal.1 dumpshm.1 findmicrophones.1 findwebcams.1 \
+ flvdumper.1 gnash.1 gprocessor.1 gtk-gnash.1 kde4-gnash.1 \
+ rtmpget.1 soldumper.1
OPTIONS= PLUGIN "Enable browser plugin" on \
CYGNAL "Enable Cygnal media server" off \
@@ -244,9 +244,8 @@ pre-configure:
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|libdir)|exec_prefix)/libdata|' \
${WRKSRC}/Makefile.in
-
-pre-build:
- cat ${WRKSRC}/libbase/Makefile
+ @${REINPLACE_CMD} -e '/^man1dir =/ s|=.*|= ${MAN1PREFIX}/man/man1|' \
+ ${WRKSRC}/doc/C/Makefile.in
post-install:
.for conf in ${CONFIG_FILES}
@@ -276,5 +275,7 @@ post-install:
x-maintainer-make-snapshot:
bzr export --revision=${REVISION} --root=gnash-trunk \
${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} http://bzr.savannah.gnu.org/r/gnash/trunk/
+ ${RM} -f ${DISTINFO}
+ ${MAKE} makesum
.include <bsd.port.post.mk>
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
index 377425840ae9..e6533a4143fe 100644
--- a/graphics/gnash-devel/distinfo
+++ b/graphics/gnash-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-trunk-11741.tar.bz2) = b9f8c994c31546cdc54c160c908b7aa4
-SHA256 (gnash-trunk-11741.tar.bz2) = 307895229eece080f4bedf2196aec3ebb92217a186c5ff13727779b9a6aa2087
-SIZE (gnash-trunk-11741.tar.bz2) = 4399182
+MD5 (gnash-trunk-11957.tar.bz2) = 4fb470b193c4ef446c501e441678c8a3
+SHA256 (gnash-trunk-11957.tar.bz2) = 1c3a68838baca48cba686c91615a5f1e5a40d0fb62d6dae7201db94d713b11cd
+SIZE (gnash-trunk-11957.tar.bz2) = 4463437
diff --git a/graphics/gnash-devel/files/patch-plugin-klash-klash_part.cpp b/graphics/gnash-devel/files/patch-plugin-klash-klash_part.cpp
new file mode 100644
index 000000000000..edd622becdee
--- /dev/null
+++ b/graphics/gnash-devel/files/patch-plugin-klash-klash_part.cpp
@@ -0,0 +1,11 @@
+--- plugin/klash/klash_part.cpp.orig 2009-03-02 18:29:45.000000000 +0300
++++ plugin/klash/klash_part.cpp 2009-03-06 05:27:45.000000000 +0300
+@@ -160,7 +160,7 @@
+ QString procname;
+ char *gnash_env = getenv("KLASH_PLAYER");
+ if (!gnash_env) {
+- procname = GNASHBINDIR "/kde-gnash";
++ procname = GNASHBINDIR "/kde3-gnash";
+ } else {
+ procname = gnash_env;
+ }
diff --git a/graphics/gnash-devel/files/patch-plugin-klash4-klash_part.cpp b/graphics/gnash-devel/files/patch-plugin-klash4-klash_part.cpp
new file mode 100644
index 000000000000..31cd5c7a6f28
--- /dev/null
+++ b/graphics/gnash-devel/files/patch-plugin-klash4-klash_part.cpp
@@ -0,0 +1,11 @@
+--- plugin/klash4/klash_part.cpp.orig 2009-03-02 18:29:50.000000000 +0300
++++ plugin/klash4/klash_part.cpp 2009-03-06 05:44:08.000000000 +0300
+@@ -147,7 +147,7 @@
+ }
+ }
+ KParts::Part::setWidget (new KlashView (wparent));
+- setXMLFile("klashpartui.rc");
++ setXMLFile("klash/klashpartui.rc");
+ setProgressInfoEnabled (false);
+
+ if (m_fullscreen)
diff --git a/graphics/gnash-devel/files/patch-utilities-dumpshm.cpp b/graphics/gnash-devel/files/patch-utilities-dumpshm.cpp
index 9f467b0344b1..75ce12a240e2 100644
--- a/graphics/gnash-devel/files/patch-utilities-dumpshm.cpp
+++ b/graphics/gnash-devel/files/patch-utilities-dumpshm.cpp
@@ -1,17 +1,20 @@
---- utilities/dumpshm.cpp.orig 2010-01-10 20:05:25.000000000 +0300
-+++ utilities/dumpshm.cpp 2010-01-11 02:30:47.000000000 +0300
-@@ -314,10 +314,10 @@
- }
+--- utilities/dumpshm.cpp.orig 2010-02-11 02:20:23.000000000 +0300
++++ utilities/dumpshm.cpp 2010-02-18 22:26:30.000000000 +0300
+@@ -316,12 +316,12 @@
+ }
#ifdef IPC_PERM_KEY
- if (shmseg.shm_segsz == 64528) {
-- log_debug(_("Found it! \"set LCShmKey 0x %s %s \" in your ~/.gnashrc", hex, shmseg.shm_perm.IPC_PERM_KEY));
-- log_debug(_("Last changed on: %s", ctime(&shmseg.shm_ctime)));
-- log_debug(_("Last attached on: %s", ctime(&shmseg.shm_atime)));
-- log_debug(_("Last detached on: %s", ctime(&shmseg.shm_dtime)));
-+ log_debug("Found it! \"set LCShmKey 0x %s %s \" in your ~/.gnashrc", hex, shmseg.shm_perm.IPC_PERM_KEY);
-+ log_debug("Last changed on: %s", ctime(&shmseg.shm_ctime));
-+ log_debug("Last attached on: %s", ctime(&shmseg.shm_atime));
-+ log_debug("Last detached on: %s", ctime(&shmseg.shm_dtime));
- return shmseg.shm_perm.IPC_PERM_KEY;
- }
- #endif // end of IPC_PERM_KEY
+ if (shmseg.shm_segsz == 64528) {
+- log_debug(_("Found it! \"set LCShmKey %s\" in your ~/.gnashrc",
++ log_debug(_("Found it! \"set LCShmKey %s\" in your ~/.gnashrc"),
+ boost::io::group(hex, showbase,
+- shmseg.shm_perm.IPC_PERM_KEY)));
+- log_debug(_("Last changed on: %s", ctime(&shmseg.shm_ctime)));
+- log_debug(_("Last attached on: %s", ctime(&shmseg.shm_atime)));
+- log_debug(_("Last detached on: %s", ctime(&shmseg.shm_dtime)));
++ shmseg.shm_perm.IPC_PERM_KEY));
++ log_debug(_("Last changed on: %s"), ctime(&shmseg.shm_ctime));
++ log_debug(_("Last attached on: %s"), ctime(&shmseg.shm_atime));
++ log_debug(_("Last detached on: %s"), ctime(&shmseg.shm_dtime));
+ return shmseg.shm_perm.IPC_PERM_KEY;
+ }
+ #endif // end of IPC_PERM_KEY
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
index cba7cab2199e..a5067dad26ff 100644
--- a/graphics/gnash-devel/pkg-plist
+++ b/graphics/gnash-devel/pkg-plist
@@ -1,4 +1,3 @@
-bin/dumpshm
%%GSTREAMER%%bin/findmicrophones
%%GSTREAMER%%bin/findwebcams
bin/flvdumper
@@ -15,6 +14,7 @@ bin/soldumper
%%KPARTS%%share/apps/klash/klashpartui.rc
@comment Should be //KPARTS//, but it is installed regardless of whether plugin is enabled
%%KPARTS%%share/services/klash_part.desktop
+include/gnash/AMF.h
include/gnash/AVM1Movie_as.h
include/gnash/AccessibilityProperties_as.h
include/gnash/Accessibility_as.h
@@ -73,14 +73,19 @@ include/gnash/Event_as.h
include/gnash/ExportableResource.h
include/gnash/ExternalInterface_as.h
include/gnash/FileFilter_as.h
+include/gnash/FileTypes.h
include/gnash/FocusEvent_as.h
include/gnash/FontStyle_as.h
include/gnash/FontType_as.h
include/gnash/Font_as.h
include/gnash/FrameLabel_as.h
include/gnash/FullScreenEvent_as.h
+include/gnash/GC.h
include/gnash/Geometry.h
include/gnash/GlowFilter_as.h
+include/gnash/GnashException.h
+include/gnash/GnashImage.h
+include/gnash/GnashImageJpeg.h
include/gnash/GnashKey.h
include/gnash/GradientBevelFilter_as.h
include/gnash/GradientGlowFilter_as.h
@@ -111,6 +116,7 @@ include/gnash/KeyLocation_as.h
include/gnash/KeyboardEvent_as.h
include/gnash/Keyboard_as.h
include/gnash/LineScaleMode_as.h
+include/gnash/LineStyle.h
include/gnash/LoaderContext_as.h
include/gnash/LoaderInfo_as.h
include/gnash/Loader_as.h
@@ -127,14 +133,17 @@ include/gnash/Movie.h
include/gnash/MovieClip.h
include/gnash/MovieClip_as.h
include/gnash/MovieFactory.h
+include/gnash/NamingPolicy.h
include/gnash/NativeFunction.h
include/gnash/NetConnection_as.h
include/gnash/NetStatusEvent_as.h
include/gnash/NetStream_as.h
+include/gnash/NetworkAdapter.h
include/gnash/NewObjectSample_as.h
include/gnash/ObjectEncoding_as.h
include/gnash/ObjectURI.h
include/gnash/PixelSnapping_as.h
+include/gnash/Point2d.h
include/gnash/Point_as.h
include/gnash/PrintJobOptions_as.h
include/gnash/PrintJobOrientation_as.h
@@ -145,6 +154,7 @@ include/gnash/Property.h
include/gnash/PropertyList.h
include/gnash/Proxy_as.h
include/gnash/RGBA.h
+include/gnash/Range2d.h
include/gnash/Rectangle_as.h
include/gnash/Relay.h
include/gnash/Responder_as.h
@@ -202,6 +212,7 @@ include/gnash/TextSnapshot_as.h
include/gnash/TimerEvent_as.h
include/gnash/Timer_as.h
include/gnash/Transform_as.h
+include/gnash/URL.h
include/gnash/URLLoaderDataFormat_as.h
include/gnash/URLLoader_as.h
include/gnash/URLRequestHeader_as.h
@@ -223,19 +234,27 @@ include/gnash/builtin_function.h
include/gnash/cxform.h
include/gnash/display_pkg.h
include/gnash/drag_state.h
+include/gnash/dsodefs.h
include/gnash/event_id.h
include/gnash/external_pkg.h
include/gnash/fill_style.h
include/gnash/filters_pkg.h
include/gnash/fn_call.h
include/gnash/geom_pkg.h
+include/gnash/gettext.h
include/gnash/gnash.h
+include/gnash/log.h
include/gnash/movie_definition.h
include/gnash/movie_root.h
include/gnash/namedStrings.h
include/gnash/net_pkg.h
-include/gnash/styles.h
+include/gnash/rc.h
+include/gnash/ref_counted.h
+include/gnash/smart_ptr.h
+include/gnash/snappingrange.h
+include/gnash/string_table.h
include/gnash/text_pkg.h
+include/gnash/utility.h
%%KPARTS%%lib/kde3/libklashpart.so
%%KPARTS%%lib/kde3/libklashpart.la
%%KPARTS4%%kde4/share/apps/klash/pluginsinfo
@@ -260,9 +279,9 @@ lib/gnash/libgnashamf.so
%%AGG%%lib/gnash/libgnashagg.la
%%AGG%%lib/gnash/libgnashagg.so
%%AGG%%lib/gnash/libgnashagg.so.0
+lib/gnash/libgnashbase-%%GNASHVER%%.so
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashbase.so.0
lib/gnash/libgnashcore-%%GNASHVER%%.so
lib/gnash/libgnashcore.la
lib/gnash/libgnashcore.so