aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /graphics
parent91926e92b73e3751382216a16044c5d8b24ad126 (diff)
downloadports-951c257ea3655de6e80c26a36c18c69ee8047ea8.tar.gz
ports-951c257ea3655de6e80c26a36c18c69ee8047ea8.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cairo/Makefile16
-rw-r--r--graphics/cairo/distinfo6
-rw-r--r--graphics/cairo/pkg-plist1
-rw-r--r--graphics/eog/Makefile5
-rw-r--r--graphics/eog/distinfo6
-rw-r--r--graphics/eog/files/patch-libeog_eog-image-list.c17
-rw-r--r--graphics/eog/pkg-plist42
-rw-r--r--graphics/evince/Makefile13
-rw-r--r--graphics/evince/distinfo6
-rw-r--r--graphics/evince/files/patch-CVE-2006-586422
-rw-r--r--graphics/evince/files/patch-backend_ps_ps-interpreter.c10
-rw-r--r--graphics/evince/files/patch-configure11
-rw-r--r--graphics/evince/pkg-plist157
-rw-r--r--graphics/p5-Cairo/Makefile4
-rw-r--r--graphics/p5-Cairo/distinfo6
-rw-r--r--graphics/py-cairo/Makefile7
-rw-r--r--graphics/py-cairo/distinfo6
17 files changed, 215 insertions, 120 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index b093b80148b0..d98cabccbcb0 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -3,14 +3,15 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/cairo/Makefile,v 1.45 2006/08/19 16:29:11 marcus Exp $
+# $MCom: ports/graphics/cairo/Makefile,v 1.56 2007/03/06 13:39:18 ahze Exp $
#
PORTNAME= cairo
-PORTVERSION= 1.2.6
-PORTREVISION?= 1
+PORTVERSION= 1.4.0
+PORTREVISION?= 0
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
+#MASTER_SITES= http://cairographics.org/snapshots/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Vector graphics library with cross-device output support
@@ -53,15 +54,10 @@ PLIST_SUB+= X11=""
.endif
post-patch:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
- ${WRKSRC}/src/*.* \
- ${WRKSRC}/pixman/src/*.*
-.endif
- @${REINPLACE_CMD} -e 's|-lcairo|-lcairo ${PTHREAD_LIBS}|' \
- ${WRKSRC}/src/*.pc.in
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/test/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lcairo|-lcairo ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/src/*.pc.in
@${REINPLACE_CMD} -e 's|src test doc|src doc|; \
s|@CAIRO_HAS_PNG_FUNCTIONS_TRUE@am__append_1 = test||' \
${WRKSRC}/Makefile.in
diff --git a/graphics/cairo/distinfo b/graphics/cairo/distinfo
index 560d0cf0cd36..e13c5200d1c9 100644
--- a/graphics/cairo/distinfo
+++ b/graphics/cairo/distinfo
@@ -1,3 +1,3 @@
-MD5 (cairo-1.2.6.tar.gz) = 487b3d7515752fe57f780d0fd707b01a
-SHA256 (cairo-1.2.6.tar.gz) = 7d36449c9a05c2c9b44248b10e9f82f0bca99f30e24848435e65aca77c28b3f9
-SIZE (cairo-1.2.6.tar.gz) = 2973689
+MD5 (cairo-1.4.0.tar.gz) = b0882df4621bcf5b69f024b9475f8d4e
+SHA256 (cairo-1.4.0.tar.gz) = 583f9ae2c9b7d2ef33cfbd194148e71a335dafc226e13e213f07ff2dc398bb47
+SIZE (cairo-1.4.0.tar.gz) = 3067230
diff --git a/graphics/cairo/pkg-plist b/graphics/cairo/pkg-plist
index 39be152857f9..c81b6e936df0 100644
--- a/graphics/cairo/pkg-plist
+++ b/graphics/cairo/pkg-plist
@@ -1,3 +1,4 @@
+include/cairo/cairo-deprecated.h
include/cairo/cairo-features.h
include/cairo/cairo-ft.h
%%GLITZ%%include/cairo/cairo-glitz.h
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
index d207071e1789..93a0f2da69f4 100644
--- a/graphics/eog/Makefile
+++ b/graphics/eog/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/graphics/eog/Makefile,v 1.4 2006/10/21 18:34:14 mezz Exp $
+# $MCom: ports/graphics/eog/Makefile,v 1.51 2007/03/13 00:48:55 mezz Exp $
#
PORTNAME= eog
-PORTVERSION= 2.16.3
+PORTVERSION= 2.18.0.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui \
librsvg2 desktopfileutils gnomedesktop
+INSTALLS_ICONS= yes
USE_GETTEXT= yes
USE_XLIB= yes
INSTALLS_OMF= yes
diff --git a/graphics/eog/distinfo b/graphics/eog/distinfo
index b35494eb2e04..6b68e48b77ba 100644
--- a/graphics/eog/distinfo
+++ b/graphics/eog/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/eog-2.16.3.tar.bz2) = 82468185d766b9676d7f06c124939f9d
-SHA256 (gnome2/eog-2.16.3.tar.bz2) = 81fd0962414fa5af71c38cd1cfb1753b12fafdd42111679813a7294eb5a0bdcb
-SIZE (gnome2/eog-2.16.3.tar.bz2) = 1071413
+MD5 (gnome2/eog-2.18.0.1.tar.bz2) = 32f4cd4cd3108522eccf0b8fd85c8bbd
+SHA256 (gnome2/eog-2.18.0.1.tar.bz2) = 9c18c512d7da540e8c96059f00af8e309c5ac6322de168f54f09c0451f59ec9e
+SIZE (gnome2/eog-2.18.0.1.tar.bz2) = 1235965
diff --git a/graphics/eog/files/patch-libeog_eog-image-list.c b/graphics/eog/files/patch-libeog_eog-image-list.c
deleted file mode 100644
index 609cd0469a4e..000000000000
--- a/graphics/eog/files/patch-libeog_eog-image-list.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- libeog/eog-image-list.c.orig Thu Aug 25 14:57:02 2005
-+++ libeog/eog-image-list.c Thu Aug 25 14:57:46 2005
-@@ -450,12 +450,13 @@
- case GNOME_VFS_MONITOR_EVENT_CREATED:
-
- if (list && list->priv) {
-+ gchar *str;
- node = list->priv->store;
-
- while (node != NULL && !found) {
-
- uri = eog_image_get_uri(node->data);
-- gchar *str = gnome_vfs_uri_to_string
-+ str = gnome_vfs_uri_to_string
- (uri, GNOME_VFS_URI_HIDE_NONE);
- found = (strcmp (str, info_uri)==0)?TRUE:FALSE;
- g_free (str);
diff --git a/graphics/eog/pkg-plist b/graphics/eog/pkg-plist
index ee244189d2f2..08a99fc188c6 100644
--- a/graphics/eog/pkg-plist
+++ b/graphics/eog/pkg-plist
@@ -7,8 +7,11 @@ share/gnome/help/eog/C/figures/eog_save_as_window.png
share/gnome/help/eog/C/figures/eog_start_window.png
share/gnome/help/eog/C/legal.xml
share/gnome/help/eog/de/eog.xml
+share/gnome/help/eog/de/figures/eog_save_as_window.png
share/gnome/help/eog/de/figures/eog_start_window.png
-share/gnome/help/eog/de/legal.xml
+share/gnome/help/eog/en_GB/eog.xml
+share/gnome/help/eog/en_GB/figures/eog_save_as_window.png
+share/gnome/help/eog/en_GB/figures/eog_start_window.png
share/gnome/help/eog/es/eog.xml
share/gnome/help/eog/es/figures/eog_save_as_window.png
share/gnome/help/eog/es/figures/eog_start_window.png
@@ -27,6 +30,15 @@ share/gnome/help/eog/ja/legal.xml
share/gnome/help/eog/ko/eog.xml
share/gnome/help/eog/ko/figures/eog_start_window.png
share/gnome/help/eog/ko/legal.xml
+share/gnome/help/eog/pa/eog.xml
+share/gnome/help/eog/pa/figures/eog_save_as_window.png
+share/gnome/help/eog/pa/figures/eog_start_window.png
+share/gnome/help/eog/pt_BR/eog.xml
+share/gnome/help/eog/pt_BR/figures/eog_save_as_window.png
+share/gnome/help/eog/pt_BR/figures/eog_start_window.png
+share/gnome/help/eog/ru/eog.xml
+share/gnome/help/eog/ru/figures/eog_save_as_window.png
+share/gnome/help/eog/ru/figures/eog_start_window.png
share/gnome/help/eog/sv/eog.xml
share/gnome/help/eog/sv/figures/eog_save_as_window.png
share/gnome/help/eog/sv/figures/eog_start_window.png
@@ -41,27 +53,26 @@ share/gnome/help/eog/zh_TW/figures/eog_start_window.png
share/gnome/help/eog/zh_TW/legal.xml
share/gnome/omf/eog/eog-C.omf
share/gnome/omf/eog/eog-de.omf
+share/gnome/omf/eog/eog-en_GB.omf
share/gnome/omf/eog/eog-es.omf
share/gnome/omf/eog/eog-eu.omf
share/gnome/omf/eog/eog-fr.omf
share/gnome/omf/eog/eog-it.omf
share/gnome/omf/eog/eog-ja.omf
share/gnome/omf/eog/eog-ko.omf
+share/gnome/omf/eog/eog-pa.omf
+share/gnome/omf/eog/eog-pt_BR.omf
+share/gnome/omf/eog/eog-ru.omf
share/gnome/omf/eog/eog-sv.omf
share/gnome/omf/eog/eog-uk.omf
share/gnome/omf/eog/eog-zh_CN.omf
share/gnome/omf/eog/eog-zh_TW.omf
-share/gnome/pixmaps/eog/down-right.png
-share/gnome/pixmaps/eog/loading.png
-share/gnome/pixmaps/eog/orient-horizontal.png
-share/gnome/pixmaps/eog/orient-vertical.png
-share/gnome/pixmaps/eog/right-down.png
-share/gnome/pixmaps/eog/stock-flip-horizontal-16.png
-share/gnome/pixmaps/eog/stock-flip-vertical-16.png
-share/gnome/pixmaps/eog/stock-rotate-180-16.png
-share/gnome/pixmaps/eog/stock-rotate-270-16.png
-share/gnome/pixmaps/eog/stock-rotate-90-16.png
share/gnome/pixmaps/gnome-eog.png
+share/icons/hicolor/16x16/apps/eog.png
+share/icons/hicolor/22x22/apps/eog.png
+share/icons/hicolor/24x24/apps/eog.png
+share/icons/hicolor/32x32/apps/eog.png
+share/icons/hicolor/scalable/apps/eog.svg
share/locale/af/LC_MESSAGES/eog.mo
share/locale/am/LC_MESSAGES/eog.mo
share/locale/ar/LC_MESSAGES/eog.mo
@@ -140,7 +151,6 @@ share/locale/zh_CN/LC_MESSAGES/eog.mo
share/locale/zh_HK/LC_MESSAGES/eog.mo
share/locale/zh_TW/LC_MESSAGES/eog.mo
share/locale/zu/LC_MESSAGES/eog.mo
-@dirrm share/gnome/pixmaps/eog
@dirrm share/gnome/omf/eog
@dirrm share/gnome/help/eog/zh_TW/figures
@dirrm share/gnome/help/eog/zh_TW
@@ -150,6 +160,12 @@ share/locale/zu/LC_MESSAGES/eog.mo
@dirrm share/gnome/help/eog/uk
@dirrm share/gnome/help/eog/sv/figures
@dirrm share/gnome/help/eog/sv
+@dirrm share/gnome/help/eog/ru/figures
+@dirrm share/gnome/help/eog/ru
+@dirrm share/gnome/help/eog/pt_BR/figures
+@dirrm share/gnome/help/eog/pt_BR
+@dirrm share/gnome/help/eog/pa/figures
+@dirrm share/gnome/help/eog/pa
@dirrm share/gnome/help/eog/ko/figures
@dirrm share/gnome/help/eog/ko
@dirrm share/gnome/help/eog/ja/figures
@@ -162,6 +178,8 @@ share/locale/zu/LC_MESSAGES/eog.mo
@dirrm share/gnome/help/eog/eu
@dirrm share/gnome/help/eog/es/figures
@dirrm share/gnome/help/eog/es
+@dirrm share/gnome/help/eog/en_GB/figures
+@dirrm share/gnome/help/eog/en_GB
@dirrm share/gnome/help/eog/de/figures
@dirrm share/gnome/help/eog/de
@dirrm share/gnome/help/eog/C/figures
diff --git a/graphics/evince/Makefile b/graphics/evince/Makefile
index 04800b48a94c..07735e345ad2 100644
--- a/graphics/evince/Makefile
+++ b/graphics/evince/Makefile
@@ -3,12 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/evince/Makefile,v 1.58 2006/10/10 02:27:26 ahze Exp $
+# $MCom: ports/graphics/evince/Makefile,v 1.64 2007/03/13 12:00:09 ahze Exp $
#
PORTNAME= evince
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= graphics print gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -34,6 +33,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
GCONF_SCHEMAS= evince.schemas evince-thumbnailer.schemas
+MAN1= evince.1
+
OPTIONS= DVI "Enable DVI viewer support" off \
T1LIB "Enable T1LIB for TYPE1 fonts to DVI (Enables DVI)" off \
NAUTILUS "Enable Nautilus plugin" on \
@@ -104,10 +105,8 @@ RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar \
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lt1lib|-lt1 -lm| ; \
- s|execinfo.h|#|g' \
- ${WRKSRC}/configure \
- ${WRKSRC}/dvi/mdvi-lib/Makefile.in
+ @${REINPLACE_CMD} -e 's|execinfo.h|#|g' \
+ ${WRKSRC}/configure
post-install:
@-update-desktop-database
diff --git a/graphics/evince/distinfo b/graphics/evince/distinfo
index f80ff610751a..6928356b79af 100644
--- a/graphics/evince/distinfo
+++ b/graphics/evince/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/evince-0.6.1.tar.bz2) = 55a1d4af3cac209c7cfbe83b7ffcee1d
-SHA256 (gnome2/evince-0.6.1.tar.bz2) = ee72f48ec0c76a8f44d8a6aed6759d43a147a9d5bb2b15f06460c4d6ef86025e
-SIZE (gnome2/evince-0.6.1.tar.bz2) = 1212271
+MD5 (gnome2/evince-0.8.0.tar.bz2) = b4f7b154535c05ca77a23be193fc458d
+SHA256 (gnome2/evince-0.8.0.tar.bz2) = eaed6371b1909a8cbab91f7e40c710b251e7adbb2a88174f12b96e26e132a8df
+SIZE (gnome2/evince-0.8.0.tar.bz2) = 1460387
diff --git a/graphics/evince/files/patch-CVE-2006-5864 b/graphics/evince/files/patch-CVE-2006-5864
deleted file mode 100644
index 2e3931054b4d..000000000000
--- a/graphics/evince/files/patch-CVE-2006-5864
+++ /dev/null
@@ -1,22 +0,0 @@
---- ps/ps.c.orig Fri Jan 6 21:03:44 2006
-+++ ps/ps.c Thu Dec 14 10:11:35 2006
-@@ -1231,7 +1231,8 @@
- int level = 0;
- quoted = 1;
- line++;
-- while(*line && !(*line == ')' && level == 0)) {
-+ while(*line && !(*line == ')' && level == 0)
-+ && (cp - text) < PSLINELENGTH - 1) {
- if(*line == '\\') {
- if(*(line + 1) == 'n') {
- *cp++ = '\n';
-@@ -1302,7 +1303,8 @@
- }
- }
- else {
-- while(*line && !(*line == ' ' || *line == '\t' || *line == '\n'))
-+ while(*line && !(*line == ' ' || *line == '\t' || *line == '\n')
-+ && (cp - text) < PSLINELENGTH - 1)
- *cp++ = *line++;
- }
- *cp = '\0';
diff --git a/graphics/evince/files/patch-backend_ps_ps-interpreter.c b/graphics/evince/files/patch-backend_ps_ps-interpreter.c
new file mode 100644
index 000000000000..9cd98bbefae7
--- /dev/null
+++ b/graphics/evince/files/patch-backend_ps_ps-interpreter.c
@@ -0,0 +1,10 @@
+--- backend/ps/ps-interpreter.c.orig Tue Mar 13 07:00:12 2007
++++ backend/ps/ps-interpreter.c Tue Mar 13 07:00:21 2007
+@@ -29,6 +29,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <sys/wait.h>
++#include <signal.h>
+ #include <errno.h>
+
+ #include "ps-interpreter.h"
diff --git a/graphics/evince/files/patch-configure b/graphics/evince/files/patch-configure
new file mode 100644
index 000000000000..dc2323992061
--- /dev/null
+++ b/graphics/evince/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Dec 18 18:05:50 2006
++++ configure Mon Dec 18 18:06:30 2006
+@@ -25315,7 +25315,7 @@ else
+ echo "${ECHO_T}yes" >&6
+ enable_cairo_pdf=yes
+ fi
+- if test x$enable_cairo_pdf == xyes; then
++ if test x$enable_cairo_pdf = xyes; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_CAIRO_PDF 1
diff --git a/graphics/evince/pkg-plist b/graphics/evince/pkg-plist
index 06e0564df2b5..dfb1c85b7ef9 100644
--- a/graphics/evince/pkg-plist
+++ b/graphics/evince/pkg-plist
@@ -3,19 +3,98 @@ bin/evince-thumbnailer
%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.a
%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.la
%%NAUTILUS%%lib/nautilus/extensions-1.0/libevince-properties-page.so
+%%DOCSDIR%%/EvAttachment.html
+%%DOCSDIR%%/EvJobPrint.html
+%%DOCSDIR%%/EvNavigationAction.html
+%%DOCSDIR%%/EvNavigationActionWidget.html
+%%DOCSDIR%%/EvPageAction.html
+%%DOCSDIR%%/EvPageActionWidget.html
+%%DOCSDIR%%/EvWindow.html
+%%DOCSDIR%%/evince-EvHistory.html
+%%DOCSDIR%%/evince-EvImage.html
+%%DOCSDIR%%/evince-EvPasswordDialog.html
+%%DOCSDIR%%/evince-EvPasswordView.html
+%%DOCSDIR%%/evince-EvRenderContext.html
+%%DOCSDIR%%/evince-EvSidebar.html
+%%DOCSDIR%%/evince-EvSidebarAttachments.html
+%%DOCSDIR%%/evince-EvSidebarLinks.html
+%%DOCSDIR%%/evince-EvSidebarThumbnails.html
+%%DOCSDIR%%/evince-EvTooltip.html
+%%DOCSDIR%%/evince-ev-async-renderer.html
+%%DOCSDIR%%/evince-ev-document-factory.html
+%%DOCSDIR%%/evince-ev-document-find.html
+%%DOCSDIR%%/evince-ev-document-fonts.html
+%%DOCSDIR%%/evince-ev-document-images.html
+%%DOCSDIR%%/evince-ev-document-info.html
+%%DOCSDIR%%/evince-ev-document-links.html
+%%DOCSDIR%%/evince-ev-document-misc.html
+%%DOCSDIR%%/evince-ev-document-security.html
+%%DOCSDIR%%/evince-ev-document-thumbnails.html
+%%DOCSDIR%%/evince-ev-document-transition.html
+%%DOCSDIR%%/evince-ev-document.html
+%%DOCSDIR%%/evince-ev-file-exporter.html
+%%DOCSDIR%%/evince-ev-file-helpers.html
+%%DOCSDIR%%/evince-ev-job-queue.html
+%%DOCSDIR%%/evince-ev-link-action.html
+%%DOCSDIR%%/evince-ev-link-dest.html
+%%DOCSDIR%%/evince-ev-link.html
+%%DOCSDIR%%/evince-ev-metadata-manager.html
+%%DOCSDIR%%/evince-ev-page-cache.html
+%%DOCSDIR%%/evince-ev-pixbuf-cache.html
+%%DOCSDIR%%/evince-ev-print-job.html
+%%DOCSDIR%%/evince-ev-properties-dialog.html
+%%DOCSDIR%%/evince-ev-properties-fonts.html
+%%DOCSDIR%%/evince-ev-selection.html
+%%DOCSDIR%%/evince-ev-sidebar-page.html
+%%DOCSDIR%%/evince-ev-stock-icons.html
+%%DOCSDIR%%/evince-ev-utils.html
+%%DOCSDIR%%/evince-ev-view-accessible.html
+%%DOCSDIR%%/evince-ev-view.html
+%%DOCSDIR%%/evince-ev-window-title.html
+%%DOCSDIR%%/evince.devhelp
+%%DOCSDIR%%/evince.devhelp2
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/ix01.html
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/pt01.html
+%%DOCSDIR%%/pt02.html
+%%DOCSDIR%%/pt03.html
+%%DOCSDIR%%/pt04.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
share/gnome/applications/evince.desktop
share/gnome/evince/evince-password.glade
+share/gnome/evince/evince-preview-toolbar.xml
share/gnome/evince/evince-properties.glade
share/gnome/evince/evince-toolbar.xml
share/gnome/evince/evince-ui.xml
share/gnome/evince/hand-open.png
+share/gnome/evince/icons/hicolor/16x16/actions/view-page-continuous.png
+share/gnome/evince/icons/hicolor/16x16/actions/view-page-facing.png
+share/gnome/evince/icons/hicolor/16x16/actions/zoom-fit-page.png
+share/gnome/evince/icons/hicolor/16x16/actions/zoom-fit-width.png
+share/gnome/evince/icons/hicolor/22x22/actions/view-page-continuous.png
+share/gnome/evince/icons/hicolor/22x22/actions/view-page-facing.png
+share/gnome/evince/icons/hicolor/22x22/actions/zoom-fit-page.png
+share/gnome/evince/icons/hicolor/22x22/actions/zoom-fit-width.png
+share/gnome/evince/icons/hicolor/24x24/actions/view-page-continuous.png
+share/gnome/evince/icons/hicolor/24x24/actions/view-page-facing.png
+share/gnome/evince/icons/hicolor/24x24/actions/zoom-fit-page.png
+share/gnome/evince/icons/hicolor/24x24/actions/zoom-fit-width.png
share/gnome/help/evince/C/evince.xml
share/gnome/help/evince/C/figures/evince_start_window.png
share/gnome/help/evince/C/legal.xml
share/gnome/help/evince/bg/evince.xml
share/gnome/help/evince/bg/figures/evince_start_window.png
+share/gnome/help/evince/ca/evince.xml
+share/gnome/help/evince/ca/figures/evince_start_window.png
share/gnome/help/evince/el/evince.xml
share/gnome/help/evince/el/figures/evince_start_window.png
+share/gnome/help/evince/en_GB/evince.xml
+share/gnome/help/evince/en_GB/figures/evince_start_window.png
share/gnome/help/evince/es/evince.xml
share/gnome/help/evince/es/figures/evince_start_window.png
share/gnome/help/evince/fi/evince.xml
@@ -36,7 +115,9 @@ share/gnome/help/evince/uk/evince.xml
share/gnome/help/evince/uk/figures/evince_start_window.png
share/gnome/omf/evince/evince-C.omf
share/gnome/omf/evince/evince-bg.omf
+share/gnome/omf/evince/evince-ca.omf
share/gnome/omf/evince/evince-el.omf
+share/gnome/omf/evince/evince-en_GB.omf
share/gnome/omf/evince/evince-es.omf
share/gnome/omf/evince/evince-fi.omf
share/gnome/omf/evince/evince-fr.omf
@@ -48,8 +129,10 @@ share/gnome/omf/evince/evince-sv.omf
share/gnome/omf/evince/evince-uk.omf
share/icons/hicolor/16x16/apps/evince.png
share/icons/hicolor/22x22/apps/evince.png
+share/icons/hicolor/24x24/apps/evince.png
share/icons/hicolor/48x48/apps/evince.png
share/icons/hicolor/scalable/apps/evince.svg
+share/locale/ar/LC_MESSAGES/evince.mo
share/locale/be/LC_MESSAGES/evince.mo
share/locale/bg/LC_MESSAGES/evince.mo
share/locale/bn/LC_MESSAGES/evince.mo
@@ -83,6 +166,7 @@ share/locale/ko/LC_MESSAGES/evince.mo
share/locale/ku/LC_MESSAGES/evince.mo
share/locale/lt/LC_MESSAGES/evince.mo
share/locale/lv/LC_MESSAGES/evince.mo
+share/locale/mg/LC_MESSAGES/evince.mo
share/locale/mk/LC_MESSAGES/evince.mo
share/locale/ml/LC_MESSAGES/evince.mo
share/locale/mr/LC_MESSAGES/evince.mo
@@ -113,35 +197,6 @@ share/locale/wa/LC_MESSAGES/evince.mo
share/locale/zh_CN/LC_MESSAGES/evince.mo
share/locale/zh_HK/LC_MESSAGES/evince.mo
share/locale/zh_TW/LC_MESSAGES/evince.mo
-@dirrm share/gnome/omf/evince
-@dirrm share/gnome/help/evince/uk/figures
-@dirrm share/gnome/help/evince/uk
-@dirrm share/gnome/help/evince/sv/figures
-@dirrm share/gnome/help/evince/sv
-@dirrm share/gnome/help/evince/sr/figures
-@dirrm share/gnome/help/evince/sr
-@dirrm share/gnome/help/evince/ru/figures
-@dirrm share/gnome/help/evince/ru
-@dirrm share/gnome/help/evince/nl/figures
-@dirrm share/gnome/help/evince/nl
-@dirrm share/gnome/help/evince/it/figures
-@dirrm share/gnome/help/evince/it
-@dirrm share/gnome/help/evince/fr/figures
-@dirrm share/gnome/help/evince/fr
-@dirrm share/gnome/help/evince/fi/figures
-@dirrm share/gnome/help/evince/fi
-@dirrm share/gnome/help/evince/es/figures
-@dirrm share/gnome/help/evince/es
-@dirrm share/gnome/help/evince/el/figures
-@dirrm share/gnome/help/evince/el
-@dirrm share/gnome/help/evince/bg/figures
-@dirrm share/gnome/help/evince/bg
-@dirrm share/gnome/help/evince/C/figures
-@dirrm share/gnome/help/evince/C
-@dirrm share/gnome/help/evince
-@dirrm share/gnome/evince
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || true
@dirrmtry share/locale/zh_TW/LC_MESSAGES
@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@@ -170,6 +225,8 @@ share/locale/zh_TW/LC_MESSAGES/evince.mo
@dirrmtry share/locale/ne
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
@dirrmtry share/locale/ko/LC_MESSAGES
@@ -190,3 +247,45 @@ share/locale/zh_TW/LC_MESSAGES/evince.mo
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be/LC_MESSAGES
@dirrmtry share/locale/be
+@dirrm share/gnome/omf/evince
+@dirrm share/gnome/help/evince/uk/figures
+@dirrm share/gnome/help/evince/uk
+@dirrm share/gnome/help/evince/sv/figures
+@dirrm share/gnome/help/evince/sv
+@dirrm share/gnome/help/evince/sr/figures
+@dirrm share/gnome/help/evince/sr
+@dirrm share/gnome/help/evince/ru/figures
+@dirrm share/gnome/help/evince/ru
+@dirrm share/gnome/help/evince/nl/figures
+@dirrm share/gnome/help/evince/nl
+@dirrm share/gnome/help/evince/it/figures
+@dirrm share/gnome/help/evince/it
+@dirrm share/gnome/help/evince/fr/figures
+@dirrm share/gnome/help/evince/fr
+@dirrm share/gnome/help/evince/fi/figures
+@dirrm share/gnome/help/evince/fi
+@dirrm share/gnome/help/evince/es/figures
+@dirrm share/gnome/help/evince/es
+@dirrm share/gnome/help/evince/en_GB/figures
+@dirrm share/gnome/help/evince/en_GB
+@dirrm share/gnome/help/evince/el/figures
+@dirrm share/gnome/help/evince/el
+@dirrm share/gnome/help/evince/ca/figures
+@dirrm share/gnome/help/evince/ca
+@dirrm share/gnome/help/evince/bg/figures
+@dirrm share/gnome/help/evince/bg
+@dirrm share/gnome/help/evince/C/figures
+@dirrm share/gnome/help/evince/C
+@dirrm share/gnome/help/evince
+@dirrm share/gnome/evince/icons/hicolor/24x24/actions
+@dirrm share/gnome/evince/icons/hicolor/24x24
+@dirrm share/gnome/evince/icons/hicolor/22x22/actions
+@dirrm share/gnome/evince/icons/hicolor/22x22
+@dirrm share/gnome/evince/icons/hicolor/16x16/actions
+@dirrm share/gnome/evince/icons/hicolor/16x16
+@dirrm share/gnome/evince/icons/hicolor
+@dirrm share/gnome/evince/icons
+@dirrm share/gnome/evince
+@dirrm %%DOCSDIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/graphics/p5-Cairo/Makefile b/graphics/p5-Cairo/Makefile
index 1efcb49f3c66..5f4a1e212439 100644
--- a/graphics/p5-Cairo/Makefile
+++ b/graphics/p5-Cairo/Makefile
@@ -3,11 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/p5-Cairo/Makefile,v 1.5 2006/09/06 22:53:39 ahze Exp $
+# $MCom: ports/graphics/p5-Cairo/Makefile,v 1.8 2007/02/16 18:14:25 mezz Exp $
#
PORTNAME= Cairo
-PORTVERSION= 1.023
+PORTVERSION= 1.030
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gtk2-perl
diff --git a/graphics/p5-Cairo/distinfo b/graphics/p5-Cairo/distinfo
index 11eabbf01d41..55033bd3d361 100644
--- a/graphics/p5-Cairo/distinfo
+++ b/graphics/p5-Cairo/distinfo
@@ -1,3 +1,3 @@
-MD5 (Cairo-1.023.tar.gz) = 0c5a1ef1c49ab3c508f04a8b6321cb74
-SHA256 (Cairo-1.023.tar.gz) = c66e196b81f7698d6fb8eb7a8244d279f02c91195b71ccfa6c5b0b8ee9fb8e28
-SIZE (Cairo-1.023.tar.gz) = 43737
+MD5 (Cairo-1.030.tar.gz) = 6f8f8f0d200b6fc942452b4d1566a0eb
+SHA256 (Cairo-1.030.tar.gz) = bc26662ba2fffa85dc038d9909f0df3efbf09494cdd2e35df1b52bf5fb5dae86
+SIZE (Cairo-1.030.tar.gz) = 45459
diff --git a/graphics/py-cairo/Makefile b/graphics/py-cairo/Makefile
index 3e006778676c..35acb785eac4 100644
--- a/graphics/py-cairo/Makefile
+++ b/graphics/py-cairo/Makefile
@@ -3,14 +3,13 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/py-cairo/Makefile,v 1.20 2006/09/06 22:05:06 marcus Exp $
+# $MCom: ports/graphics/py-cairo/Makefile,v 1.22 2007/03/14 21:38:08 ahze Exp $
#
PORTNAME= cairo
-PORTVERSION= 1.2.6
+PORTVERSION= 1.4.0
CATEGORIES= graphics python
-MASTER_SITES= http://cairographics.org/releases/ \
- http://zeqadious.homelinux.net/zenwalk/buildscripts/official/pycairo/
+MASTER_SITES= http://cairographics.org/releases/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py${PORTNAME}-${PORTVERSION}
diff --git a/graphics/py-cairo/distinfo b/graphics/py-cairo/distinfo
index 5fbc8da5aa22..14e8d750ec13 100644
--- a/graphics/py-cairo/distinfo
+++ b/graphics/py-cairo/distinfo
@@ -1,3 +1,3 @@
-MD5 (pycairo-1.2.6.tar.gz) = 166b04c4800c01aba1a6c8b14e87e0bc
-SHA256 (pycairo-1.2.6.tar.gz) = 28f01729946721bec2361480f2802da5015e1271ce5cdbe6ff97a1442a19c595
-SIZE (pycairo-1.2.6.tar.gz) = 480714
+MD5 (pycairo-1.4.0.tar.gz) = e26e77919b606113f565d70036c1f504
+SHA256 (pycairo-1.4.0.tar.gz) = 9212afffee727e39ae99406b5a59ab3248556bcfebfae24d8278313678147e32
+SIZE (pycairo-1.4.0.tar.gz) = 479455